DDNS HTTP Update, Configuration and Troubleshooting

Unanswered Question
Jun 13th, 2014
User Badges:

G'day Everyone,

I am kind of struggling here and really don't know where to turn to next and I was hoping if I threw my question amongst all you Cisco guru's you might be able to point me in the right direction. My apologies in advance if this is in the wrong group.

The problem I am having is with DDNS (Dynamic DNS). I have read the configuration guides and they all seemed pretty straight forward. My problem is that my DDNS configuration just doesn't update the 3rd party service I am trying to configure. No matter which service I try to use (OpenDNS, NoIP, DnsOMatic, etc..) they all fail with HTTPDNSUPD: Call returned Connection time out. 

I am hoping you all might be able to point out the glaring mistake I have made with my config as I have typed it and retyped it and still cannot get it working. I am trying to get this set up on my home Cisco1841 (C1841-ADVENTERPRISEK9-M), Version 15.1(4)M8.

Here is my configuration that I have tried getting going with a 3rd party provider called NoIp.com. The username is formatted as an email address and I have tried using both [email protected] and email%40address.com with no luck.

 


Cisco_GW#sh run
Building configuration...

Current configuration : 6526 bytes
!
! Last configuration change at 16:42:22 EST Fri Jun 13 2014
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cisco_GW
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
memory-size iomem 15
clock timezone EST 10 0
clock summer-time EST recurring 1 Sun Oct 2:00 1 Sun Apr 3:00
dot11 syslog
ip source-route
!
no ip dhcp use vrf connected
no ip dhcp conflict logging
ip dhcp excluded-address 192.168.1.1 192.168.1.200
ip dhcp excluded-address 192.168.1.235
!
ip dhcp pool DHCP_DEFAULT
 network 192.168.1.0 255.255.255.0
 domain-name home.Local
 dns-server 192.231.203.132 192.231.203.3
 default-router 192.168.1.1
 lease 0 12
!
ip cef
ip domain name home.local
ip name-server 192.231.203.132
ip name-server 192.231.203.3
ip ddns update method NOIP
 HTTP
  add http:\\[email protected]:password@dynupdate.no-ip.com/nic/update?hostname=<h>&myip=<a>
  remove http:\\[email protected]:password@dynupdate.no-ip.com/nic/update?hostname=<h>&myip=<a>
 interval maximum 2 0 0 0
 interval minimum 1 0 0 0
!
no ipv6 cef
!
multilink bundle-name authenticated
!
crypto pki token default removal timeout 0
!
license udi pid CISCO1841 sn FCZ1139115S
!
redundancy
!
ip ssh version 1
!
interface FastEthernet0/0
 description INTERNAL_NETWORK
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface ATM0/0/0
 no ip address
 no atm ilmi-keepalive
 pvc 8/35
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
!
interface Dialer0
 description TO_INTERNODE
 ip ddns update hostname home-gw.no-ip.org
 ip ddns update NOIP
 ip address negotiated
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname USERNAME
 ppp chap password 7 PASSWORD
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source list INTERNAL interface Dialer0 overload
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip access-list extended INTERNAL
 remark Allow Only Internal Network
 permit ip 192.168.1.0 0.0.0.255 any
!
dialer-list 1 protocol ip permit
!
control-plane
!
line con 0
line aux 0
line vty 0 4
 access-class INTERNAL in
 login
 transport input all
!
scheduler allocate 20000 1000
ntp source Dialer0
ntp server 192.231.203.132
end
!

Cisco_GW#clear inter dial 0
Cisco_GW#
.Jun 13 07:02:48.569: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down
.Jun 13 07:02:48.569: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di0
.Jun 13 07:02:48.569: DYNUPD: SWIF goingdown 'Virtual-Access2'
.Jun 13 07:02:48.585: DYNDNSUPD: Removing DNS mapping for home-gw.no-ip.org <=> 118.209.229.153
.Jun 13 07:02:48.585: HTTPDNS: Update remove called for home-gw.no-ip.org <=> 118.209.229.153
.Jun 13 07:02:48.585: HTTPDNSUPD: Session ID = 0x19
.Jun 13 07:02:48.585: HTTPDNSUPD: URL = 'http://[email protected]:password@dynupdate.no-ip.com/nic/update?hostname=home-gw.no-ip.org&myip=118.209.229.153'
.Jun 13 07:02:48.585: HTTPDNSUPD: Sending request
.Jun 13 07:02:48.589: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to down
.Jun 13 07:02:49.488: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
.Jun 13 07:02:49.488: %DIALER-6-BIND: Interface Vi2 bound to profile Di0
.Jun 13 07:02:51.648: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to up
.Jun 13 07:02:51.648: DYNUPD: SWIF comingup 'Virtual-Access2'
Jun 13 07:03:08.591: HTTPDNSUPD: Call returned Connection time out, update of home-gw.no-ip.org <=> 118.209.229.153 failed
Jun 13 07:03:08.591: DYNDNSUPD: Another update completed (outstanding=0, total=0)
Jun 13 07:03:08.591: HTTPDNSUPD: Clearing all session 25 info
.Jun 13 07:03:11.910: DYNDNSUPD: Adding DNS mapping for home-gw.no-ip.org <=> 118.209.208.42
.Jun 13 07:03:11.910: HTTPDNS: Update add called for home-gw.no-ip.org <=> 118.209.208.42
.Jun 13 07:03:11.910: HTTPDNSUPD: Session ID = 0x1A
.Jun 13 07:03:11.910: HTTPDNSUPD: URL = 'http://[email protected]:password@dynupdate.no-ip.com/nic/update?hostname=home-gw.no-ip.org&myip=118.209.208.42'
.Jun 13 07:03:11.910: HTTPDNSUPD: Sending request
.Jun 13 07:03:31.913: HTTPDNSUPD: Call returned Connection time out, update of home-gw.no-ip.org <=> 118.209.208.42 failed

.Jun 13 07:03:31.913: DYNDNSUPD: Another update completed (outstanding=0, total=0)
.Jun 13 07:03:31.913: HTTPDNSUPD: Clearing all session 26 info
Cisco_GW#
Cisco_GW#
Cisco_GW#ping dynupdate.no-ip.com
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.23.224.120, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 176/177/180 ms
Cisco_GW#
Cisco_GW#
Cisco_GW#u all
All possible debugging has been turned off
Cisco_GW#debug domain
Domain Name System debugging is on
Cisco_GW#clear inter dial 0
Cisco_GW#
Jun 13 07:11:23.370: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down
Jun 13 07:11:23.370: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di0
.Jun 13 07:11:23.514: search_nametype_index: dynupdate.no-ip.com
.Jun 13 07:11:23.514: search_nametype_index: found dynupdate.no-ip.com for dynupdate.no-ip.com
.Jun 13 07:11:23.518: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to down
.Jun 13 07:11:24.274: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
.Jun 13 07:11:24.274: %DIALER-6-BIND: Interface Vi2 bound to profile Di0
.Jun 13 07:11:26.418: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to up
.Jun 13 07:11:46.880: search_nametype_index: dynupdate.no-ip.com
.Jun 13 07:11:46.880: search_nametype_index: found dynupdate.no-ip.com for dynupdate.no-ip.com
Cisco_GW#
Cisco_GW#sh ip ddns update
Dynamic DNS Update on Dialer0:
  Update Method Name            Update Destination
  NOIP                          not available
Cisco_GW#

Pasting http:[email protected]:password@dynupdate.no-ip.com/nic/update?hostname=home-gw.no-ip.org&myip=118.209.208.42 into Google Chrome:
good 118.209.208.42

and updates the IP address of hostname home-gw.no-ip.org

If anyone can see any flaws in this config I would be so happy and appreciative. This has been driving me crazy for days now.

Many thanks in advance,

John

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion