IP Communicator ports

Unanswered Question
Jun 23rd, 2014
User Badges:

I am trying to set it up so that mobile users that connect over VPN can use the IP communicator software.  So far, if I am on WIFI at the office I can only get the software to register, but not make or receive calls.  If I am on another location's Internet, I can not get the software to register or make/receive calls.  Is this even possible, or am I do I need to allow a specific set of ports?  I ran a packet sniffer and have not seen any traffic that could indicate a blockage or potential traffic to my CUCM server.  TIA.

 

David

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jaime Valencia Mon, 06/23/2014 - 17:17
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    2011

Yes, you can use IPC over VPN, notes on VPN support are on the release notes.

If you can only register the IPC on your corporate wifi, I'd start by looking at connectivity issues, ACLs, firewalls, antivirus, etc. Then you can move to try it on VPN.

Make sure your VPN config has routing to your CUCM servers and to the ip phones you want to call.

David Lee Wed, 06/25/2014 - 11:39
User Badges:

Whats funny, is now I can get the communicator software to register.  It gets an extension that I assigned it.  If I call another extension, no one can hear me and I can't hear them even though I hear the phone ringing.  I have checked to make sure that there is no Firewall blocking communication and the issue still persists.  Its odd.  The only port I see activity on is 2000 for SCCP.  I'm at a loss here.  I even tried to force the program to use ports I designate for audio and I see nothing going over those ports. 

Brian Meade Wed, 06/25/2014 - 12:47
User Badges:
  • Silver, 250 points or more

Double click the "?" during an active call and see if the TX/RX packets are increasing.  Make sure your PC can ping the phone you're calling.

Suresh Hudda Wed, 06/25/2014 - 23:21
User Badges:
  • Gold, 750 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

Hi David,

You can try to take ethereal sniffer traces at each node in the path between CUCM and Laptop/CIPC and can check where rtp/udp packets are dropping and then you will get it to know exactly that where is the issue and what is blocking them.

 

Suresh

Manish Gogna Mon, 06/23/2014 - 17:18
User Badges:
  • Cisco Employee,

Hi David,

If the cipc is able to register then you need to open up ports for RTP ( UDD 16384-32767 ) as well as ports for SIP / sccp / h323 signaling for the established call depending upon the registration protocol for cipc as well as the protocols involved in call flow.

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/port/9_0_1/CUCM_...

HTH

Manish

Actions

This Discussion