×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Setting up VPN

Answered Question
Jun 29th, 2014
User Badges:

Dear all,

About two years ago I (finally) had vpn set up, but I had to nuke the setup a while back (to long ago to remember why).

My setup:

Cisco ASA-5505 on-board accelerator (revision 0x0)

Base license.

Cisco Adaptive Security Appliance Software Version 8.4(2)
Device Manager Version 6.4(5)

I have created a DMZ-zone and an inside and outside zone.

All servers are headless Linux-servers.

(I also recently had to re-create the servers because of a corrupted disk).

So the setup is as following:

One main linux-server also working as a virtualbox-host.

One dmz-www-server and one dmz-ftp-server.

I will be adding a linux-server for git and a few others.

My first goal is to be able to reach the main server with SSH. Secondly reaching other servers in the network.

I also like to use the open source cisco-vpn-client in Linux, and the cisco VPN client which I also use for connecting to other clients.

Here is my current configuration:

interface Ethernet0/0
 switchport access vlan 2
 speed 100
 duplex full
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5

 switchport access vlan 300
 speed 100
 duplex full
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address dhcp
!
interface Vlan300
 no forward interface Vlan1
 nameif dmz
 security-level 50
 ip address 192.168.2.1 255.255.255.0
!

ftp mode passive
clock timezone CEST 1
clock summer-time CEDT recurring
dns domain-lookup inside
dns domain-lookup outside
dns domain-lookup dmz
dns server-group DefaultDNS
 name-server 192.168.1.8
 name-server 193.75.75.75
 name-server 193.75.75.193
 name-server 8.8.8.8
 domain-name inside-sport.no
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object network obj_any
 subnet 0.0.0.0 0.0.0.0
object network inside-net
 subnet 192.168.1.0 255.255.255.0
object network dmz-webserver
 host 192.168.2.100
 description Web Server Host Object
object network dmz-ftpserver
 host 192.168.2.101
 description FTP Server Host Object

object network DMZ.net
 subnet 192.168.2.0 255.255.255.0
object service FTP
 service tcp source eq ftp
object service WWW
 service tcp source eq www
access-list outside_access_in extended permit tcp any host 192.168.2.101 eq ftp
access-list outside_access_in extended permit tcp any host 192.168.2.100 eq www
access-list inside_access_dmz extended permit tcp any object DMZ.net range 1 65535
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
nat (dmz,outside) source static dmz-webserver interface service WWW WWW
nat (dmz,outside) source static dmz-ftpserver interface service FTP FTP
!
object network obj_any
 nat (inside,outside) dynamic interface
object network inside-net

 nat (inside,outside) dynamic interface
object network DMZ.net
 nat (dmz,outside) dynamic interface
access-group outside_access_in in interface outside
access-group inside_access_dmz in interface dmz
route outside 0.0.0.0 0.0.0.0 173.194.32.34 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
aaa authentication ssh console LOCAL
aaa authentication enable console LOCAL
aaa authentication http console LOCAL
aaa authorization command LOCAL
aaa authorization exec authentication-server
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
crypto ca trustpoint _SmartCallHome_ServerCA
 crl configure
crypto ca certificate chain _SmartCallHome_ServerCA
 certificate ca 6ecc7aa5a7032009b8cebcf4e952d491
    308205ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130
    0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117
    30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b
    13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504
    0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72
    20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56
    65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043
    65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d31
    30303230 38303030 3030305a 170d3230 30323037 32333539 35395a30 81b5310b
    30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20
    496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65
    74776f72 6b313b30 39060355 040b1332 5465726d 73206f66 20757365 20617420
    68747470 733a2f2f 7777772e 76657269 7369676e 2e636f6d 2f727061 20286329
    3130312f 302d0603 55040313 26566572 69536967 6e20436c 61737320 33205365
    63757265 20536572 76657220 4341202d 20473330 82012230 0d06092a 864886f7
    0d010101 05000382 010f0030 82010a02 82010100 b187841f c20c45f5 bcab2597
    a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10
    9c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc
    7f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b

    15fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845
    63cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8
    18b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced
    4a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f
    81f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201
    db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868
    7474703a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101
    ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8
    45010717 03305630 2806082b 06010505 07020116 1c687474 70733a2f 2f777777
    2e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a
    1c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406
    03551d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973
    69676e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403
    02010630 6d06082b 06010505 07010c04 61305fa1 5da05b30 59305730 55160969
    6d616765 2f676966 3021301f 30070605 2b0e0302 1a04148f e5d31a86 ac8d8e6b
    c3cf806a d448182c 7b192e30 25162368 7474703a 2f2f6c6f 676f2e76 65726973
    69676e2e 636f6d2f 76736c6f 676f2e67 69663028 0603551d 11042130 1fa41d30
    1b311930 17060355 04031310 56657269 5369676e 4d504b49 2d322d36 301d0603
    551d0e04 1604140d 445c1653 44c1827e 1d20ab25 f40163d8 be79a530 1f060355
    1d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609
    2a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80
    4bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e
    b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a
    6decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc

    481d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16
    b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0
    5becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8
    6119b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 16de0c28
    6c2527b9 deb78458 c61f381e a4c4cb66
  quit
telnet timeout 5
ssh 192.168.1.0 255.255.255.0 inside
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 30
console timeout 0
management-access inside

dhcpd dns 192.168.1.1 193.75.75.75
dhcpd domain inside-sport.no
dhcpd auto_config outside
!
dhcpd address 192.168.1.20-192.168.1.49 inside
dhcpd dns 192.168.1.1 interface inside
dhcpd domain inside-sport.no interface inside
dhcpd enable inside
!
threat-detection basic-threat
threat-detection statistics access-list

no threat-detection statistics tcp-intercept
webvpn
username foofoo password foooo encrypted privilege 15
username bazbaz password baaar encrypted privilege 15
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny

  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ip-options
  inspect icmp
!
service-policy global_policy global
prompt hostname context
call-home reporting anonymous
Cryptochecksum:88cf7ca3aa1aa19ec0418f557cc0fedf

Correct Answer by Marius Gunnerud about 3 years 1 month ago

first of all I noticed this:

ip local pool client_pool 10.10.10.1-10.10.10.10 mask 255.255.255.248

That subnet mask will only include IPs in the range 10.10.10.1 to 10.10.10.7.  I suggest either changing the mask or the IP pool IP range.

As for the error you get use a subnet keyword instead

object network VPNUSERS
  subnet 10.10.10.0 255.255.255.248

What IP is your PC receiving from the DHCP server?

I also noticed you do not have dhcp enabled on the inside interface or is that a copy paste error?  dhcpd enable inside

could you also run a packet tracer on the ASA

packet-tracer input inside tcp 192.168.1.50 12345 4.2.2.2 80 detail

--

Please remember to select a correct answer and rate helpful posts

Correct Answer by Marius Gunnerud about 3 years 1 month ago

If you are just looking for a remote access VPN setup, you could do something like the following just change the names and IPs as needed:

ip local pool VPNPOOL 10.10.10.1-10.10.10.10

crypto ikev1 policy 5
 authentication pre-share
 encryption aes
 hash sha
 group 5

crypto ipsec ikev1 transform-set VPNSET esp-aes esp-sha-hmac

crypto dynamic-map DYNMAP 65535 set ikev1 transform-set VPNSET
crypto dynamic-map DYNMAP 65535 set reverse-route
crypto map VPNMAP 65535 ipsec-isakmp dynamic DYNMAP
crypto map VPNMAP interface outside

crypto ikev1 enable outside

tunnel-group VPNGROUP type remote-access
tunnel-group VPNGROUP ipsec-attributes
 ikev1 pre-shared-key PASSWORD

management-access inside

--

Please remember to select a correct answer and rate helpful posts

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
Marius Gunnerud Sun, 06/29/2014 - 03:11
User Badges:
  • Red, 2250 points or more
  • Cisco Designated VIP,

    2017 Firewalling

If you are just looking for a remote access VPN setup, you could do something like the following just change the names and IPs as needed:

ip local pool VPNPOOL 10.10.10.1-10.10.10.10

crypto ikev1 policy 5
 authentication pre-share
 encryption aes
 hash sha
 group 5

crypto ipsec ikev1 transform-set VPNSET esp-aes esp-sha-hmac

crypto dynamic-map DYNMAP 65535 set ikev1 transform-set VPNSET
crypto dynamic-map DYNMAP 65535 set reverse-route
crypto map VPNMAP 65535 ipsec-isakmp dynamic DYNMAP
crypto map VPNMAP interface outside

crypto ikev1 enable outside

tunnel-group VPNGROUP type remote-access
tunnel-group VPNGROUP ipsec-attributes
 ikev1 pre-shared-key PASSWORD

management-access inside

--

Please remember to select a correct answer and rate helpful posts

Trond Husoe Tue, 07/01/2014 - 00:25
User Badges:

Dear Magnus,

Thanks for the assistance,.

I ended up with this setup:

ip local pool VPNPOOL 10.10.10.1-10.10.10.10

access-list split_tunnel_acl standard permit 192.168.1.0 255.255.255.0

This part here is important. What it does, as far as I could understand, is that it routes/connects the network you come from through the tunnel (10.10.10.x) to the internal network (192.168.1.0).

object-group network obj_10.10.10.1_255
network-object 10.10.10.1 255.255.255.255

The above line must be changed to

object-group network obj_10.10.10.1_255 (just so you don't have to fix the nat-line below)

network-object 10.10.10.0 255.255.255.248
 

object-group network obj_192.168.1.0_24
network-object 192.168.1.0 255.255.255.0

nat (inside,outside) source static obj_192.168.1.0_24 obj_192.168.1.0_24 destination static obj_10.10.10.1_248 obj_10.10.10.1_248 no-proxy-arp route-lookup

crypto ipsec ikev1 transform-set set1 esp-3des esp-sha-hmac
crypto dynamic-map dyn_map 65535 set ikev1 transform-set set1
crypto map outside_map 65535 ipsec-isakmp dynamic dyn_map
crypto map outside_map interface outside

crypto ikev1 enable outside crypto ikev1 policy 65535
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400

group-policy ipsec_ra_policy internal
group-policy ipsec_ra_policy attributes
split-tunnel-policy tunnelspecified
split-tunnel-network-list value split_tunnel_acl

tunnel-group NAME-OF-VPN-TUNNEL type remote-access
tunnel-group NAME-OF-VPN-TUNNEL general-attributes
address-pool client_pool
default-group-policy ipsec_ra_policy
tunnel-group NAME-OF-VPN-TUNNEL ipsec-attributes
ikev1 pre-shared-key *****

management-access inside

---

This setup makes it possible for me to connect to the server at the office, and also run SSH to it.

I am giving you correct answer, as it pointed me in the right direction.

 

-- EDIT --

The green lines are edited because the initial setup only worked if you got the 10.10.10.1 address when connecting to the network over VPN.

 

Trond Husoe Tue, 07/01/2014 - 02:09
User Badges:

When coming into the office, any computer connecting to the network has no access to the internet. I have access to the servers in the network, but the computer connected (just recently) has no access outside.

the server has access, but I believe they have kept access because they have stayed online during the whole process.

Any suggestions on how to fix this is more than welcomed.

 

Marius Gunnerud Tue, 07/01/2014 - 02:13
User Badges:
  • Red, 2250 points or more
  • Cisco Designated VIP,

    2017 Firewalling

We would need to see the configuration of your ASA, also let us know the source IP which is having issues.

How many PC's are on the network?

This almost sounds like there is a NAT issue, do you have your dynamic NAT statements in place?

--

Please remember to select a correct answer and rate helpful posts

Trond Husoe Tue, 07/01/2014 - 02:25
User Badges:

Below is the current running configuration.

There are three laptops and two internal servers. Two dmz-servers.

(I also notice that I cannot get to the www-server in the dmz, but I have another thread for that issue)

hostname fw
domain-name inside-sport.no
enable password ******** encrypted
passwd ********** encrypted
names
!
interface Ethernet0/0
 switchport access vlan 2
 speed 100
 duplex full
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
 switchport access vlan 300

 speed 100
 duplex full
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address dhcp
!
interface Vlan300
 no forward interface Vlan1
 nameif dmz
 security-level 50
 ip address 192.168.2.1 255.255.255.0
!
ftp mode passive

clock timezone CEST 1
clock summer-time CEDT recurring
dns domain-lookup inside
dns domain-lookup outside
dns domain-lookup dmz
dns server-group DefaultDNS
 name-server 192.168.1.8
 name-server 193.75.75.75
 name-server 193.75.75.193
 name-server 8.8.8.8
 domain-name inside-sport.no
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object network obj_any
 subnet 0.0.0.0 0.0.0.0
object network inside-net
 subnet 192.168.1.0 255.255.255.0
object network dmz-webserver
 host 192.168.2.100
 description Web Server Host Object
object network dmz-ftpserver
 host 192.168.2.101
 description FTP Server Host Object
object network DMZ.net

 subnet 192.168.2.0 255.255.255.0
object service FTP
 service tcp source eq ftp
object service WWW
 service tcp source eq www
object network NETWORK_OBJ_192.168.1.0_24
 subnet 192.168.1.0 255.255.255.0
object-group network obj_10.10.10.0_16
 network-object 10.10.10.0 255.255.255.248
object-group network obj_192.168.1.0_24
 network-object 192.168.1.0 255.255.255.0
access-list outside_access_in extended permit tcp any host 192.168.2.101 eq ftp
access-list outside_access_in extended permit tcp any host 192.168.2.100 eq www
access-list inside_access_dmz extended permit tcp any object DMZ.net range 1 65535
access-list split_tunnel_acl standard permit 192.168.1.0 255.255.255.0
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
ip local pool client_pool 10.10.10.1-10.10.10.10 mask 255.255.255.248
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable

arp timeout 14400
nat (dmz,outside) source static dmz-webserver interface service WWW WWW
nat (dmz,outside) source static dmz-ftpserver interface service FTP FTP
nat (inside,outside) source static obj_192.168.1.0_24 obj_192.168.1.0_24 destination static obj_10.10.10.0_16 obj_10.10.10.0_16 no-proxy-arp route-lookup
nat (inside,outside) source static any any destination static NETWORK_OBJ_192.168.1.0_24 NETWORK_OBJ_192.168.1.0_24 no-proxy-arp route-lookup
!
object network obj_any
 nat (inside,outside) dynamic interface
object network inside-net
 nat (inside,outside) dynamic interface
access-group outside_access_in in interface outside
access-group inside_access_dmz in interface dmz
route outside 0.0.0.0 0.0.0.0 173.194.32.34 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
aaa authentication ssh console LOCAL
aaa authentication enable console LOCAL

aaa authentication http console LOCAL
aaa authorization command LOCAL
aaa authorization exec authentication-server
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
crypto ipsec ikev1 transform-set set1 esp-3des esp-sha-hmac
crypto dynamic-map dyn_map 65535 set ikev1 transform-set set1
crypto map outside_map 65535 ipsec-isakmp dynamic dyn_map
crypto map outside_map interface outside
crypto ca trustpoint _SmartCallHome_ServerCA
 crl configure
crypto ca certificate chain _SmartCallHome_ServerCA
 certificate ca 6ecc7aa5a7032009b8cebcf4e952d491

(dropping the rest of this long block. I believe it is related to the call home service for the cisco firewall)

quit
crypto ikev1 enable outside
crypto ikev1 policy 65535
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400

telnet timeout 5
ssh 192.168.1.0 255.255.255.0 inside
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 30
console timeout 0
management-access inside

dhcpd dns 192.168.1.1 193.75.75.75
dhcpd domain inside-sport.no
dhcpd auto_config outside
!
dhcpd address 192.168.1.50-192.168.1.79 inside
dhcpd dns 192.168.1.1 interface inside
dhcpd domain inside-sport.no interface inside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy ipsec_ra_policy internal
group-policy ipsec_ra_policy attributes
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value split_tunnel_acl
username foooo password ************* encrypted privilege 15

username trond password ************** encrypted privilege 15
tunnel-group VPN-INSIDE-SPORT type remote-access
tunnel-group VPN-INSIDE-SPORT general-attributes
 address-pool client_pool
 default-group-policy ipsec_ra_policy
tunnel-group VPN-INSIDE-SPORT ipsec-attributes
 ikev1 pre-shared-key *****
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp

  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ip-options
  inspect icmp
!
service-policy global_policy global
prompt hostname context
call-home reporting anonymous
Cryptochecksum:*********************************
: end

 

 

Marius Gunnerud Tue, 07/01/2014 - 02:32
User Badges:
  • Red, 2250 points or more
  • Cisco Designated VIP,

    2017 Firewalling

Ah ok so the users connecting to the VPN do not have internet access?

You need to do hairpinning. So you need add a NAT statement that translates the VPN IPs to the outside interface and permit intra interface traffic (which you already have configured).  somthing like the following:

same-security-traffic permit intra-interface

object network VPNUSERS
  range 10.10.10.1 10.10.10.10
  nat (outside,outside) dynamic interface

--

Please remember to select a correct answer and rate helpful posts

Trond Husoe Tue, 07/01/2014 - 02:40
User Badges:

When I access the system remotely with vpn I have access to the internet and also to all servers in the network.

And the servers have access to the internet. So everything seems just nice and dandy.

When I am at the office how ever, I cannot access the internet. I can access the servers and all computers in the network.

I can still add the VPNUSERS Network object. Seems like a good idea to have

same-security-traffic permit intra-interface <- is present already

When running this:

object network VPNUSERS

range 10.10.10.1 10.10.10.10

I get a message telling me this:

Addresses overlap with existing localpool range

 

Correct Answer
Marius Gunnerud Tue, 07/01/2014 - 03:24
User Badges:
  • Red, 2250 points or more
  • Cisco Designated VIP,

    2017 Firewalling

first of all I noticed this:

ip local pool client_pool 10.10.10.1-10.10.10.10 mask 255.255.255.248

That subnet mask will only include IPs in the range 10.10.10.1 to 10.10.10.7.  I suggest either changing the mask or the IP pool IP range.

As for the error you get use a subnet keyword instead

object network VPNUSERS
  subnet 10.10.10.0 255.255.255.248

What IP is your PC receiving from the DHCP server?

I also noticed you do not have dhcp enabled on the inside interface or is that a copy paste error?  dhcpd enable inside

could you also run a packet tracer on the ASA

packet-tracer input inside tcp 192.168.1.50 12345 4.2.2.2 80 detail

--

Please remember to select a correct answer and rate helpful posts

Trond Husoe Tue, 07/01/2014 - 03:59
User Badges:

Changed the VPNUSERS network object to use subnet instead. Added back the ip local pool client_pool

I then also added the dhcpd enable inside.

Output of packet-tracer command:

Phase: 1
Type: ACCESS-LIST
Subtype:
Result: ALLOW
Config:
Implicit Rule
Additional Information:
 Forward Flow based lookup yields rule:
 in  id=0xcb2e15a8, priority=1, domain=permit, deny=false
        hits=1380614, user_data=0x0, cs_id=0x0, l3_type=0x8
        src mac=0000.0000.0000, mask=0000.0000.0000
        dst mac=0000.0000.0000, mask=0100.0000.0000
        input_ifc=inside, output_ifc=any

Phase: 2
Type: ROUTE-LOOKUP
Subtype: input
Result: ALLOW
Config:
Additional Information:
in   0.0.0.0         0.0.0.0         outside

Phase: 3
Type: IP-OPTIONS
Subtype:
Result: ALLOW
Config:
Additional Information:
 Forward Flow based lookup yields rule:
 in  id=0xcb3453f0, priority=0, domain=inspect-ip-options, deny=true
        hits=23454, user_data=0x0, cs_id=0x0, reverse, flags=0x0, protocol=0
        src ip/id=0.0.0.0, mask=0.0.0.0, port=0
        dst ip/id=0.0.0.0, mask=0.0.0.0, port=0, dscp=0x0
        input_ifc=inside, output_ifc=any

Phase: 4
Type: NAT
Subtype:
Result: ALLOW
Config:
object network inside-net
 nat (inside,outside) dynamic interface
Additional Information:
Dynamic translate 192.168.1.50/12345 to 193.91.175.82/6856
 Forward Flow based lookup yields rule:
 in  id=0xcbe94388, priority=6, domain=nat, deny=false
        hits=22984, user_data=0xcb3d84d0, cs_id=0x0, use_real_addr, flags=0x0, protocol=0
        src ip/id=192.168.1.0, mask=255.255.255.0, port=0
        dst ip/id=0.0.0.0, mask=0.0.0.0, port=0, dscp=0x0
        input_ifc=inside, output_ifc=outside

Phase: 5
Type: HOST-LIMIT
Subtype:
Result: ALLOW
Config:
Additional Information:
 Forward Flow based lookup yields rule:
 in  id=0xcb3b29b0, priority=0, domain=host-limit, deny=false
        hits=22747, user_data=0x0, cs_id=0x0, flags=0x0, protocol=0
        src ip/id=0.0.0.0, mask=0.0.0.0, port=0
        dst ip/id=0.0.0.0, mask=0.0.0.0, port=0, dscp=0x0
        input_ifc=inside, output_ifc=any

Phase: 6
Type: IP-OPTIONS
Subtype:
Result: ALLOW
Config:
Additional Information:
 Reverse Flow based lookup yields rule:
 in  id=0xcb36f638, priority=0, domain=inspect-ip-options, deny=true
        hits=70090, user_data=0x0, cs_id=0x0, reverse, flags=0x0, protocol=0
        src ip/id=0.0.0.0, mask=0.0.0.0, port=0
        dst ip/id=0.0.0.0, mask=0.0.0.0, port=0, dscp=0x0
        input_ifc=outside, output_ifc=any

Phase: 7
Type: FLOW-CREATION
Subtype:
Result: ALLOW
Config:
Additional Information:
New flow created with id 31191, packet dispatched to next module
Module information for forward flow ...
snp_fp_tracer_drop
snp_fp_inspect_ip_options
snp_fp_tcp_normalizer
snp_fp_translate
snp_fp_adjacency
snp_fp_fragment
snp_ifc_stat

Module information for reverse flow ...
snp_fp_tracer_drop
snp_fp_inspect_ip_options
snp_fp_translate
snp_fp_tcp_normalizer
snp_fp_adjacency
snp_fp_fragment
snp_ifc_stat

Result:
input-interface: inside
input-status: up
input-line-status: up
output-interface: outside
output-status: up
output-line-status: up
Action: allow


---

I now see on my laptops that I am back on the network. So one of those things seemed to work.

I am now not testing the vpn, I'll be doing that this evening just to be sure things are working OK.

 

Marius Gunnerud Tue, 07/01/2014 - 04:01
User Badges:
  • Red, 2250 points or more
  • Cisco Designated VIP,

    2017 Firewalling

Good stuff that you are back online! yes

As per the packet tracer all from the inside to the internet should be fine now.

Let us know how it goes with the VPN test.

Marius Gunnerud Mon, 06/30/2014 - 03:30
User Badges:
  • Red, 2250 points or more
  • Cisco Designated VIP,

    2017 Firewalling

Thank you for the rating smiley

Actions

This Discussion

Related Content