×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

IKEv2 Site to Site VPN using certificate is failing.

Unanswered Question
Jul 10th, 2014
User Badges:

Hi 

I am trying to create a VPN tunnel using IOS ca server from an ASA5505 to 881 router but failing (see following debug). This works perfectly fine with pre share.

Would be great, if anyone could shed some lights. 

 

*May 26 13:20:53.331: IKEv2:Searching Policy with fvrf 0, local address 1.1.1.2
*May 26 13:20:53.331: IKEv2:Found Policy 'POLICY_1'
*May 26 13:20:53.331: IKEv2:(SA ID = 1):[IKEv2 -> PKI] Start PKI Session
*May 26 13:20:53.331: IKEv2:(SA ID = 1):[PKI -> IKEv2] Starting of PKI Session PASSED
*May 26 13:20:53.331: IKEv2:(SA ID = 1):[IKEv2 -> Crypto Engine] Computing DH public key, DH Group 24
*May 26 13:20:53.331: IKEv2:(SA ID = 1):[Crypto Engine -> IKEv2] DH key Computation PASSED
*May 26 13:20:53.331: IKEv2:(SA ID = 1):Request queued for computation of DH key
*May 26 13:20:53.331: IKEv2:IKEv2 initiator - no config data to send in IKE_SA_INIT exch
*May 26 13:20:53.331: IKEv2:(SA ID = 1):Generating IKE_SA_INIT message
*May 26 13:20:53.331: IKEv2:(SA ID = 1):IKE Proposal: 1, SPI size: 0 (initial negotiation), 
Num. transforms: 4
3DES SHA256 SHA256 DH_GROUP_2048_256_MODP/Group 24 

*May 26 13:20:53.331: IKEv2:(SA ID = 1):Sending Packet [To 1.1.1.1:500/From 1.1.1.2:500/VRF i0:f0] 
Initiator SPI : 2581A26ADE3818E1 - Responder SPI : 0000000000000000 Message id: 0
IKEv2 IKE_SA_INIT Exchange REQUEST 
Payload contents: 
SA KE N VID VID NOTIFY(NAT_DETECTION_SOURCE_IP) NOTIFY(NAT_DETECTION_DESTINATION_IP) 

*May 26 13:20:53.331: IKEv2:(SA ID = 1):Insert SA 

*May 26 13:20:53.335: IKEv2:(SA ID = 1):Received Packet [From 1.1.1.1:500/To 1.1.1.2:500/VRF i0:f0] 
Initiator SPI : 2581A26ADE3818E1 - Responder SPI : 4808E0AC351071E6 Message id: 0
IKEv2 IKE_SA_INIT Exchange RESPONSE 
Payload contents: 
SA KE N VID VID NOTIFY(NAT_DETECTION_SOURCE_IP) NOTIFY(NAT_DETECTION_DESTINATION_IP) CERTREQ VID 

*May 26 13:20:53.335: IKEv2:(SA ID = 1):Processing IKE_SA_INIT message
*May 26 13:20:53.335: IKEv2:(SA ID = 1):Verify SA init message
*May 26 13:20:53.335: IKEv2:(SA ID = 1):Processing IKE_SA_INIT message
*May 26 13:20:53.335: IKEv2:(SA ID = 1):[IKEv2 -> PKI] Retrieving trustpoint(s) from received certificate hash(es)
*May 26 13:20:53.335: IKEv2:(SA ID = 1):[PKI -> IKEv2] Retrieved trustpoint(s): 'MyTrust' 
*May 26 13:20:53.335: IKEv2:(SA ID = 1):[IKEv2 -> PKI] Getting cert chain for the trustpoint MyTrust
*May 26 13:20:53.339: IKEv2:(SA ID = 1):[PKI -> IKEv2] Getting of cert chain for the trustpoint PASSED
*May 26 13:20:53.339: IKEv2:(SA ID = 1):Checking NAT discovery
*May 26 13:20:53.339: IKEv2:(SA ID = 1):NAT not found
*May 26 13:20:53.339: IKEv2:(SA ID = 1):[IKEv2 -> Crypto Engine] Computing DH secret key, DH Group 24
*May 26 13:20:53.599: IKEv2:(SA ID = 1):[Crypto Engine -> IKEv2] DH key Computation PASSED
*May 26 13:20:53.599: IKEv2:(SA ID = 1):Request queued for computation of DH secret
*May 26 13:20:53.599: IKEv2:(SA ID = 1):[IKEv2 -> Crypto Engine] Calculate SKEYSEED and create rekeyed IKEv2 SA
*May 26 13:20:53.603: IKEv2:(SA ID = 1):[Crypto Engine -> IKEv2] SKEYSEED calculation and creation of rekeyed IKEv2 SA PASSED
*May 26 13:20:53.603: IKEv2:(SA ID = 1):Completed SA init exchange
*May 26 13:20:53.603: IKEv2:(SA ID = 1):Check for EAP exchange
*May 26 13:20:53.603: IKEv2:(SA ID = 1):Generate my authentication data
*May 26 13:20:53.603: IKEv2:[IKEv2 -> Crypto Engine] Generate IKEv2 authentication data
*May 26 13:20:53.603: IKEv2:[Crypto Engine -> IKEv2] IKEv2 authentication data generation PASSED
*May 26 13:20:53.603: IKEv2:(SA ID = 1):Get my authentication method
*May 26 13:20:53.603: IKEv2:(SA ID = 1):My authentication method is 'RSA'
*May 26 13:20:53.603: IKEv2:(SA ID = 1):Sign authentication data
*May 26 13:20:53.603: IKEv2:(SA ID = 1):[IKEv2 -> PKI] Getting private key
*May 26 13:20:53.603: IKEv2:(SA ID = 1):[PKI -> IKEv2] Getting of private key PASSED
*May 26 13:20:53.603: IKEv2:(SA ID = 1):[IKEv2 -> Crypto Engine] Sign authentication data
*May 26 13:20:53.871: IKEv2:(SA ID = 1):[Crypto Engine -> IKEv2] Signing of authenticaiton data PASSED
*May 26 13:20:53.871: IKEv2:(SA ID = 1):Authentication material has been sucessfully signed
*May 26 13:20:53.871: IKEv2:(SA ID = 1):Check for EAP exchange
*May 26 13:20:53.871: IKEv2:(SA ID = 1):Generating IKE_AUTH message
*May 26 13:20:53.871: IKEv2:(SA ID = 1):Constructing IDi payload: 'Router.domain.com' of type 'FQDN'
*May 26 13:20:53.871: IKEv2:(SA ID = 1):[IKEv2 -> PKI] Retrieve configured trustpoint(s)
*May 26 13:20:53.871: IKEv2:(SA ID = 1):[PKI -> IKEv2] Retrieved trustpoint(s): 'MyTrust' 'Trustpool4' 'Trustpool3' 'Trustpool2' 'Trustpool1' 'Trustpool'
*May 26 13:20:53.871: IKEv2:(SA ID = 1):[IKEv2 -> PKI] Get Public Key Hashes of trustpoints
*May 26 13:20:53.871: IKEv2:(SA ID = 1):[PKI -> IKEv2] Getting of Public Key Hashes of trustpoints PASSED
*May 26 13:20:53.871: IKEv2:(SA ID = 1):ESP Proposal: 1, SPI size: 4 (IPSec negotiation), 
Num. transforms: 3
3DES SHA256 Don't use ESN
*May 26 13:20:53.871: IKEv2:(SA ID = 1):Building packet for encryption. 
Payload contents: 
VID IDi CERT CERTREQ NOTIFY(HTTP_CERT_LOOKUP_SUPPORTED) AUTH SA TSi TSr NOTIFY(INITIAL_CONTACT) NOTIFY(SET_WINDOW_SIZE) NOTIFY(ESP_TFC_NO_SUPPORT) NOTIFY(NON_FIRST_FRAGS) 

*May 26 13:20:53.871: IKEv2:(SA ID = 1):Sending Packet [To 1.1.1.1:500/From 1.1.1.2:500/VRF i0:f0] 
Initiator SPI : 2581A26ADE3818E1 - Responder SPI : 4808E0AC351071E6 Message id: 1
IKEv2 IKE_AUTH Exchange REQUEST 
Payload contents: 
ENCR 


*May 26 13:20:53.875: IKEv2:(SA ID = 1):Received Packet [From 1.1.1.1:500/To 1.1.1.2:500/VRF i0:f0] 
Initiator SPI : 2581A26ADE3818E1 - Responder SPI : 4808E0AC351071E6 Message id: 1
IKEv2 IKE_AUTH Exchange RESPONSE 
Payload contents: 
NOTIFY(AUTHENTICATION_FAILED) 

*May 26 13:20:53.875: IKEv2:(SA ID = 1):Process auth response notify
*May 26 13:20:53.875: IKEv2:(SA ID = 1):
*May 26 13:20:53.875: IKEv2:(SA ID = 1):Auth exchange failed
*May 26 13:20:53.875: IKEv2:(SA ID = 1):Auth exchange failed

*May 26 13:20:53.875: IKEv2:(SA ID = 1):Auth exchange failed
*May 26 13:20:53.875: IKEv2:(SA ID = 1):Abort exchange
*May 26 13:20:53.879: IKEv2:(SA ID = 1):Deleting SA
*May 26 13:20:53.879: IKEv2:(SA ID = 1):[IKEv2 -> PKI] Close PKI Session
*May 26 13:20:53.879: IKEv2:(SA ID = 1):[PKI -> IKEv2] Closing of PKI Session PASSED

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Marius Gunnerud Fri, 07/11/2014 - 01:33
User Badges:
  • Red, 2250 points or more
  • Cisco Designated VIP,

    2017 Firewalling

What are you using as a CA server? how are you  creating and importing the certificates to the ASA and IOS router?

most likely there is a mismatch in the certificates or the enrollment with the CA has been done incorrectly.

Also, could you please post a full running config of both devices (sanitised) so we can check for any mis-matched configuration.

--

Please remember to select a correct answer and rate helpful posts

Suran Fernando Fri, 07/11/2014 - 04:01
User Badges:

Hi Marius 

Thanks for the response !

 

I am using IOS ca server (Cisco3800) and please see the config below. 

 

ASA

====

 


ASA Version 9.1(4) 
!
hostname x-x-ASA
domain-name x.x.uk
enable password NuLKvvWGg.x9HEKO encrypted
xlate per-session deny tcp any4 any4
xlate per-session deny tcp any4 any6
xlate per-session deny tcp any6 any4
xlate per-session deny tcp any6 any6
xlate per-session deny udp any4 any4 eq domain
xlate per-session deny udp any4 any6 eq domain
xlate per-session deny udp any6 any4 eq domain
xlate per-session deny udp any6 any6 eq domain
names
!
interface Ethernet0/0
 switchport access vlan 30
!
interface Ethernet0/1
 switchport access vlan 20
!
interface Ethernet0/2
 shutdown

interface Ethernet0/3
 shutdown
!
interface Ethernet0/4
 shutdown
!
interface Ethernet0/5
 shutdown
!
interface Ethernet0/6
 shutdown
!
interface Ethernet0/7
 shutdown
!
interface Vlan1
 no nameif
 no security-level
 no ip address
!
interface Vlan20
 nameif inside
 security-level 100
ip address x.x.1.1 255.255.255.0 
!
interface Vlan30
 nameif outside
 security-level 0
 ip address x.x.x.1 255.255.255.192 
!
ftp mode passive
dns server-group DefaultDNS
 domain-name fco.gov.uk
object network obj_x.x.1.2
 host x.x.1.2
object network obj_x.x.1.0
 subnet x.x.1.0 255.255.255.0
object network obj_x.x.1.0_vpn
 subnet x.x.1.0 255.255.255.0
object network obj_x.x.3.0_vpn
 subnet x.x.3.0 255.255.255.0
access-list OUTtoIN extended permit tcp x.x.x.0 255.255.255.192 x.x.1.0 255.255.255.0 eq ssh 
access-list OUTtoIN extended permit tcp x.x.x.0 255.255.255.192 x.x.1.0 255.255.255.0 
access-list VPN-TRAFFIC extended permit ip x.x.1.0 255.255.255.0 x.x.3.0 255.255.255.0 
pager lines 24
logging enable
logging console debugging
logging buffered warnings
mtu outside 1500
mtu inside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
nat (inside,outside) source static obj_x.x.1.0_vpn obj_x.x.1.0_vpn destination static obj_x.x.3.0_vpn obj_x.x.3.0_vpn
!
object network obj_x.x.1.2
 nat (inside,outside) static x.x.x.12
object network obj_x.x.1.0
 nat (inside,outside) dynamic interface
access-group OUTtoIN in interface outside
route outside x.x.3.0 255.255.255.0 x.x.x.6 1 
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
aaa authentication ssh console LOCAL 
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
crypto ipsec ikev2 ipsec-proposal AES256
 protocol esp encryption aes-256
 protocol esp integrity sha-1
crypto ipsec security-association pmtu-aging infinite
crypto map ASA-IOS 10 match address VPN-TRAFFIC
crypto map ASA-IOS 10 set peer x.x.x.6 
crypto map ASA-IOS 10 set ikev2 ipsec-proposal AES256
crypto map ASA-IOS 10 set trustpoint TEST1 chain
crypto map ASA-IOS interface outside
crypto ca trustpoint _SmartCallHome_ServerCA
 crl configure
crypto ca trustpoint TEST1
 enrollment url http://x.x.x.51:80
 fqdn LMS-Branch-ASA.fco.gov.uk
 subject-name CN=LMS-Branch-ASA C=UK 
 serial-number
 crl configure
crypto ca trustpool policy
crypto ca certificate chain _SmartCallHome_ServerCA
 certificate ca 6ecc7aa5a7032009b8cebcf4e952d491
    308205ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130 
    0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117 
    30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b 
    13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504 
    0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72 
    20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56 
    65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043 
    65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d31 
    30303230 38303030 3030305a 170d3230 30323037 32333539 35395a30 81b5310b 
    30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20 
    496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65 
    74776f72 6b313b30 39060355 040b1332 5465726d 73206f66 20757365 20617420 
    68747470 733a2f2f 7777772e 76657269 7369676e 2e636f6d 2f727061 20286329 
    3130312f 302d0603 55040313 26566572 69536967 6e20436c 61737320 33205365 
    63757265 20536572 76657220 4341202d 20473330 82012230 0d06092a 864886f7 
    0d010101 05000382 010f0030 82010a02 82010100 b187841f c20c45f5 bcab2597 
    a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10 
    9c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc 
    7f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b 
    15fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845 
    63cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8 
    18b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced 
    4a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f 
<--- More --->
              
    81f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201 
    db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868 
    7474703a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101 
    ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8 
    45010717 03305630 2806082b 06010505 07020116 1c687474 70733a2f 2f777777 
    2e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a 
    1c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406 
    03551d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973 
    69676e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403 
    02010630 6d06082b 06010505 07010c04 61305fa1 5da05b30 59305730 55160969 
    6d616765 2f676966 3021301f 30070605 2b0e0302 1a04148f e5d31a86 ac8d8e6b 
    c3cf806a d448182c 7b192e30 25162368 7474703a 2f2f6c6f 676f2e76 65726973 
    69676e2e 636f6d2f 76736c6f 676f2e67 69663028 0603551d 11042130 1fa41d30 
    1b311930 17060355 04031310 56657269 5369676e 4d504b49 2d322d36 301d0603 
    551d0e04 1604140d 445c1653 44c1827e 1d20ab25 f40163d8 be79a530 1f060355 
    1d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609 
    2a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80 
    4bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e 
    b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a 
    6decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc 
    481d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16 
    b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0 
    5becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8 
    6119b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 16de0c28 
<--- More --->
              
    6c2527b9 deb78458 c61f381e a4c4cb66
  quit
crypto ca certificate chain TEST1
 certificate 0e
    30820279 308201e2 a0030201 0202010e 300d0609 2a864886 f70d0101 04050030 
    2f312d30 2b060355 04030c24 43504c4d 532d4272 616e6368 5f312e66 636f2e67 
    6f762e75 6b204c3d 52545020 433d554b 301e170d 31343037 30363130 31303234 
    5a170d31 35303730 36313031 3032345a 305c311c 301a0603 55040313 134c4d53 
    2d427261 6e63682d 41534120 433d554b 313c3012 06035504 05130b4a 4d583137 
    30373430 484b3026 06092a86 4886f70d 01090216 194c4d53 2d427261 6e63682d 
    4153412e 66636f2e 676f762e 756b3081 9f300d06 092a8648 86f70d01 01010500 
    03818d00 30818902 818100be d69393a4 426637a3 d2f26f98 ef8c649f ec39535a 
    7f771705 08424083 2c8134d0 26e03658 8502de42 f2fcad98 68bda85a 300d1fc2 
    6ecdc2d1 99f72f98 43ac592e 25fd8b5f 959b013d 4d58ac0e e60eac06 16d739d2 
    622558cd 4a4b3f0e bedbdd34 49d6da71 af5fa52e f71efc1b 1f424357 b0af38b4 
    10b8e1a6 0429d465 44788d02 03010001 a3783076 30240603 551d1104 1d301b82 
    194c4d53 2d427261 6e63682d 4153412e 66636f2e 676f762e 756b300e 0603551d 
    0f0101ff 04040302 05a0301f 0603551d 23041830 168014a3 c22b732c 00434041 
    47ffdb44 a6514333 bdf94c30 1d060355 1d0e0416 0414ecf9 e401be31 d7a6a4e7 
    bcbcdbbd 6fb84b36 1a16300d 06092a86 4886f70d 01010405 00038181 0010c508 
    bc80d4b7 f7fbcb94 91448445 dcab8afd 32af6f2d 75954cfa 285c97aa 2066291b 
    b92b1a8a e9bb46eb 584b3323 5c737902 e58fd1fd b0648d44 2dfa52c9 7969b684 
    93fe1c78 76110fb6 7dbb1f6a 14659a8b f02c0564 47979125 ab106b0d 234e45f1 
    6b1e8d35 803846eb b8dbf102 b5b57477 8c8cdd84 a3b4e511 d88aa914 0a
<--- More --->
              
  quit
 certificate ca 01
    30820237 308201a0 a0030201 02020101 300d0609 2a864886 f70d0101 04050030 
    2f312d30 2b060355 04030c24 43504c4d 532d4272 616e6368 5f312e66 636f2e67 
    6f762e75 6b204c3d 52545020 433d554b 301e170d 31343037 30313134 35383533 
    5a170d31 37303633 30313435 3835335a 302f312d 302b0603 5504030c 2443504c 
    4d532d42 72616e63 685f312e 66636f2e 676f762e 756b204c 3d525450 20433d55 
    4b30819f 300d0609 2a864886 f70d0101 01050003 818d0030 81890281 8100cdb8 
    493614fa b2e354d9 4539f7b1 51a3c3ff 79a5bc00 7ffda54a 48f43e26 aa1fcda6 
    0e3f86c0 47445ae3 509c6f3d decd67e9 d49c68d1 d0e70705 cd5fd48d 5df655f5 
    9e25b734 f1dc8d3a 5415e30e a365dd67 1e6ebc15 4cf37e0a d7a1bdcb 2923d25b 
    0bea7c67 deb48ffd 73f2a73c 068a19f6 504e3953 cbb96cbb 0aa7619f 163f0203 
    010001a3 63306130 0f060355 1d130101 ff040530 030101ff 300e0603 551d0f01 
    01ff0404 03020186 301f0603 551d2304 18301680 14a3c22b 732c0043 404147ff 
    db44a651 4333bdf9 4c301d06 03551d0e 04160414 a3c22b73 2c004340 4147ffdb 
    44a65143 33bdf94c 300d0609 2a864886 f70d0101 04050003 8181005b 400014ab 
    1e3cb016 4429fc72 9b41ede3 ca72ad5d ea181cf7 529aec3e bce8a482 dc98bca5 
    8dc17e9f cdbf370b cca22d5d d3db2509 6aace206 7f81e346 dd12f6cd ca18fc50 
    6efcfe4a f3534a85 55b0dc0a f54e7989 962baa06 690c551c 768885d4 7e290e20 
    c0c0b85e e151a2c5 31470062 1c06287d 30e74827 f6e8b799 df6e06
  quit
crypto ikev2 policy 10
 encryption aes-256
 integrity sha
 group 5
 prf sha
 lifetime seconds 86400
crypto ikev2 enable outside
telnet timeout 5
ssh x.x.x.0 255.255.255.192 outside
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
username lmsuser password qieRRyX0kX6A9qFV encrypted privilege 15
tunnel-group x.x.x.6 type ipsec-l2l
tunnel-group x.x.x.6 ipsec-attributes
 ikev2 remote-authentication certificate
 ikev2 local-authentication certificate TEST1
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
<--- More --->
              
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect ip-options 
  inspect netbios 
  inspect rsh 
  inspect rtsp 
  inspect skinny  
  inspect esmtp 
  inspect sqlnet 
  inspect sunrpc 
  inspect tftp 
  inspect sip  
  inspect xdmcp 
  inspect icmp 
!
service-policy global_policy global
prompt hostname context 
call-home reporting anonymous
call-home
 profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email [email protected]
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:ca2bfbda3ba783a92cd63d65ae58eb4a

 

 

 

Router

======

 

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2014.07.08 09:19:26 =~=~=~=~=~=~=~=~=~=~=~=
sh log run
Building configuration...
 
Current configuration : 4955 bytes
!
! Last configuration change at 10:47:39 UTC Sun Jul 6 2014 by lmsuser
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname xxxx881
!
boot-start-marker
boot-end-marker
!
!
enable secret 4 LcV6aBcc/53FoCJjXQMd7rBUDEpeevrK8V5jQVoJEhU
!
no aaa new-model
memory-size iomem 10
!
crypto pki trustpoint TEST1
 enrollment retry count 3
 --More--         enrollment retry period 3
 enrollment url http://x.x.x.51:80
 serial-number
 revocation-check none
!
!
crypto pki certificate chain TEST1
 certificate 0D
  3082022D 30820196 A0030201 0202010D 300D0609 2A864886 F70D0101 05050030 
  2F312D30 2B060355 04030C24 43504C4D 532D4272 616E6368 5F312E66 636F2E67 
  6F762E75 6B204C3D 52545020 433D554B 301E170D 31343037 30363130 30353337 
  5A170D31 35303730 36313030 3533375A 30393137 30120603 55040513 0B46435A 
  31383032 36305344 30210609 2A864886 F70D0109 02161442 72616E63 68383831 
  2E66636F 2E676F76 2E756B30 819F300D 06092A86 4886F70D 01010105 0003818D 
  00308189 02818100 97780445 031532CB 2066387C 7703482B 0232D1A0 C68FC6FA 
  2E3D83E2 28A69A14 081E5917 7FBE1CC5 5FE27EB9 62CDEE0A 240723CA 434745F4 
  976BFC72 41C8E4BB EE75EBC9 72C7230E 383CE2BA 0C5888EF 4DF41451 47DB43B2 
  E7CE4D82 1FE1AD02 236815FA 11A69434 F5220561 C7D79447 C9289777 EC5ED524 
  3E2096F5 F50B0E49 02030100 01A34F30 4D300B06 03551D0F 04040302 05A0301F 
  0603551D 23041830 168014A3 C22B732C 00434041 47FFDB44 A6514333 BDF94C30 
  1D060355 1D0E0416 0414F313 283F7D02 B8E66F8B 93E88A3D A99620C9 F494300D 
  06092A86 4886F70D 01010505 00038181 00A0721C 8CB58BFD C9DB7EBF 7AAFBE4C 
  97515BD0 4173FD3A EABE1ACC D2803070 84BDC82F B0FA6108 C080B750 F9EB6024 
 --More--          F6F11545 2857542E C1ED1D7A 5BF41FCF 8BF5CBDD C8780D55 A937CFE5 D2916B98 
  5D566320 E70398AE 187FEB71 C9A820CB 2F73C676 D5575EBB E9720110 5B7D4335 
  B9ACCAD0 089DF9BB 9813081F 5C86C0EF 33
  quit
 certificate ca 01
  30820237 308201A0 A0030201 02020101 300D0609 2A864886 F70D0101 04050030 
  2F312D30 2B060355 04030C24 43504C4D 532D4272 616E6368 5F312E66 636F2E67 
  6F762E75 6B204C3D 52545020 433D554B 301E170D 31343037 30313134 35383533 
  5A170D31 37303633 30313435 3835335A 302F312D 302B0603 5504030C 2443504C 
  4D532D42 72616E63 685F312E 66636F2E 676F762E 756B204C 3D525450 20433D55 
  4B30819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281 8100CDB8 
  493614FA B2E354D9 4539F7B1 51A3C3FF 79A5BC00 7FFDA54A 48F43E26 AA1FCDA6 
  0E3F86C0 47445AE3 509C6F3D DECD67E9 D49C68D1 D0E70705 CD5FD48D 5DF655F5 
  9E25B734 F1DC8D3A 5415E30E A365DD67 1E6EBC15 4CF37E0A D7A1BDCB 2923D25B 
  0BEA7C67 DEB48FFD 73F2A73C 068A19F6 504E3953 CBB96CBB 0AA7619F 163F0203 
  010001A3 63306130 0F060355 1D130101 FF040530 030101FF 300E0603 551D0F01 
  01FF0404 03020186 301F0603 551D2304 18301680 14A3C22B 732C0043 404147FF 
  DB44A651 4333BDF9 4C301D06 03551D0E 04160414 A3C22B73 2C004340 4147FFDB 
  44A65143 33BDF94C 300D0609 2A864886 F70D0101 04050003 8181005B 400014AB 
  1E3CB016 4429FC72 9B41EDE3 CA72AD5D EA181CF7 529AEC3E BCE8A482 DC98BCA5 
  8DC17E9F CDBF370B CCA22D5D D3DB2509 6AACE206 7F81E346 DD12F6CD CA18FC50 
  6EFCFE4A F3534A85 55B0DC0A F54E7989 962BAA06 690C551C 768885D4 7E290E20 
  C0C0B85E E151A2C5 31470062 1C06287D 30E74827 F6E8B799 DF6E06
 --More--           quit
!
!
!
!
 
 
!
!
!
!
ip domain name x.x.uk
ip cef
no ipv6 cef
!
!
multilink bundle-name authenticated
license udi pid CISCO881-SEC-K9 sn FCZ180260SD
!
!
username lmsuser privilege 15 password 0 password
!
crypto ikev2 proposal AES256 
 encryption aes-cbc-256
 integrity sha1
 group 5
!
crypto ikev2 policy POLICY1 
 proposal AES256
!
crypto ikev2 keyring VPN-KEYS
 peer ASA1
  address x.x.x.1
  pre-shared-key local cisco123
  pre-shared-key remote cisco123
 !
!
!
crypto ikev2 profile PROF1
 match identity remote address x.x.x.1 255.255.255.255 
 identity local address x.x.x.6
 authentication remote rsa-sig
 authentication local rsa-sig
 pki trustpoint TEST1
!
!
 
!
!
crypto ipsec transform-set ESP-AES256 esp-aes 256 esp-sha-hmac 
 mode tunnel
!
!
!
crypto map TESTMAP 10 ipsec-isakmp 
 set peer x.x.x.1
 set transform-set ESP-AES256 
 set ikev2-profile PROF1
 match address VPN-TRAFFIC
!
!
!
!
!
interface FastEthernet0
 switchport access vlan 40
 no ip address
!
interface FastEthernet1
 no ip address
!
interface FastEthernet2
 no ip address
!
interface FastEthernet3
 no ip address
!
interface FastEthernet4
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Vlan1
 ip address x.x.x.1 255.255.255.0
!
interface Vlan23
 no ip address
!
interface Vlan40
 ip address x.x.x.6 255.255.255.192
 crypto map TESTMAP
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route x.x.x.0 255.255.255.0 x.x.x.1
!
ip access-list extended VPN-TRAFFIC
 permit ip x.x.3.0 0.0.0.255 x.x.1.0 0.0.0.255
!
!
!
control-plane
!
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 login local
 transport input all
!
!
end
 
#
nkarthikeyan Fri, 07/11/2014 - 02:02
User Badges:
  • Gold, 750 points or more

Hi,

 

Can you give the below mentioned command of the cisco router and check if the error message appears?

no crypto ikev2 http-url cert

 

Also can you check on the authentication parameters that is used in ASA and router for IKEv2 negotiation?

 

Regards

Karthik

 

nkarthikeyan Fri, 07/11/2014 - 05:04
User Badges:
  • Gold, 750 points or more

Hi,

Can you configure this command under tunnel group configuration of your ASA.

tunnel-group x.x.x.6 type ipsec-l2l
tunnel-group x.x.x.6 ipsec-attributes

 peer-id-validate nocheck

and check with your cert auth.

 

Regards

Karthik

Actions

This Discussion