VCS Expressway TLS issue

Answered Question
Jul 11th, 2014
User Badges:

I installed expressway for collaboration edge, and it works fine for Jabber for Windows.

But when I tried Jabber for Mac (9.6), the phone services and voicemail are connected, but not the IM service. Same thing happens for Jabber for iPhone and iPad.

When I checked the event log, it says

traffic_server[26816]: Event="Sending HTTP error response" Status="407" Reason="Proxy Authentication Required"

tvcs: Event="Registration Rejected" Reason="Unknown domain"

tvcs: Event="Inbound TLS Negotiation Error" Detail="No SSL error available, probably remote disconnect"

Any idea?

By the way, I am using self-signed certificates following the VCS certificate deployment guide and MRA deployment guide.

Correct Answer by Ayodeji Okanlawon about 2 years 11 months ago

Did your IM work when Jabber is internal? Have you tried a new jabber version 9.7 or 10.5?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Nikhil Jayan Ka... Thu, 07/17/2014 - 02:30
User Badges:

 

Call failures due to "407 proxy authentication required" or "500 Internal Server Error" errors
Call failures can occur if the traversal zones on VCS are configured with an Authentication policy of Check credentials. Ensure that the Authentication policy on the traversal zones used for mobile and remote access is set to Do not check credentials.

Please refer below document page no 32.

http://www.cisco.com/c/dam/en/us/td/docs/telepresence/infrastructure/vcs...

 

Thanks & Regards,

Nikhil Jayan

 

huangzg Thu, 07/17/2014 - 02:35
User Badges:

The traversal zone is configured Do not check credentials on both sides.
 

Nikhil Jayan Ka... Thu, 07/17/2014 - 02:43
User Badges:

 

Hope the below ports are opened from VCSC to IM&P

TCP 7400

 

Thanks & Regards,

Nikhil Jayan

huangzg Thu, 07/17/2014 - 03:09
User Badges:

VCSC is in internal network. And the wierd thing is Windows client works with no issues.

Roberto Zamudio... Wed, 09/17/2014 - 15:02
User Badges:

 

I have this problem too, could you share to me the way you fix this problem?

 

Thank you!

Correct Answer
Ayodeji Okanlawon Thu, 09/18/2014 - 14:33
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

Did your IM work when Jabber is internal? Have you tried a new jabber version 9.7 or 10.5?

Roberto Zamudio... Thu, 09/18/2014 - 23:04
User Badges:

 

Hi all!

 

Yes of course! I 've been trying with 10.5 but seems to be a certificate problem, I am not pretty sure yet. Thanks!

 

Ayodeji Okanlawon Fri, 09/19/2014 - 02:22
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

Jabber doesn't exchange certificates with IM and presence server for MRA. Certificate exchange occurs between expressway-c and expressway-e to create a secure https and sip channel for the http and sip signalling messages. If all your other services are working, then I doubt your issue is certificate related

huangzg Thu, 09/18/2014 - 17:30
User Badges:

Upgrading to new version Jabber clients fixed the issue.

Actions

This Discussion