×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

IP Phone will not find CME but does get IP address

Unanswered Question
Aug 9th, 2014
User Badges:

Trying to figure this out, if I put my 3524PoE switch's interface as follows, the IP phone works perfectly:

switchport access 110
switchport voice vlan 110

 

But if I put the interface as follows so I can put a PC on the phone's PC port, the IP phone gets the correct IP address from the DHCP server but never registers with CME

switchport access 69
switchport voice vlan 110

 

Any suggestions?  Config of switch and router follow:

SWITCH   3524-PoE
------------------------------
sh ver
System image file is "flash:c3500xl-c3h2s-mz.120-5.WC16.bin"
cisco WS-C3524-PWR-XL (PowerPC403) processor (revision 0x01) with 8192K/1024K bytes of memory.

 

sh run
ip subnet-zero
ip name-server 4.2.2.2
!
!
!
interface FastEthernet0/1
 description Shop Gateway Computer
 switchport access vlan 69
 spanning-tree portfast
!
interface FastEthernet0/2
 description Shop IP Phone
 switchport access vlan 69
 switchport voice vlan 110
 spanning-tree portfast
!
interface FastEthernet0/3
 description Hanger IP phone
 switchport access vlan 69
 switchport voice vlan 110
 spanning-tree portfast
!
interface FastEthernet0/4
 description Shop Dell Test Bench Computer
 switchport access vlan 69
 spanning-tree portfast
!         
interface FastEthernet0/5
 shutdown
 switchport access vlan 999
 spanning-tree portfast
!
interface FastEthernet0/6
 description Access Point - Shop_AP 192.168.100.106 port FastEthernet 0
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 100
 switchport trunk allowed vlan 1,69,100,200,1002-1005
 switchport mode trunk
!
interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 100
 switchport trunk allowed vlan 1,69,100,110,125,200,1002-1005
 switchport mode trunk
!
interface VLAN1
 no ip address
 no ip directed-broadcast
 no ip route-cache
 shutdown
!
interface VLAN100
 ip address 192.168.100.108 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
!
ip default-gateway 192.168.100.101


ROUTER  -  2851
-------------------------------------------------
dot11 syslog
ip source-route
!
!
ip cef
!
ip dhcp excluded-address 192.168.69.1 192.168.69.240
ip dhcp excluded-address 192.168.200.1 192.168.200.240
ip dhcp excluded-address 10.110.0.1 10.110.0.20
ip dhcp excluded-address 192.168.125.1 192.168.125.9
!
ip dhcp pool Users
 network 192.168.69.0 255.255.255.0
 default-router 192.168.69.1
 domain-name mtd.home
 dns-server 4.2.2.2
 option 150 ip 10.110.0.1
 lease 0 12
!
ip dhcp pool Voice
 network 10.110.0.0 255.255.255.0
 default-router 10.110.0.1
 option 150 ip 10.110.0.1
 dns-server 4.2.2.2
 domain-name mtd.home
 lease 0 12
!
ip domain lookup source-interface GigabitEthernet0/1
ip domain name mtd.home
ip name-server 4.2.2.2
ip name-server 8.8.8.8
no ipv6 cef
!
multilink bundle-name authenticated
!
redundancy
!
!
gw-accounting syslog
!
interface GigabitEthernet0/0
 shutdown
!
interface Service-Engine0/1
 description "CUE-AIM Voicemail Module"
 ip unnumbered GigabitEthernet0/1.110
 service-module ip address 10.110.0.2 255.255.255.0
 service-module ip default-gateway 10.110.0.1
!
interface GigabitEthernet0/1
 description Router - C3524 Port Fa0/20 Trunk
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/1.69
 description "Data Network"
 encapsulation dot1Q 69
 ip address 192.168.69.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface GigabitEthernet0/1.110
 description "Voice Network"
 encapsulation dot1Q 110
 ip address 10.110.0.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
router eigrp 1577
 network 10.110.0.0 0.0.0.255
 network 192.168.69.0
 network 192.168.100.101 0.0.0.0
 network 192.168.125.0
 network 192.168.200.0
!
ip nat inside source list NAT_ACL interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 192.168.69.3
ip route 10.110.0.2 255.255.255.255 Service-Engine0/1
!
logging history size 500
access-list 100 remark "Block access from the Guest network to everything except the printer & the Interent
access-list 100 permit ip any host 192.168.69.99
access-list 100 permit ip any 192.168.200.0 0.0.0.7
access-list 100 deny   ip any 192.168.0.0 0.0.255.255
access-list 100 permit ip any any
!
!
dial-peer inbound selection sip-trunk
sip-ua
 credentials number ....
!
telephony-service
 no auto-reg-ephone
 max-ephones 100
 max-dn 20
 ip source-address 10.110.0.1 port 2000
 service phone daysDisplayNotActive 1,7
 service phone displayOnTime 08:00
 service phone displayOnDuration 12
 service phone displayIdleTimeout 00:10
 service phone settingsAccess 1
 service phone modeOfOperation 1
 service phone displaywhebincomingcall 1
 system message The Durham Corporation
 url services http://phone-xml.berbee.com/menu.xml
 load 7960-7940 P00308000800
 load 7970 SCCP70.9-1-1SR1S
 time-zone 12
 voicemail 5000
 mwi relay
 max-conferences 4 gain -6
 moh MoH.wav
 multicast moh 239.2.2.2 port 2000
 transfer-system full-consult
 directory entry 1 1001 name Michael Durham
 create cnf-files version-stamp 7960 May 26 2014 12:14:45
!
ephone-dn  1  dual-line
 number 1000
 label "Certification Solutions"
 description Administrator
 call-forward busy 5000
 call-forward noan 5000 timeout 17
 corlist incoming Keyring-National
!
ephone  5
 device-security-mode none
 description Hanger Phone
 mac-address 0008.2128.7A30
 type 7940
 button  1:1 2f2
!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
islam.kamal Sat, 08/09/2014 - 13:54
User Badges:
  • Red, 2250 points or more

Hi

Can you check the below:-

1-ip dhcp pool Users
no option 150 ip 10.110.0.1   / remove option 150 under Data DHCP/

interface FastEthernet0/2
 description Shop IP Phone
switchport mode access
!
interface FastEthernet0/3
 description Hanger IP phone
switchport mode access

2- Can you share debug tftp events .

3- Try to do , go to phone phusically -setting -securoty setting - delete CTL , ITL

Thanks

please rate all useful information

Actions

This Discussion