×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Help | SIP Trunk Through CME IOS 15.1 Towards SIP ISP | Outgoing Call Issue

Unanswered Question
Aug 16th, 2014
User Badges:

My phones are registered with the CME and i have purchased a Sip trunk . After doing the configuration from my side i am not able to make an outgoing call to the PSTN number through SIP trunk.
I am attaching two files :

1 Router running configuration

2 Debug messages of SIP

Kindly Find the attachment below .

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Tagir Temirgaliyev Sat, 08/16/2014 - 08:52
User Badges:
  • Silver, 250 points or more
Sent: 
REGISTER sip:gw2.sip.us:5060 SIP/2.0

////

Authorization: Digest username="5245798725",realm="gw2.sip.us",uri="sip:gw2.sip.us:5060",response="7ed5ba1aeac06c817b85c2dbe27367e7",nonce="U+ytflPsqybfv42Ryk9al/95ESy/wYeLXU1gUBM4lrBPyTI8M1DbfH09zxfD",cnonce="D9DAF3A4",qop=auth,algorithm=md5,nc=00000001

Content-Length: 0


Received: 
SIP/2.0 401 Unauthorized


WWW-Authenticate: Digest realm="gw2.sip.us", nonce="U+ytgFPsqygibbsnBlbZSJnSzv9GWaFdXU1gUBM4lrBPyTI8M1DbfFH7dCnA", qop="auth"

Content-Length: 0

 

you sent register and you recieved unauthorized. it looks like username/password incorrect

and dont forget to rate post

Tagir Temirgaliyev Sun, 08/17/2014 - 07:34
User Badges:
  • Silver, 250 points or more

may be calling or called number incorrect. send debug to provider

Ayodeji Okanlawon Sun, 08/17/2014 - 12:48
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

What is your ITSP saying. You need to work with them to resolve this one..

The invite you sent contains yoru authentication credentials..

Sent:
INVITE sip:[email protected]:5060 SIP/2.0

Via: SIP/2.0/UDP 192.235.68.162:5060;branch=z9hG4bK8FBA1C34

Remote-Party-ID: "US-Test" <sip:[email protected]>;party=calling;screen=no;privacy=off

From: "US-Test" <sip:[email protected]>;tag=2759C404-12A3

To: <sip:[email protected]>

Date: Thu, 14 Aug 2014 13:42:57 GMT

Call-ID: [email protected]

--

--

Proxy-Authorization: Digest username="5245798725",realm="gw2.sip.us",uri="sip:[email protected]:5060",response="5c0780df149e2095ffa2cc3a82324cf1",nonce="U+ytbVPsqxVLlM+Q+FKbz21eW/PJWZ/0qmlfGHm8LYFzoZ5QH6VR0zsOho3C",cnonce="966E3696",qop=auth,algorithm=md5,nc=00000001

Content-Type: application/sdp

Content-Disposition: session;handling=required

Content-Length: 253

 

Next they are requesting authorization for using the same credentials you already sent to them

Received:
SIP/2.0 407 Proxy Authentication Required

Via: SIP/2.0/UDP 192.235.68.162:5060;branch=z9hG4bK8FBA1C34;rport=59195

From: "US-Test" <sip:[email protected]>;tag=2759C404-12A3

To: <sip:[email protected]>;tag=6b55604b003175432ccabd664d6002bd.2cff

Call-ID: [email protected]

CSeq: 102 INVITE

Proxy-Authenticate: Digest realm="gw2.sip.us", nonce="U+ytbVPsqxVY3f1Rcwe6MFkPUG1ZvsHtqmlfGHm8LYFzoZ5QH6VR01H7YxjA", qop="auth"

 

You need to ask them what is wrong with your authentication credentials..

You also need to verify what realm you  need to be using. You have configured gw1.sip.us. But I also see gw2.sip .us..which is which?

Content-Length: 0

Actions

This Discussion

Related Content