×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

nexus 1000v CBWFQ problem

Unanswered Question
Aug 18th, 2014
User Badges:

Hi

I set up CBWFQ like descripted in http://www.cisco.com/c/en/us/products/collateral/switches/nexus-1000v-switch-vmware-vsphere/white_paper_c11-704041.html

We have a test environment with two ESX servers, both are connected to a cisco switch with 4 Gig links each, aggregated to an ether channel (po7 and po8).

But it seems not to work. If I check the qos status using the command

module vem 3 execute vemcmd show qos pinst 561

id       type
-------- --------
     561 Egress_q
            class        bytes matched         pkts matched
         -------- -------------------- --------------------
                0                    0                    0

                1                    0                    0

                2                    0                    0

                3                    0                    0

                4                    0                    0

         filter id 72352001
                    276255476              1018150
         filter id 72352002
                            0                    0
         filter id 72352003
                            0                    0

it looks like the policy would no work, all the matched counters are zero.

The same here:

ee-vswitch1# show policy-map interface port-channel 7

Global statistics status :   enabled

port-channel7

  Service-policy (queuing) output:   uplink_queue_policy
    policy statistics status:   enabled

    Class-map (queuing):   n1kv_control_packet_class (match-any)
      Match: protocol n1k_control
      Match: protocol n1k_packet
      Match: protocol n1k_mgmt
      bandwidth percent 15
      queue dropped pkts : 0
      queue matched pkts : 0
      queue inrate bytes ( Kbits/sec )  : 0
      queue outrate bytes ( Kbits/sec ) : 0

    Class-map (queuing):   vmotion_class (match-all)
      Match: protocol vmw_vmotion
      bandwidth percent 20
      queue dropped pkts : 0
      queue matched pkts : 0
      queue inrate bytes ( Kbits/sec )  : 0
      queue outrate bytes ( Kbits/sec ) : 0

    Class-map (queuing):   vmw_mgmt_class (match-all)
      Match: protocol vmw_mgmt
      bandwidth percent 15
      queue dropped pkts : 0
      queue matched pkts : 0
      queue inrate bytes ( Kbits/sec )  : 0
      queue outrate bytes ( Kbits/sec ) : 0

    Class-map (queuing):   vm_gold_class (match-all)
      Match: cos 4
      bandwidth percent 20
      queue dropped pkts : 0
      queue matched pkts : 0
      queue inrate bytes ( Kbits/sec )  : 0
      queue outrate bytes ( Kbits/sec ) : 0

    Class-map (queuing):   vm_platinum_class (match-all)
      Match: cos 5
      bandwidth percent 30
      queue dropped pkts : 0
      queue matched pkts : 0
      queue inrate bytes ( Kbits/sec )  : 0
      queue outrate bytes ( Kbits/sec ) : 0

 

 

The configuration of the port channels shows the service policy ...

ee-vswitch1# sh run int po 7 expand-port-profile

!Command: show running-config interface port-channel7 expand-port-profile
!Time: Mon Aug 18 16:59:32 2014

version 4.2(1)SV2(2.2)

interface port-channel7
  switchport
  switchport mode trunk
  vem 3
  switchport trunk allowed vlan 115,187,304
  service-policy type queuing output uplink_queue_policy

 

ee-vswitch1# sh int po 7
port-channel7 is up
  Hardware: Port-Channel, address: 0050.565a.fef2 (bia 0050.565a.fef2)
  MTU 1500 bytes, BW 4000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA
  Port mode is trunk
  full-duplex, 1000 Mb/s
  Beacon is turned off
  Input flow-control is off, output flow-control is off
  Switchport monitor is off
  Members in this channel: Eth3/1, Eth3/2, Eth3/3, Eth3/4
  Last clearing of "show interface" counters never
  300 seconds input rate 15720 bits/sec, 6 packets/sec
  300 seconds output rate 8000 bits/sec, 2 packets/sec
  Rx
    33147917 unicast packets  8128044 multicast packets  1737159 broadcast packets
    43012133 input packets  19097280714 bytes
    59 input packet drops
  Tx
    13459277 unicast packets  717426 multicast packets  42323 broadcast packets
    14219216 output packets  3725087001 bytes
    63277 flood packets
    0 output packet drops
  3 interface resets

... but the channel members do not

ee-vswitch1# sh run int Eth3/1 expand-port-profile

!Command: show running-config interface Ethernet3/1 expand-port-profile
!Time: Mon Aug 18 17:01:26 2014

version 4.2(1)SV2(2.2)

interface Ethernet3/1
  description uplink ctrl du-esx101
  switchport mode trunk
  switchport trunk allowed vlan 115,187,304
  channel-group auto mode active
  no shutdown

 

Any idea what's wrong here?

Thanks in advance

Thomas

 

Complete configuration:

ee-vswitch1# sh run

!Command: show running-config
!Time: Mon Aug 18 17:04:13 2014

version 4.2(1)SV2(2.2)
svs switch edition essential

no feature telnet
feature lacp
feature vtracker

username admin password 5 *  role network-admin
username orion password 5 *  role network-operator

banner motd #Nexus 1000v Switch#

ssh key rsa 2048
ip domain-lookup
ip host ee-vswitch1 172.17.72.21
radius-server host * key 7 * auth-port 1645 acct-port 1646 authentication accounting timeout 5
aaa group server radius AD-authentication
    server *
    use-vrf management
hostname ee-vswitch1
errdisable recovery cause failed-port-state
class-map type queuing match-all vm_gold_class
  match cos 4
class-map type queuing match-all vmotion_class
  match protocol vmw_vmotion
class-map type queuing match-all vmw_mgmt_class
  match protocol vmw_mgmt
class-map type queuing match-all vm_platinum_class
  match cos 5
class-map type queuing match-any n1kv_control_packet_class
  match protocol n1k_control
  match protocol n1k_packet
  match protocol n1k_mgmt
policy-map type qos gold_in_mark
  class class-default
    set cos 4
policy-map type qos platinum_in_mark
  class class-default
    set cos 5
policy-map type queuing uplink_queue_policy
  class type queuing n1kv_control_packet_class
    bandwidth percent 15
  class type queuing vmotion_class
    bandwidth percent 20
  class type queuing vmw_mgmt_class
    bandwidth percent 15
  class type queuing vm_gold_class
    bandwidth percent 20
  class type queuing vm_platinum_class
    bandwidth percent 30
vem 3
  host id 34353835-3631-435a-4338-333334315a42
vem 4
  host id 34353835-3631-435a-4338-333334315a39
snmp-server user admin network-admin auth md5 * priv * localizedkey
snmp-server user orion network-operator auth sha * priv aes-128 * localizedkey
ntp server 172.17.72.1 prefer
aaa authentication login default group AD-authentication

vrf context management
  ip route 0.0.0.0/0 172.17.72.1
vlan 1,115,187,304,373
vlan 115
  name clients_115
vlan 187
  name clients_187

lacp offload
port-channel load-balance ethernet source-mac
port-profile default max-ports 32
port-profile default port-binding static
port-profile type ethernet Unused_Or_Quarantine_Uplink
  vmware port-group
  shutdown
  description Port-group created for Nexus1000V internal usage. Do not use.
  state enabled
port-profile type vethernet Unused_Or_Quarantine_Veth
  vmware port-group
  shutdown
  description Port-group created for Nexus1000V internal usage. Do not use.
  state enabled
port-profile type ethernet Uplink_QoS
  vmware port-group
  switchport mode trunk
  switchport trunk allowed vlan 115,187,304
  service-policy type queuing output uplink_queue_policy
  channel-group auto mode active
  no shutdown
  system vlan 115,304
  state enabled
port-profile type vethernet VLAN115-Clients
  vmware port-group
  switchport mode access
  switchport access vlan 115
  service-policy type qos input platinum_in_mark
  no shutdown
  state enabled
port-profile type ethernet Uplink
  vmware port-group
  switchport mode trunk
  switchport trunk allowed vlan 115,187
  channel-group auto mode active
  no shutdown
  state enabled
port-profile type vethernet n1kv-veth-vlan-115-l3
  capability l3control
  vmware port-group
  port-binding static auto expand
  switchport mode access
  switchport access vlan 115
  no shutdown
  system vlan 115
  max-ports 256
  min-ports 16
  state enabled
port-profile type vethernet n1kv-veth-vlan-304
  vmware port-group
  port-binding static auto expand
  switchport mode access
  switchport access vlan 304
  no shutdown
  system vlan 304
  max-ports 256
  min-ports 16
  state enabled
port-profile type ethernet n1kv-eth-5
  vmware port-group
  switchport mode trunk
  switchport trunk allowed vlan 115,304
  switchport trunk native vlan 1
  channel-group auto mode active
  no shutdown
  system vlan 115,304
  state enabled
port-profile type vethernet VLAN187-Clients
  vmware port-group
  switchport mode access
  switchport access vlan 187
  no shutdown
  state enabled

system storage-loss log time 30
vdc ee-vswitch1 id 1
  limit-resource vlan minimum 16 maximum 2049
  limit-resource monitor-session minimum 0 maximum 2
  limit-resource vrf minimum 16 maximum 8192
  limit-resource port-channel minimum 0 maximum 768
  limit-resource u4route-mem minimum 1 maximum 1
  limit-resource u6route-mem minimum 1 maximum 1

interface port-channel7
  inherit port-profile Uplink_QoS
  vem 3

interface port-channel8
  inherit port-profile Uplink_QoS
  vem 4

interface mgmt0
  ip address 172.17.72.21/24

interface Vethernet1
  inherit port-profile n1kv-veth-vlan-115-l3
  description VMware VMkernel, vmk0
  vmware dvport 384 dvswitch uuid "03 ae 0e 50 7e 57 a8 f1-a9 65 9f 5e e6 d0 56 1c"
  vmware vm mac 0021.5ACA.788C

interface Vethernet2
  inherit port-profile VLAN115-Clients
  description nex-vm1, Network Adapter 1
  vmware dvport 320 dvswitch uuid "03 ae 0e 50 7e 57 a8 f1-a9 65 9f 5e e6 d0 56 1c"
  vmware vm mac 0050.568E.09C1

interface Vethernet3
  inherit port-profile VLAN115-Clients
  description du-vc1, Network Adapter 1
  vmware dvport 321 dvswitch uuid "03 ae 0e 50 7e 57 a8 f1-a9 65 9f 5e e6 d0 56 1c"
  vmware vm mac 000C.29F5.49E7

interface Vethernet4
  inherit port-profile VLAN115-Clients
  description nex-vm2, Network Adapter 1
  no shutdown
  vmware dvport 322 dvswitch uuid "03 ae 0e 50 7e 57 a8 f1-a9 65 9f 5e e6 d0 56 1c"
  vmware vm mac 0050.568E.2C44

interface Vethernet5
  inherit port-profile VLAN115-Clients
  description nex-vm3, Network Adapter 1
  vmware dvport 323 dvswitch uuid "03 ae 0e 50 7e 57 a8 f1-a9 65 9f 5e e6 d0 56 1c"
  vmware vm mac 0050.568E.4129

interface Vethernet6
  inherit port-profile n1kv-veth-vlan-304
  description VMware VMkernel, vmk1
  vmware dvport 400 dvswitch uuid "03 ae 0e 50 7e 57 a8 f1-a9 65 9f 5e e6 d0 56 1c"
  vmware vm mac 0050.5668.0A35

interface Vethernet7
  inherit port-profile n1kv-veth-vlan-115-l3
  description VMware VMkernel, vmk0
  vmware dvport 385 dvswitch uuid "03 ae 0e 50 7e 57 a8 f1-a9 65 9f 5e e6 d0 56 1c"
  vmware vm mac 0021.5ACA.FEF2

interface Vethernet8
  inherit port-profile n1kv-veth-vlan-304
  description VMware VMkernel, vmk1
  vmware dvport 401 dvswitch uuid "03 ae 0e 50 7e 57 a8 f1-a9 65 9f 5e e6 d0 56 1c"
  vmware vm mac 0050.566E.9FC0

interface Ethernet3/1
  inherit port-profile Uplink_QoS
  description uplink ctrl du-esx101

interface Ethernet3/2
  inherit port-profile Uplink_QoS
  description uplink VMs du-esx101

interface Ethernet3/3
  inherit port-profile Uplink_QoS
  description uplink ctrl du-esx101

interface Ethernet3/4
  inherit port-profile Uplink_QoS
  description uplink VMs du-esx101

interface Ethernet4/1
  inherit port-profile Uplink_QoS
  description uplink ctrl du-esx102

interface Ethernet4/2
  inherit port-profile Uplink_QoS
  description uplink VMs du-esx102

interface Ethernet4/3
  inherit port-profile Uplink_QoS
  description uplink ctrl du-esx102

interface Ethernet4/4
  inherit port-profile Uplink_QoS
  description uplink VMs du-esx102

interface control0
clock timezone MET 1 0
clock summer-time MEST 5 sunday march 02:00 5 sunday October 03:00 60
line console
boot kickstart bootflash:/nexus-1000v-kickstart.4.2.1.SV2.2.2.bin sup-1
boot system bootflash:/nexus-1000v.4.2.1.SV2.2.2.bin sup-1
boot kickstart bootflash:/nexus-1000v-kickstart.4.2.1.SV2.2.2.bin sup-2
boot system bootflash:/nexus-1000v.4.2.1.SV2.2.2.bin sup-2
svs-domain
  domain id 2
  control vlan 373
  packet vlan 373
  svs mode L3 interface mgmt0
svs connection vcenter
  protocol vmware-vim
  remote ip address * port 80
  vmware dvs uuid "03 ae 0e 50 7e 57 a8 f1-a9 65 9f 5e e6 d0 56 1c" datacenter-name center1
  admin user *
  max-ports 8192
  connect
vservice global type vsg
  tcp state-checks invalid-ack
  tcp state-checks seq-past-window
  no tcp state-checks window-variation
  no bypass asa-traffic
vnm-policy-agent
  registration-ip 0.0.0.0
  shared-secret **********
  log-level info
logging server *

 

 

 

 

 

 

 

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion