×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

SFP-GE-T not working on ASR1001

Answered Question
Aug 18th, 2014
User Badges:

Hi all,

 

I have 2 ASR1001 and I'm trying to bring up a direct link between them.

The SFP that I used is SFP-GE-T which is supported.

ASRs are running the recommended IOS XE release 3.7.6S.

The config of both interfaces is extremely simple:

interface GigabitEthernet0/0/0
 ip address xxxx
 negotiation auto
 no shutdown

!

The SFP are recognised and seems to work well:

 


Router1#sh hw-module subslot 0/0 transceiver 0 idprom 
IDPROM for transceiver GigabitEthernet0/0/0:
  Description                               = SFP or SFP+ optics (type 3)
  Transceiver Type:                         = GE T (26)
  Product Identifier (PID)                  = N/A                 
  Vendor Revision                           =     
  Serial Number (SN)                        = MTC150304G3     
  Vendor Name                               = CISCO-METHODE   
  Vendor OUI (IEEE company ID)              = 00.0B.40 (2880)
  CLEI code                                 = 
  Cisco part number                         = 
  Device State                              = Enabled.
  Date code (yy/mm/dd)                      = 20/11/01
  Connector type                            = Unknown.
  Encoding                                  = 8B10B
                                              NRZ
  Nominal bitrate                           =  (0 Mbits/s)
  Minimum bit rate as % of nominal bit rate = not specified
  Maximum bit rate as % of nominal bit rate = not specified

Router1#sh hw-module subslot 0/0 transceiver 0 status 
The Transceiver in slot 0 subslot 0 port 0 is enabled.
  Sensor Data is not supported by this transceiver
 

Router2#sh hw-module subslot 0/0 transceiver 0 idprom 
IDPROM for transceiver GigabitEthernet0/0/0:
  Description                               = SFP or SFP+ optics (type 3)
  Transceiver Type:                         = GE T (26)
  Product Identifier (PID)                  = N/A                 
  Vendor Revision                           =     
  Serial Number (SN)                        = MTC150304G9     
  Vendor Name                               = CISCO-METHODE   
  Vendor OUI (IEEE company ID)              = 00.0B.40 (2880)
  CLEI code                                 = 
  Cisco part number                         = 
  Device State                              = Enabled.
  Date code (yy/mm/dd)                      = 20/11/01
  Connector type                            = Unknown.
  Encoding                                  = 8B10B
                                              NRZ
  Nominal bitrate                           =  (0 Mbits/s)
  Minimum bit rate as % of nominal bit rate = not specified
  Maximum bit rate as % of nominal bit rate = not specified

Router2#sh hw-module subslot 0/0 transceiver 0 status 
The Transceiver in slot 0 subslot 0 port 0 is enabled.
  Sensor Data is not supported by this transceiver

I already tried to:

- change RJ-45 cable

- use cat 6 and cat 5e cables

- disable and enable autonegotiation

- move the config to another GigabitEthernet port

 

I haven't any spare SFP-GE-T so I couldn't try to change them.

On the same routers I have another port (GigabitEthernet0/0/3) with SFP-SX-MMD and it is up and running.

 

Any suggestion?

 

Regards

Stefano

Correct Answer by Leo Laohoo about 2 years 12 months ago

Go HERE and scroll down to Table B-8.  See the part number?  It's for a 30-1421-01.  So I was wrong when I said that the "04" is supported.  

 

If you need to order more, make sure you specify to the vendor the SKU code of "30-1421-01".

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Loading.
Leo Laohoo Mon, 08/18/2014 - 15:22
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

interface GigabitEthernet0/0/0
 negotiation auto

ASR don't support auto negotiation.  You need to specify the speed and the duplex settings.  

 

Post the picture of the SFP as well if is still doesn't work.  There are certain hardware revisions of the SFP that the ASR supports.

s-durando Mon, 08/18/2014 - 23:13
User Badges:

Hi Leo,

 

thanks for your support.

I already tried to disable auto negotiation and specify speed and duplex settings.

Now I'm going to check hardware revision of the SFP as you suggested.

 

Stefano

Leo Laohoo Tue, 08/19/2014 - 02:34
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Look at the SFP.  Did you see the value 30-1421-04?  The "04" is the hardware revision number and it should be supported.  

 

I think you need to raise a TAC Case.

s-durando Wed, 08/20/2014 - 06:06
User Badges:

Hi Leo,

I used another SFP-GE-T with part number 30-1421-01 and it works fine.

Anyway the SFPs with part number 30-1421-04 are not broken. I tested them on a Catalyst 3750 and they work fine.

Maybe there is an incompatibility between ASR 1001 and SFP-GE-T with part number 30-1421-04.

 

Regards

Stefano

Correct Answer
Leo Laohoo Wed, 08/20/2014 - 15:46
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Go HERE and scroll down to Table B-8.  See the part number?  It's for a 30-1421-01.  So I was wrong when I said that the "04" is supported.  

 

If you need to order more, make sure you specify to the vendor the SKU code of "30-1421-01".

sajiporu1 Sat, 01/10/2015 - 07:27
User Badges:

Dear s-durando,

Were u able to solve the SFP-GE-T and ASR 1001 incompatibility issues.

 

 

s-durando Sun, 01/11/2015 - 23:54
User Badges:

Yes I solved the problem by replacing with GLC-T with hardware revision number (or TAN = top assembly number) equal to 30-1421-01

Stefano

s-durando Tue, 08/19/2014 - 00:03
User Badges:

Hi Leo,

I attached the picture of SFP.

How can I verify if hardware revision is not supported?

 

Regards

Stefano

Attachment: 

Actions

This Discussion