MLDP MVPN no multicast in MDT data

Unanswered Question
Aug 26th, 2014
User Badges:

Hello colleagues.

We are trying to configure mldp-based mvpn in our mpls network (6500 with sup720-3C and 2T). But we have the problem: no multicast traffic at receiver PE from mdt data.

I'm sure that our streamers are OK, because R1-source has STBs connected to it (behind SVI vlan16) and these STBs get multicast.

Have you any ideas why we can't get multicast at R2 ?

Here are outputs of commands:

R1-source#
ip multicast-routing
ip multicast-routing vrf IPTV
!
ip vrf IPTV
 rd 65530:16
 vpn id 65530:16
 mdt preference mldp
 mdt default mpls mldp 10.20.100.1
 mdt data mpls mldp 100
 mdt data threshold 20
 route-target export 65530:16
 route-target import 65530:16
!
!
interface Vlan16
 description IPTV-STB
 ip vrf forwarding IPTV
 ip address 10.0.0.1 255.255.0.0
 ip helper-address 10.1.1.1
 no ip unreachables
 ip pim sparse-mode
!
interface Vlan116
 description Link-to-DHCP
 ip vrf forwarding IPTV
 ip address 10.25.116.1 255.255.255.252
 no ip unreachables
 ip pim sparse-mode
!
interface Vlan1116
 description IPTV-Streamers
 ip vrf forwarding IPTV
 ip address 192.168.1.1 255.255.0.0
 no ip unreachables
 ip pim sparse-mode
!
interface Loopback0
 description *** ROUTER ID ***
 ip address 10.20.100.11 255.255.255.255
 ip pim sparse-mode
!
router eigrp 100
 !
 address-family ipv4 vrf IPTV
  redistribute bgp 65530 metric 10000000 1 255 1 1500
  network 10.0.0.0 0.0.255.255
  network 10.25.116.0 0.0.0.3
  network 172.17.16.0 0.0.0.255
  passive-interface default
  no passive-interface Vlan116
  autonomous-system 100
  eigrp router-id 10.25.116.1
  nsf
 exit-address-family
 variance 2
 network 10.0.0.0
 redistribute connected
 redistribute static
 passive-interface default
 no passive-interface TenGigabitEthernet1/4/8
 no passive-interface TenGigabitEthernet2/4/8
 eigrp router-id 10.20.20.9
 nsf
!
router bgp 65530
 bgp router-id 10.20.100.11
 bgp log-neighbor-changes
 no bgp default ipv4-unicast
 neighbor 10.20.100.1 remote-as 65530
 neighbor 10.20.100.1 update-source Loopback0
 !
 address-family ipv4
 exit-address-family
 !
 address-family vpnv4
  neighbor 10.20.100.1 activate
  neighbor 10.20.100.1 send-community extended
 exit-address-family
 !
 address-family ipv4 mdt
  neighbor 10.20.100.1 activate
  neighbor 10.20.100.1 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf IPTV
  redistribute connected
  redistribute eigrp 100
 exit-address-family

 


R1-source#sh ip mr vr IPTV 239.1.1.1
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group,
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
       Q - Received BGP S-A Route, q - Sent BGP S-A Route,
       V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.1.1.1), 1d00h/00:03:25, RP 192.168.1.1, flags: SJC
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Lspvif1, Forward/Sparse, 00:00:04/00:03:25
    Vlan1116, Forward/Sparse, 1d00h/00:02:26
    Vlan16, Forward/Sparse, 1d00h/00:02:44

(192.168.1.101, 239.1.1.1), 17:34:12/00:02:52, flags: T
  Incoming interface: Vlan1116, RPF nbr 0.0.0.0, RPF-MFD
  Outgoing interface list:
    Lspvif1, Forward/Sparse, 00:00:04/00:03:25
    Vlan16, Forward/Sparse, 1d00h/00:02:44, H

 

R1-source#sh ip pim vr IPTV ne
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
10.25.116.2       Vlan116                  6d18h/00:01:26    v2    1 / DR S P G
10.20.100.1       Lspvif1                  00:58:07/00:01:16 v2    1 / S P G
10.20.100.3       Lspvif1                  00:58:07/00:01:36 v2    1 / S P G

 


R1-source#sh ip pim vrf IPTV bsr-router
PIMv2 Bootstrap information
This system is the Bootstrap Router (BSR)
  BSR address: 192.168.1.1 (?)
  Uptime:      1d17h, BSR Priority: 0, Hash mask length: 0
  Next bootstrap message in 00:00:54
  Candidate RP: 192.168.1.1(Vlan1116)
    Holdtime 150 seconds
    Advertisement interval 60 seconds
    Next advertisement in 00:00:32

 


R1-source#sh ip pim vrf IPTV rp 239.1.1.1
Group: 239.1.1.1, RP: 192.168.1.1, v2, next RP-reachable in 00:00:49

 


R1-source#sh mpls mldp database
  * Indicates MLDP recursive forwarding is enabled

LSM ID : 1E   Type: P2MP   Uptime : 00:12:56
  FEC Root           : 10.20.100.11 (we are the root)
  Opaque decoded     : [mdt 65530:16 1]
  Opaque length      : 11 bytes
  Opaque value       : 02 000B 0655300000001600000001
  Upstream client(s) :
    None
      Expires        : N/A           Path Set ID  : 20
  Replication client(s):
    10.20.100.1:0
      Uptime         : 00:12:56      Path Set ID  : None
      Out label (D)  : 44            Interface    : TenGigabitEthernet1/4/8*
      Local label (U): None          Next Hop     : 10.20.10.57

LSM ID : 1F   Type: P2MP   Uptime : 00:01:47
  FEC Root           : 10.20.100.11 (we are the root)
  Opaque decoded     : [mdt 65530:16 2]
  Opaque length      : 11 bytes
  Opaque value       : 02 000B 0655300000001600000002
  Upstream client(s) :
    None
      Expires        : N/A           Path Set ID  : 21
  Replication client(s):
    MDT  (VRF IPTV)
      Uptime         : 00:01:47      Path Set ID  : None
      Interface      : Lspvif1
    10.20.100.1:0
      Uptime         : 00:01:47      Path Set ID  : None
      Out label (D)  : 45            Interface    : TenGigabitEthernet1/4/8*
      Local label (U): None          Next Hop     : 10.20.10.57

LSM ID : 19 (RNR LSM ID: 1A)   Type: MP2MP   Uptime : 1d00h
  FEC Root           : 10.20.100.1
  Opaque decoded     : [mdt 65530:16 0]
  Opaque length      : 11 bytes
  Opaque value       : 02 000B 0655300000001600000000
  RNR active LSP     : (this entry)
  Upstream client(s) :
    10.20.100.1:0    [Active]
      Expires        : Never         Path Set ID  : 1B
      Out Label (U)  : 98            Interface    : TenGigabitEthernet1/4/8*
      Local Label (D): 150           Next Hop     : 10.20.10.57
  Replication client(s):
    MDT  (VRF IPTV)
      Uptime         : 1d00h         Path Set ID  : 1C
      Interface      : Lspvif1

 

R1-source#sh adjacency lspvif 1
Protocol Interface                 Address
IP       Lspvif1                   225.0.0.0(3)
IP       Lspvif1                   225.0.0.0(3)

 

 

 

 

R2-receiver#
ip multicast-routing
ip multicast-routing vrf IPTV
!
ip vrf IPTV
 rd 65530:16
 vpn id 65530:16
 mdt preference mldp
 mdt default mpls mldp 10.20.100.1
 mdt data mpls mldp 100
 mdt data threshold 20
 route-target export 65530:16
 route-target import 65530:16
!
!
interface Vlan16
 description IPTV-STB
 ip vrf forwarding IPTV
 ip address 10.2.0.1 255.255.0.0
 ip helper-address 10.1.1.1
 ip pim sparse-mode
!
interface Loopback0
 description *** Router ID Global ***
 ip address 10.20.100.1 255.255.255.255
 ip pim sparse-mode
!
router bgp 65530
 bgp router-id 10.20.100.1
 bgp log-neighbor-changes
 no bgp default ipv4-unicast
 neighbor campus peer-group
 neighbor campus remote-as 65530
 neighbor campus update-source Loopback0
 neighbor 10.20.100.2 peer-group campus
 neighbor 10.20.100.3 peer-group campus
 neighbor 10.20.100.4 peer-group campus
 neighbor 10.20.100.5 peer-group campus
 neighbor 10.20.100.6 peer-group campus
 neighbor 10.20.100.7 peer-group campus
 neighbor 10.20.100.8 peer-group campus
 neighbor 10.20.100.9 peer-group campus
 neighbor 10.20.100.10 peer-group campus
 neighbor 10.20.100.11 peer-group campus
 neighbor 10.20.100.253 peer-group campus
 !
 address-family ipv4
 exit-address-family
 !
 address-family vpnv4
  neighbor campus send-community extended
  neighbor campus route-reflector-client
  neighbor 10.20.100.2 activate
  neighbor 10.20.100.3 activate
  neighbor 10.20.100.4 activate
  neighbor 10.20.100.5 activate
  neighbor 10.20.100.6 activate
  neighbor 10.20.100.7 activate
  neighbor 10.20.100.8 activate
  neighbor 10.20.100.9 activate
  neighbor 10.20.100.10 activate
  neighbor 10.20.100.11 activate
  neighbor 10.20.100.253 activate
 exit-address-family
 !
 address-family ipv4 mdt
  neighbor campus send-community extended
  neighbor campus route-reflector-client
  neighbor 10.20.100.11 activate
 exit-address-family
 !
 address-family ipv4 vrf IPTV
  redistribute connected
 exit-address-family

 

R2-receiver#sh ip mr vr IPTV 239.1.1.1
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group,
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
       Q - Received BGP S-A Route, q - Sent BGP S-A Route,
       V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.1.1.1), 00:11:34/stopped, RP 192.168.1.1, flags: SJC
  Incoming interface: Lspvif1, RPF nbr 10.20.100.11
  Outgoing interface list:
    Vlan16, Forward/Sparse, 00:11:34/00:02:38

(192.168.1.101, 239.1.1.1), 00:11:28/00:02:51, flags: TY
  Incoming interface: Lspvif1, RPF nbr 10.20.100.11, MDT: [2, 10.20.100.11]/00:02:51
  Outgoing interface list:
    Vlan16, Forward/Sparse, 00:11:28/00:02:38

 


R2-receiver#sh ip pim vr IPTV ne
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
10.20.100.11      Lspvif1                  18:56:29/00:01:26 v2    1 / DR S P G
10.20.100.3       Lspvif1                  18:56:29/00:01:42 v2    1 / S P G

 


R2-receiver#sh ip pim vrf IPTV bsr-router
PIMv2 Bootstrap information
  BSR address: 192.168.1.1 (?)
  Uptime:      18:56:50, BSR Priority: 0, Hash mask length: 0
  Expires:     00:01:57
This system is a candidate BSR
  Candidate BSR address: 10.2.0.1, priority: 0, hash mask length: 0

 


R2-receiver#sh ip pim vrf IPTV rp 239.1.1.1
Group: 239.1.1.1, RP: 192.168.1.1, v2, uptime 18:57:18, expires 00:01:45

 


R2-receiver#sh mpls mldp database
  * Indicates MLDP recursive forwarding is enabled

LSM ID : 21   Type: P2MP   Uptime : 00:13:11
  FEC Root           : 10.20.100.11
  Opaque decoded     : [mdt 65530:16 2]
  Opaque length      : 11 bytes
  Opaque value       : 02 000B 0655300000001600000002
  Upstream client(s) :
    10.20.100.11:0    [Active]
      Expires        : Never         Path Set ID  : 2A
      Out Label (U)  : None          Interface    : TenGigabitEthernet2/1/4*
      Local Label (D): 45            Next Hop     : 10.20.10.158
  Replication client(s):
    MDT  (VRF IPTV)
      Uptime         : 00:13:11      Path Set ID  : None
      Interface      : Lspvif1

LSM ID : B (RNR LSM ID: 1D)   Type: MP2MP   Uptime : 6d19h
  FEC Root           : 10.20.100.1 (we are the root)
  Opaque decoded     : [mdt 65530:16 0]
  Opaque length      : 11 bytes
  Opaque value       : 02 000B 0655300000001600000000
  RNR active LSP     : (this entry)
  Upstream client(s) :
    None
      Expires        : N/A           Path Set ID  : E
  Replication client(s):
    10.20.100.11:0
      Uptime         : 23:13:12      Path Set ID  : 22
      Out label (D)  : 150           Interface    : TenGigabitEthernet2/1/4*
      Local label (U): 98            Next Hop     : 10.20.10.158
    10.20.100.3:0
      Uptime         : 23:12:49      Path Set ID  : 25
      Out label (D)  : 27            Interface    : TenGigabitEthernet1/9/2*
      Local label (U): 127           Next Hop     : 10.20.10.14
    MDT  (VRF IPTV)
      Uptime         : 18:57:44      Path Set ID  : 26
      Interface      : Lspvif1

 

R2-receiver#sh adjacency lspvif 1
Protocol Interface                 Address
IP       Lspvif1                   225.0.0.0(2) (incomplete)
IP       Lspvif1                   225.0.0.0(4)

 

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
LLC Svod Intern... Wed, 05/20/2015 - 04:34
User Badges:

Information from TAC:
Sup720 doesn't support in hardware mldp.
That's why I have to use old mvrf.

Actions

This Discussion