×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Can't ping outside network or internet from second cisco router

Answered Question
Sep 5th, 2014
User Badges:

Hi I'm new to cisco and networking in general and I am having a problem with my setup. I am using Todd Lammle's book as a guide. I have an apple extreme as my home router and have connected a cisco 2800, call it Corp, to one of its ethernet ports. From there I connected another 2800, call it SF, to the first cisco 2800 through s0/1/0. Corp f0/0 is on the same network 10.0.0.0 as my apple router and can ping everything including the internet and the 172.16.0.0 network which is where SF. The problem is SF can ping Corp but nothing outside of it. Also my computer on 10.0.0.0 can't ping SF either. Here is my config:

Corp Router

interface FastEthernet0/0

 description Connection to Apple Router

 ip address 10.0.0.2 255.255.255.0

 duplex auto

 speed auto

!         

interface FastEthernet0/1

 no ip address

 shutdown 

 duplex auto

 speed auto

!         

interface Serial0/1/0

 ip address 172.16.10.1 255.255.255.252

 clock rate 125000

!         

interface Serial0/1/1

 ip address 172.16.10.5 255.255.255.252

!         

router rip

 version 2

 network 10.0.0.0

 network 172.16.0.0

 default-information originate

 no auto-summary

!         

ip forward-protocol nd

!         

ip http server

ip http authentication local

ip http secure-server

!         

ip route 0.0.0.0 0.0.0.0 10.0.0.1

 

 

SF Router

 

interface FastEthernet0/0

 no ip address

 shutdown 

 duplex auto

 speed auto

!         

interface FastEthernet0/1

 no ip address

 shutdown 

 duplex auto

 speed auto

!         

interface Serial0/1/0

 description Connection to Corp

 ip address 172.16.10.2 255.255.255.252

!         

interface Serial0/1/1

 no ip address

 shutdown 

 clock rate 125000

!         

router rip

 version 2

 network 172.16.0.0

 network 192.168.10.0

 no auto-summary

!         

 

 

This is the first time I ever ask a blog a question but I been at this for a few days and just can't find the answer. Thank you in advance.

Correct Answer by Martin Moran about 2 years 11 months ago

Hey buddy!

Sorry for the delay! Too much work for this week.

I looked at your config and everything looks fine except for the following:

  • In SF router, you should specify the "version" of RIP and the "no auto-summary" command.
    • By default, RIPv1 accepts RIPv2 updates but RIPv2 doesn't accept RIPv1 updates. That's why your subnet 192.168.10.0/24 doesn't show up in the Corp routing table
  • At the Corp router, in the Fa 0/0 you don't have to specify the IP helper command because the DHCP server is Corp router. Remove it and it will work
  • Always name your interfaces to avoid getting confused

Other than that, the only change that you should do is the version and summary commands in the RIP process of SF router.

I let some files attached for review. Look at them and let me know. That thing should work now bro.

Rgrds,

Martin, IT Specialist

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (6 ratings)
Loading.
Martin Moran Fri, 09/05/2014 - 11:58
User Badges:
  • Bronze, 100 points or more

Hey @catre032882,

A few questions to help you solve the problem:

  • Can SF ping 10.0.0.2 (which is the interface of Corp in the 10.0.0.0 network)?
  • What is the default gateway of the computer that you were pinging SF?

Hint: If SF can't ping the Apple Router maybe is because the AppleRouter doesn't know how to reach network 172.16.x.x.

Hope to see your answers.

Rgrds,

Martin, IT Specialist

Carlos Trevino Fri, 09/05/2014 - 14:38
User Badges:

Yes SF can ping 10.0.0.2 and vise versa. The default gateway was 10.0.0.1 since that is my home router. I figure there is a problem setting up my practice network behind my Apple router just hoping there is a way to do it.

Martin Moran Fri, 09/05/2014 - 18:10
User Badges:
  • Bronze, 100 points or more

Hi @catre032882,

I think we're very close. Since you can ping 10.0.0.2, that tells me that the problem is obviously in the Apple router. You can try the following:

  • Try to ping 10.0.0.1 from SF: If that ping doesn't work then It tells you that the Apple router doesn't know how to reach subnet 172.16.0.0.
    • Possible solution: Set a static route in Apple router to reach subnet 172.16.0.0 and Corp router as the next hop.
  • From your computer, change the default gateway to be 10.0.0.2 (Corp router) and I bet you will ping SF from there.

Hope to see your answers.

Rgrds,

Martin, IT Specialist

Carlos Trevino Wed, 09/10/2014 - 16:02
User Badges:

Just a friendly update. I was able to make it work :) I set up NAT on the cisco router and changed the default dns to an actual dns server and everything on the Corp router started working. Sadly the routers below it still are not. I believe that is a issue with my routing table. 

Martin Moran Wed, 09/10/2014 - 19:49
User Badges:
  • Bronze, 100 points or more

I'm glad to hear that!

Can you share the new config of both Cisco routers as well as the "show ip route"? (please attach them as a .txt file for simplicity)

Don't forget to rate :P

HTH.

Rgrds,

Martin, IT Specialist

Carlos Trevino Thu, 09/11/2014 - 09:47
User Badges:

Here are my configs and ip routes. I know its going to be something dumb I forgot or something like that. I hope you can help been at this for a while already. It seems when its not one thing its another.

Attachment: 
Correct Answer
Martin Moran Sat, 09/13/2014 - 16:28
User Badges:
  • Bronze, 100 points or more

Hey buddy!

Sorry for the delay! Too much work for this week.

I looked at your config and everything looks fine except for the following:

  • In SF router, you should specify the "version" of RIP and the "no auto-summary" command.
    • By default, RIPv1 accepts RIPv2 updates but RIPv2 doesn't accept RIPv1 updates. That's why your subnet 192.168.10.0/24 doesn't show up in the Corp routing table
  • At the Corp router, in the Fa 0/0 you don't have to specify the IP helper command because the DHCP server is Corp router. Remove it and it will work
  • Always name your interfaces to avoid getting confused

Other than that, the only change that you should do is the version and summary commands in the RIP process of SF router.

I let some files attached for review. Look at them and let me know. That thing should work now bro.

Rgrds,

Martin, IT Specialist

Carlos Trevino Tue, 09/16/2014 - 10:11
User Badges:

That did it! Your Awesome! Everything seems to be running smoothly now. No to my next challenge setting up a VLAN with switches. I'm trying to learn as much as I can, so hope you don't mind me remembering your name. I am sure to need help again soon. Thank you again you saved me from many headaches. 

Carlos Trevino Tue, 09/16/2014 - 11:44
User Badges:

Ok I thought that was it but there is one more problem. Its so slow. Corp LAN is fast but SF LAN is super slow. Even when I ssh from Corp to SF typing in SF lags. The routers are connected with serial ports would this slow them down so much or is it my config?

Martin Moran Tue, 09/16/2014 - 12:20
User Badges:
  • Bronze, 100 points or more

Hey @Carlos,

I'm glad to hear that it works for you.

Try to set the default bandwidth command on the serial interfaces (both of them to 1.5 Mbps):

interface serial x/x

 bandwidth 1544

NOTE: The bandwidth command doesn't increment the actual bandwidth that a link can give. It is just a referencial command to communicate the high level protocols (routing protocols for example). TCP will also adjust its initial retransmission parameters based on the bandwidth configured with this command.

You cannot use this command to expect that a T1 link (which gives 1.5 Mbps) gives 4 Mbps, for example.

If you wanna know more about the bandwidth command, please refer to the following link: http://www.techrepublic.com/article/clarifying-the-cisco-ios-bandwidth-c...

Let me know if this could help you in something.

Rgrds,

Martin, IT Specialist

 

Carlos Trevino Tue, 09/16/2014 - 12:49
User Badges:

So the most I can get is 1.5 Mbps on a serial compared to 100 Mbps on my ethernet. Doesn't that bottle neck an entire network? Why would anyone use serial ports to link routers in any network? If I want speed at least in my home network should I change the serial ports to ethernet ports?

Martin Moran Tue, 09/16/2014 - 12:57
User Badges:
  • Bronze, 100 points or more

You're totally right! But in your case you cannot get so much bandwidth through Serial interfaces. If you have the chance to change to Ethernet then do it. It's up to you.

Most of the scenarios where Serial interfaces are used when you want to connect remote offices to the central office and there is no possibility to rent a link through MetroEthernet, for example.

Rgrds,

Martin, IT Specialist

Actions

This Discussion