xlate 5 digit extensions to a queue

Answered Question
Sep 10th, 2014
User Badges:

Hi, our client services team each has a separate call center extension.  So they have one line for personal and one for call center.  Users are now calling their 5 digit call center line instead of the HD number bypassing the call center all together.  I understand this could have been avoided ahead of time but the extensions are now known so...

I want to be able to route any calls from internal users that dial their 5 digit call center extension directly to the CTI RP call center queue.  Is there a way of doing this?  I created a xlation pattern 1110[0-9] to route to the CTI but the since the dialed number matches the 5 digit that take precedence over this xlation pattern.

Any idea's?

 

Thanks!

Correct Answer by Jaime Valencia about 2 years 11 months ago

Either you modify all together the CSS from the users so they cannot reach the direct DNs, and then only match the TP with wildcards, or you will need to modify the CSS with a new partition, make sure it's above the one to which your users belong, and create the TPs with the exact same number as the users have.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
Jaime Valencia Wed, 09/10/2014 - 13:01
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    2011

Either you modify all together the CSS from the users so they cannot reach the direct DNs, and then only match the TP with wildcards, or you will need to modify the CSS with a new partition, make sure it's above the one to which your users belong, and create the TPs with the exact same number as the users have.

Yort Mantup Thu, 09/11/2014 - 06:25
User Badges:

Jaime,

Great idea's.  Option 1 is not an option  :).   Went with option 2 and created a new partition and then a TP with the UCCX extensions only assigned to the new partition.  Works perfect.  However, the change is bouncing them from ready to not ready when a call hits the help desk queue.  Also when I dial the UCCX extension directly, it triggers my CAD from ready to Not Ready.

I am thinking I need to change the CSS or Partition in the application for the trigger??

Yort Mantup Thu, 09/11/2014 - 06:50
User Badges:

Found my issue.  Seems to be working now.  Thanks for the help.

Actions

This Discussion