×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Assigning a static IP address to a router within private network

Unanswered Question
Sep 19th, 2014
User Badges:

Here is my current topology:

 

ISP Modem --------------------(fa0/0) R1 fa(0/1)-----------------S1-----------------------(fa0/0) R2   (fa 0/1)---------------S2

                                    11.22.33.44       172.16.0.1      172.16.0.2                        dhcp       192.168.0.1        192.168.0.2

R1 is the DHCP server.

 

My R1 is our production router for the rest of our office. I am trying to set u a lab environment within our network by using a Cisco 1841(R2) Router connected to the switch. I've added ACL rules, NAT, and NAT Overload already to R2. When I use dhcp on R2, I am able to access the internet when connected onto the 192168.0.0 network.  

Issue #1:

R2 is able to ping R1 and the 172.16.0.0/24 network, but I am not able to ping FROM R1 to R2. I am able to access the internet when connected to R2's network.

 

Issue #2:

I want to consolidate all my static IP addresses so I excluded addresses 172.16.0.1 to 172.16.0.20 on R1's dhcp pool. However, when I assigned a static IP address such as 172.16.0.5 to fa0/0 of R2, I am no longer able to access the internet. I also cannot ping R1 from R2 anymore.  I would like to be able to assign static IP addresses on a few routers of labs that we are setting up. Thanks

 

Best Regards,

Sean

            

                              

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joseph Nelson Sat, 09/20/2014 - 14:48
User Badges:

Hi Sean,

 

Regarding #1:

  • Which interface on R2 did you try to ping from R1? and
  • What source address on R1 did you use?
  • I'm assuming you aren't using a routing protocol between R1 and R2?
  • If you can access the internet as you say, I'm assuming you tried to ping R2's fa0/1 interface from R1? In this case, R1 needs to know how to get to the 192.168 network. Because you are NATing at R2, I assume you do not have a static route at R1 for this 192.168.0.0/24 network sitting behind R2. Since you NAT at R2, this explains why your internet works, but your ping doesn't

 

Regarding #2:

I see no reason why setting an excluded range on R1 and assigning R2 and IP as you did wouldn't work. Only thing I can think of is that you didn't update your ACLs/NAT config to include the new IP address. Can you post your config?

 

Thanks,

Joe

Actions

This Discussion