cisco 2611XM cannot get a DHCP handout from a d-link router

Unanswered Question
Sep 25th, 2014
User Badges:

HI, first time here. Im a homeschooled student and trying to work on getting a CCNA. I ran into an issue which puts me in a stopping point. I have a Cisco 2611XM router in which im trying to pass internet traffic to a few select computers. The problem is the WAN (fa0/1) will not get an address from the d-link router which is handing out dhcp addresses to all my computers in the main network. Ive watched lots of youtube videos but only to validate Ive used the same methods they did. SO here is a quick run down of the topology.

 

cable modem>dlink router>cisco2611XM>dumbSwitch>Computer#3

                        >                  >LinksysSLMG224G 24 port switch>computers 1,2

As you can see my network splits off from the dlink into what needs to be 2 networks. 

SO why cant I get the WAN interface to get a dhcp address from the upper router when everyone else can?

config


secureROUTER#sh run
Building configuration...

Current configuration : 1031 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname secureROUTER
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$fq4Z$ty8gmQfFw6v0sM2O0rW2D1
!
no network-clock-participate slot 1
no network-clock-participate wic 0
no aaa new-model
ip subnet-zero
ip cef
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 description LAN
 ip address 10.0.0.1 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
 no cdp enable
!
interface FastEthernet0/1
 description WAN
 ip address dhcp
 ip nat outside
 no ip route-cache cef
 no ip route-cache
 duplex auto
 speed auto
 no cdp enable
!
ip nat inside source list 1 interface FastEthernet0/0 overload
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
!
!
access-list 1 permit 10.0.0.0 0.0.0.255
no cdp run
!
!
!
!
!
!
banner motd ^CGet the fuck out!!^C
!
line con 0
line aux 0
line vty 0 4
 password 7 111B1F5244000D
 logging synchronous
 login
!
!
!
end

 

 

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Martin Moran Fri, 09/26/2014 - 05:23
User Badges:
  • Bronze, 100 points or more

Hi @chadro_6963,

Are you sure the Linksys is giving DHCP? Did you connect a computer directly to it to make sure it works?

What is the DHCP scope that the Linksys is giving to hosts?

If the Fa0/1 is the WAN interface, why do you have to NAT overloading on the Fa0/0 interface? E.g.

ip nat inside source list 1 interface FastEthernet0/0 overload

It should be:

ip nat inside source list 1 interface FastEthernet0/1 overload

Hope to see your answers.

Rgrds,

Martin, IT Specialist

chadro_6963 Fri, 09/26/2014 - 20:20
User Badges:

First off the Linksys is not the DHCP server in question, its the D-Link wireless router. The D-link is giving DHCP to my main network. The cable modem gives an address to the D-Link router (this is a typical home setup) After the D-link is where the Cisco 2611XM is suppose to be getting an address on its fa0/1. 

I guess for a scope is that the Cisco router is going to create a new (secure) network branched off from the D-Link. Examples:

D-Link DHCP scope is to hand out 192.168.1.0 addresses

The CIsco 2611XM is going to be a DHCP fa0/1 client and a fa0/0 DHCP server to create a 10.0.0.0 network.

I hope this makes sence?

And yes my computer itself can get a DHCP address b.c. thats what the D-Link is doing. Removing the overload commands did not work. Here is an updated config:

 


secureROUTER>en
Password:
secureROUTER#sh run
Building configuration...

Current configuration : 887 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname secureROUTER
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$fq4Z$ty8gmQfFw6v0sM2O0rW2D1
!
no network-clock-participate slot 1
no network-clock-participate wic 0
no aaa new-model
ip subnet-zero
ip cef
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 description LAN
 ip address 10.0.0.1 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
 no cdp enable
!
interface FastEthernet0/1
 description WAN
 ip address dhcp
 ip nat outside
 no ip route-cache cef
 no ip route-cache
 duplex auto
 speed auto
 no cdp enable
!
no ip http server
ip classless
!
!
no cdp run
!
!
!
!
!
!
banner motd ^CNO!!^C
!
line con 0
line aux 0
line vty 0 4
 password 7 111B1F5244000D
 logging synchronous
 login
!
!
!
end

secureROUTER#

Actions

This Discussion