The parked call didn't show in park area in CUAC

Unanswered Question
Oct 16th, 2014
User Badges:

Hi there,

My customer told me toady, When receptionist answered the call, then drag it over to the park area, it didn't show in park area, but she can see that call in screen of deskphone, anybody know reason? the platform is Cisco Unified Attendant Console standard v10.5.

Thanks in advance.

 

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Aman Soi Fri, 10/17/2014 - 00:12
User Badges:
  • Purple, 4500 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

Hi,

Please check if bug helps.

 

Cannot view and retrieve parked calls
Symptom:
After a call is parked in CUAC 10, call disappears from the GUI and can only be retrieved after the Park timeout timer is met. 

After further analysis traces confirm that the CUACS application is not getting a required LINE_CALLSTATE event from TSP and as a result the application is unable to show the parked call in Parked Calls area. This is tied to an overlap in call park device ranges across partitions (those assigned to operator and others, entire CUCM).

Conditions:
Issue appears if there is an overlap in the call park DNs/range across partitions. This spans outside of the CSS associated with operator devices due to operators having the ability to view all park devices. 

Setup
- Create 2 or more partitions with overlapping park ranges
- Create a CSS with the partition from above that falls last alphabetically. (For instance if you created SiteA and SiteB, specify SiteB in the CSS being created)
- Specify the CSS from above as the CSS of your operator device

Reproducing Issue
- Login to application and park any call.

After which, you'll recreate the issue every time you attempt a call park. Further confirmation, if you go back into your CSS Partitions and eliminate the overlap the issue dissipates. 

You may notice that if you were to have associated the alphabetically 1st partition to the CSS that the issue does not appear. This is because the subscription of the park devices is based on an alphabetical ordering, but will only subscribe 1 device (the reason this is a defect).

Workaround:
Remove any overlap in call park DNs across the partitions associated with the operator device(s) CSS.

 

Known Affected Releases:
(1)

 

10.0

 

regds,

aman

ndehmer Fri, 10/17/2014 - 09:27
User Badges:

While Aman's reply is correct, there is other possible issues that could cause this.  One possible issue is whether or not you have a ccm service advanced parameter "Enable Clusterwide CallPark Number/ranges" enabled.  According to the documentation this shouldn't even be applicable depending on which version of CUCM (9.0.1+) you are running.  We had this turned on to True and were experiencing this issue.  However in our case, changing it to false did not resolve our issue, but did resolve other users similar issues according to tac.   The second possible issue is there appears to be some sort of bug in 10.5.1.1543 with call park where it may experience this behavior with overlapping call park DN's even though they are in different partitions/css and not accessible to each other.  I was provided a friendly, version 10.5.1.1551, that resolved this issue, but broke how directory filters were working.  I was then provided an early release of the SR/MR that is coming out at the end of this month, 10.5.1.1610 that has resolved both of these issues.  So I am currently in a wait and see for the next release as it supposedly has over 50 fixes in it according to BU/Dev person I was working with. 

Thanks

Nathan

Yangjp715 Mon, 10/20/2014 - 14:58
User Badges:

Hi ndehmer,

Thanks for your reply. Where can i download v10.5.1.1551? there is only version 10.5.1.1543 available in download section on www.cisco.com/go/ac.

Thanks.

Actions

This Discussion