×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Direct connectivity and static routing question

Unanswered Question
Oct 27th, 2014
User Badges:

I'm trying to work with a lab network that was setup to work with a wireless router in the past.  I want to do static routing from the wireless router into the HQ router to reach the subnets of my lab network (192.168.15.0/24 and 192.168.16.0/24 - and a handful of others but the x.x.15.0/24 network is the most important).

 

I used to simply point my static routes to the sub-interfaces on my router but it seems like my new wireless router doesn't see those as good addresses.  I can ping to my Fa0/0 interface on my router - which is what physically connects my wifi router to my 2801, but I cannot ping anything beyond that.  I thought perhaps my nat statements might be causing the issue but perhaps a fresh set of eyes might do the trick.

 

I apologize for the hard lesson I'm about to learn - I'm sure it's just a silly mistake on my part.  Trace routing does show that I can get to my 2801 but cannot reach the sub-interface ip addresses off of fa0/1.  I can ping them from the router itself as well as the various endpoints within those subnets, but cannot reach them from the wifi router.

 

!

HQ-RTR#show run
Building configuration...


Current configuration : 7563 bytes
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname HQ-RTR
!
boot-start-marker
boot-end-marker
!
!
logging buffered 512000 informational
enable secret 5 $1$K8GP$JbYRetpgnaxvy2wnjrPDW/
!
no aaa new-model
network-clock-participate wic 2
network-clock-select 1 T1 0/2/0
dot11 syslog
ip source-route
!
!
!
ip dhcp excluded-address 192.168.11.1 192.168.11.10
ip dhcp excluded-address 192.168.12.1 192.168.12.10
ip dhcp excluded-address 192.168.13.1 192.168.13.10
ip dhcp excluded-address 192.168.14.1 192.168.14.10
ip dhcp excluded-address 192.168.16.1 192.168.16.10
ip dhcp excluded-address 192.168.17.1 192.168.17.10
!
ip dhcp pool HQ-BR1-Pool
 import all
 network 192.168.11.0 255.255.255.0
 option 150 ip 10.10.210.10
 default-router 192.168.11.1
 domain-name proctorlabs.com
 dns-server 8.8.4.4 8.8.8.8
 lease 8
!
ip dhcp pool BR2-Pool
 import all
 network 192.168.12.0 255.255.255.0
 option 150 ip 10.10.202.1
 default-router 192.168.12.1
 domain-name proctorlabs.com
 dns-server 8.8.4.4 8.8.8.8
 lease 8
!
ip dhcp pool PSTN-Pool
 import all
 network 192.168.13.0 255.255.255.0
 option 150 ip 10.10.100.2
 default-router 192.168.13.1
 domain-name proctorlabs.com
 dns-server 8.8.4.4 8.8.8.8
 lease 8
!
ip dhcp pool Laptop-Pool
 import all
 network 192.168.14.0 255.255.255.0
 default-router 192.168.14.1
 domain-name proctorlabs.com
 dns-server 8.8.4.4 8.8.8.8
 lease 8
!
ip dhcp pool WIRELESS-HOME
 import all
 network 192.168.16.0 255.255.255.0
 default-router 192.168.16.1
 dns-server 8.8.8.8 4.2.2.2
 domain-name proctorlabs.com
 lease 8
!
!
ip cef
no ip domain lookup
ip domain name proctorlabs.com
no ipv6 cef
multilink bundle-name authenticated
!
!
!
isdn switch-type primary-ni
!
!
!
voice service voip
 sip
  bind control source-interface Loopback0
  bind media source-interface Loopback0
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g729r8
!
voice class h323 1
  h225 timeout tcp establish 3
!
!
!
!
voice translation-rule 212
 rule 1 /^1/ /+1/
!
voice translation-rule 911
 rule 1 /^1/ /+1/
!
!
voice translation-profile ANI-IN
 translate calling 212
!
voice translation-profile ANI-OUT
 translate calling 911
!
!
voice-card 0
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO2801 sn FTX1016Y07Z
archive
 log config
  hidekeys
!
!
controller T1 0/2/0
 pri-group timeslots 1-3,24
!
controller T1 0/2/1
!
!
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 h323-gateway voip bind srcaddr 1.1.1.1
!
interface FastEthernet0/0
 description (Outside Public Interface)
 ip address dhcp
 ip access-group FW-IN in
 no ip unreachables
 ip mtu 1300
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
 no cdp enable
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/1.11
 description (Inside Private Interface)
 encapsulation dot1Q 11
 ip address 192.168.11.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface FastEthernet0/1.12
 description (Inside Private Interface)
 encapsulation dot1Q 12
 ip address 192.168.12.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface FastEthernet0/1.13
 description (Inside Private Interface)
 encapsulation dot1Q 13
 ip address 192.168.13.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface FastEthernet0/1.14
 description (Inside Private Interface)
 encapsulation dot1Q 14
 ip address 192.168.14.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface FastEthernet0/1.15
 description LAB-SERVERS
 encapsulation dot1Q 15
 ip address 192.168.15.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface FastEthernet0/1.16
 description WIRELESS-HOME
 encapsulation dot1Q 16
 ip address 192.168.16.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface FastEthernet0/1.17
 description LAB-HQ-PHONES
 encapsulation dot1Q 17
 ip address 192.168.17.1 255.255.255.0
 ip helper-address 192.168.15.32
 ip nat inside
 ip virtual-reassembly in
!
interface FastEthernet0/1.18
 description LAB-HQ-DATA
 encapsulation dot1Q 18
 ip address 192.168.18.1 255.255.255.0
 ip helper-address 192.168.15.22
 ip nat inside
 ip virtual-reassembly in
!
interface FastEthernet0/1.501
 description PSTN-RTR_MGMT-NETWORK
 encapsulation dot1Q 501
 ip address 172.30.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface Serial0/2/0:23
 no ip address
 encapsulation hdlc
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn outgoing display-ie
 no cdp enable
!
interface Serial0/3/0
 description HQ-RTR_IP-WAN
 no ip address
 encapsulation frame-relay IETF
 no fair-queue
 frame-relay lmi-type ansi
!
interface Serial0/3/0.1 point-to-point
 ip address 10.1.1.1 255.255.255.128
 ip ospf mtu-ignore
 snmp trap link-status
 frame-relay interface-dlci 103
!
interface Serial0/3/0.2 point-to-point
 ip address 10.1.1.129 255.255.255.128
 ip ospf mtu-ignore
 snmp trap link-status
 frame-relay interface-dlci 102
!
interface Serial0/3/1
 no ip address
 shutdown
 clock rate 2000000
!
router ospf 1
 network 1.1.1.1 0.0.0.0 area 0
 network 10.1.1.0 0.0.0.255 area 0
 network 172.30.1.0 0.0.0.3 area 0
 network 192.168.0.0 0.0.255.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip nat inside source list 101 interface FastEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 10.0.0.1 254
ip route 0.0.0.0 0.0.0.0 192.168.1.1 254
ip route 0.0.0.0 0.0.0.0 10.93.248.160 254
ip route 192.168.100.0 255.255.255.0 172.30.1.2
ip route 0.0.0.0 0.0.0.0 dhcp
!
access-list 101 deny   ip 192.168.0.0 0.0.255.255 10.10.0.0 0.0.255.255
access-list 101 permit ip 192.168.0.0 0.0.255.255 any
access-list 102 permit udp any any eq bootps
access-list 102 permit udp any any eq bootpc
access-list 102 permit udp any eq bootpc any
access-list 102 permit udp any eq bootps any
disable-eadi
!
!
!
control-plane
!
!
voice-port 0/2/0:23
!
!
mgcp fax t38 ecm
!
mgcp profile default
!
!
dial-peer voice 1 pots
 description INCOMING-DIAL-PEER_PSTN
 translation-profile incoming 212
 incoming called-number .
 direct-inward-dial
 port 0/2/0:23
!
dial-peer voice 1000 voip
 destination-pattern 2123941...
 session target ipv4:192.168.15.33
 incoming called-number .
 voice-class codec 1
 dtmf-relay h245-alphanumeric
 no vad
!
dial-peer voice 1001 voip
 preference 1
 destination-pattern 2123941...
 session target ipv4:192.168.15.32
 incoming called-number .
 voice-class codec 1
 dtmf-relay h245-alphanumeric
 no vad
!
dial-peer voice 911 pots
 description 911 dial-peer
 translation-profile outgoing ANI-OUT
 destination-pattern 911
 port 0/2/0:23
 forward-digits 3
!
dial-peer voice 7 pots
 description LOCAL/Subscriber CALLS TO PSTN
 destination-pattern [2-9]......
 port 0/2/0:23
 forward-digits 7
!
dial-peer voice 11 pots
 description Long Distance/National CALLS TO PSTN
 destination-pattern [2-9]..[2-9]......
 forward-digits 10
 prefix 1
!
dial-peer voice 110 pots
 description INTERNATIONAL CALLS TO PSTN
 destination-pattern 011T
 port 0/2/0:23
 forward-digits all
!
!
gateway
 timer receive-rtp 1200
!
sip-ua
 retry invite 2
 timers trying 300
!
!
!
line con 0
 password cisco
 logging synchronous
 login
line aux 0
line vty 0 4
 exec-timeout 30 0
 privilege level 15
 password cisco
 logging synchronous
 login
 transport input telnet ssh
line vty 5 15
 exec-timeout 30 0
 privilege level 15
 password cisco
 logging synchronous
 login
 transport input telnet ssh
!
scheduler allocate 20000 1000
end

 

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Mostafa Ahmad Hamza Tue, 10/28/2014 - 21:51
User Badges:

Hi eric, u say that ur wifi router doesn't see the IP address 192.168.16.1 (the sub-interface FastEthernet0/1.16, if i am wrong please correct me), this mean that the wifi router can't form the L2-L3 mapping to get the L2 MAC address of ur 2801 router, this mean that it can't form any complete frame to send it toward the 2801 router, so please provide us with full details and testing  about ur scenario to be able to help u, and also i see that ur NATing configuration is ok.

BR
Mostafa 

Actions

This Discussion