×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

MoH from local Gateway.

Answered Question
Oct 30th, 2014
User Badges:

Hi.

 

I'm trying to play MoH from flash instead to travel WAN link due to quality of audio, after read and read documents and explanations i could not to make it work.

 

This is the configuration of the Gateway.

 

interface Loopback0
 ip address 10.1.10.1 255.255.255.255
 h323-gateway voip interface
 h323-gateway voip bind srcaddr 10.1.10.1

!

interface FastEthernet0/0.100
 description >>> VOICE VLAN <<<
 encapsulation dot1Q 100
 ip address 10.50.1.1 255.255.255.0
 ip accounting output-packets

!

call-manager-fallback
 max-conferences 4 gain -6
 transfer-system full-consult
 ip source-address 10.50.1.1 port 2000
 max-ephones 10
 max-dn 20
 moh miedo.wav
 multicast moh 239.1.1.1 port 16384 route 10.1.10.1 10.50.1.1

 

When shutdown the serial interface and the SRST come up the MoH work perfectly, but when the phones register again with the CUCM the MoH go through WAN link and the chopy MoH plays again.

 

The scheme is this:

 

GW BR ---------- ISP ---------- GW HQ --------- CUCM

 

In the CUCM the multicast ip addres is 239.1.1.1 port 16384, the Max-Hops is set to 1 and the MoH file is the same.

 

I don't know what are missing to my conf.

 

Thanks for your time and help.

 

Regards.

Correct Answer by Jason Hendrix about 2 years 9 months ago

morning, I opened a TAC case and after a lot of test tweak test tweak, Cisco came up with this...

 

What Cisco saw & recommends for MOH from flash - July 2014
-----------------------------------------------

Information recollected:

Currently on the traces what was happening is that the audio that was playing on the test scenario (internal call) was playing the default audio source from CUCM and not the one that the customer wanted  (router).


The audio source, the MoH and the MRG were checked for MMoH.

Solution:

Phone from the test site didn't have the audio source assigned. Once we assigned the audio source we made sure that the person that was calling had access to the MRLG with the MMoH in order to try to stream the proper file. Once we did the test call there was silence.

At this point I checked more the configuration, I noticed the following:

Region HPE communicates with MoH region through G729.

IPV service did have both G711 and G729 enabled.

I went to the local router and checked the telephony service/ccm fall back configuration, see below:

  call-manager-fallback
max-conferences 8 gain -6
transfer-system full-consult
limit-dn 7910 1
moh "music-on-hold.au"
multicast moh 239.1.1.1 port 16384 route 169.254.1.1


show ephone summary

-------------------------------------
Skinny Music On Hold Status - group 0
Active MOH clients 0 (max 1300), Media Clients 0, B-ACD Clients 0
File music-on-hold.au (not cached) type AU Media_Payload_G711Ulaw64k 160 bytes
Moh multicast 239.1.1.1 port 16384 route 169.254.1.1


The problem was that the phones were communicating to the MoH via G729, the MMoH server was set up for port 16384 and the audio source was in G711 format.

As a small modification I changed the region set up between the MoH and the test site to G711, after this we had successful MMoH on the phones:

HPEiVG01#show ccm-manager music-on-hold
Current active multicast sessions : 1
Multicast       RTP port   Packets       Call   Codec    Incoming
Address         number     in/out        id              Interface
===================================================================
239.1.1.1         16384   738/738          116398 g711ulaw  Lo0

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
Jason Hendrix Thu, 10/30/2014 - 08:05
User Badges:

morning, I opened a TAC case and after a lot of test tweak test tweak, Cisco came up with this...

 

What Cisco saw & recommends for MOH from flash - July 2014
-----------------------------------------------

Information recollected:

Currently on the traces what was happening is that the audio that was playing on the test scenario (internal call) was playing the default audio source from CUCM and not the one that the customer wanted  (router).


The audio source, the MoH and the MRG were checked for MMoH.

Solution:

Phone from the test site didn't have the audio source assigned. Once we assigned the audio source we made sure that the person that was calling had access to the MRLG with the MMoH in order to try to stream the proper file. Once we did the test call there was silence.

At this point I checked more the configuration, I noticed the following:

Region HPE communicates with MoH region through G729.

IPV service did have both G711 and G729 enabled.

I went to the local router and checked the telephony service/ccm fall back configuration, see below:

  call-manager-fallback
max-conferences 8 gain -6
transfer-system full-consult
limit-dn 7910 1
moh "music-on-hold.au"
multicast moh 239.1.1.1 port 16384 route 169.254.1.1


show ephone summary

-------------------------------------
Skinny Music On Hold Status - group 0
Active MOH clients 0 (max 1300), Media Clients 0, B-ACD Clients 0
File music-on-hold.au (not cached) type AU Media_Payload_G711Ulaw64k 160 bytes
Moh multicast 239.1.1.1 port 16384 route 169.254.1.1


The problem was that the phones were communicating to the MoH via G729, the MMoH server was set up for port 16384 and the audio source was in G711 format.

As a small modification I changed the region set up between the MoH and the test site to G711, after this we had successful MMoH on the phones:

HPEiVG01#show ccm-manager music-on-hold
Current active multicast sessions : 1
Multicast       RTP port   Packets       Call   Codec    Incoming
Address         number     in/out        id              Interface
===================================================================
239.1.1.1         16384   738/738          116398 g711ulaw  Lo0

alanbatres Thu, 10/30/2014 - 17:29
User Badges:

Hi Jason.

 

Thanks  for the information, i did some modifications to Conf, after the changes i think that the music on hold works from the Gateway, i did debug ephone moh and i saw that the file was read from the flash and with sh ip mroute the 239.1.1.1 appears under the output command, unfortunately after that i don't know what happened but the Router gets crazy and had to restart and when come's up all files in the flash were damaged.

I'll return to make the changes again and test.

 

I keep you informed.

 

Regards.

Actions

This Discussion

Related Content