How to refresh Corporate Directory? CUCM 9.1

Unanswered Question
Nov 3rd, 2014
User Badges:

Hello!

I noticed that when I check my phone (7941) and go to the Corporate Directory it still show users that are not working here anymore and old extension numbers. It's not integrated to the AD, it use the file ccmcip/xmldirectoryinput.jsp. How can I re-sync or refresh the Corporate Directory? Thanks in advance!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Carlo Poggiarelli Mon, 11/03/2014 - 11:29
User Badges:
  • Green, 3000 points or more

Hi Alberto.

Because IP Phones query CUCM each time you browse corporate directory, if you see some unwanted users it means that they still are on CUCM end users Table.

Check with CUCM Administrator if those end users have been removed.

Also give a look to Enterprise Parameters if on URL Directories field and see what is specified ther (CUCM IP or something else)

 

let me know

 

Regards

 

Carlo

Al Ro Mon, 11/03/2014 - 11:46
User Badges:

Hello Carlo!

Thanks for replying! Yes I verified and those users are not anymore under End User.

On URL Directories field it shows http://CUCM IP:8080/ccmcip/xmldirectory.jsp

Any other suggestion?

Thanks!!!

Carlo Poggiarelli Mon, 11/03/2014 - 11:52
User Badges:
  • Green, 3000 points or more

Hi Alberto.

Does this behavior happen to all phones or just to some model?

 

Check for url directorie under device configuration on your IP Phone.

 

let me know 

 

Regards

 

Carlo

Al Ro Tue, 11/04/2014 - 07:58
User Badges:

It's with all phones.

I check the phone config and I noticed the URL there is using a different port than 8080. Do you think this can be the issue?

Also, do you know if there's a way for me to edit the XML file? Or it's done by the CUCM?

Thanks again!

Carlo Poggiarelli Tue, 11/04/2014 - 08:22
User Badges:
  • Green, 3000 points or more

Hi Alberto.

IP Phones are, probably, not getting correct config from CUCM.

I suggest you to restart TFTP service from Unified Serviceability and reset some IP Phones to test that they are receiving the correct URL

 

Please keep me informed.

 

Regards

 

Carlo

Al Ro Tue, 11/04/2014 - 11:07
User Badges:

Hello Carlo,

I restarted the TFTP Service, the DirSync and even the Call Manager but still showing outdated data on the Corporate Directory.

Not really sure what's the issue. Any other thing I should try before using the bat? hehe

Thanks!

Carlo Poggiarelli Tue, 11/04/2014 - 11:16
User Badges:
  • Green, 3000 points or more

Hi Alberto.

Why BAT?

Change the url on enterprise parameters with something different and try to reset some phones.

Verify that the url on IP Phones reflects what you defined on enterprise parameter.

 

 

Let me know 

 

Regards

 

 

Carlo

Al Ro Tue, 11/04/2014 - 11:28
User Badges:

Yes, I added a number 2 to the URL, reset a few phones and all of them are showing the URL with the 2, but the data still outdated. So at least that part seems to be communicating right.

That file is created by default or can I upload the file with the right data?

Thanks!

Carlo Poggiarelli Tue, 11/04/2014 - 11:45
User Badges:
  • Green, 3000 points or more

Are you sill able to browse corporate directory even if you added an invalid url?

Have you tried to reboot cucm server?

 

Carlo

Al Ro Tue, 11/04/2014 - 13:00
User Badges:

Yes, it replaced the URL on the phone, but I'm able to browse the directory, but still the same outdated data.

Yes, I have the reboot as my last option. Will wait for the end of the business to try it. Thanks for replying!

Carlo Poggiarelli Tue, 11/04/2014 - 13:12
User Badges:
  • Green, 3000 points or more

Hi Alberto.

That's strange because with an invalid url ip phones should report host not found.

Did you try also an IP Communicator?

 

 

Regards

 

 

Carlo

Al Ro Tue, 11/04/2014 - 13:31
User Badges:

On the IP Communicator is giving me this error: "An error occurred and was logged."

Thanks!

Carlo Poggiarelli Wed, 11/05/2014 - 06:28
User Badges:
  • Green, 3000 points or more

Hi Alberto.

Sorry for late replay.

What do you have configured as server hostname? (IP Address or Hostname)

In case of hostname, I suggest you to modify it with the IP address.

Another test you can do is to temporarily disable the SBD (Security By Default) function in order to let IP Phones to point to HTTP URL instead of HTTPS.

To do that go to Enterprise Parameters and put to True the value "Prepare Cluster For Rollback to Pre 8.0"

 

HTH

 

Let Me Know

 

Regards

 

Carlo

Al Ro Wed, 11/19/2014 - 05:58
User Badges:

Hello Carlo,

Sorry for the long delay, after we rebooted the server, the problem was fixed, seems like the old information was cached somewhere. But after few minutes, the old information came back. I opened a ticket with a third party support company and they are unable to find out what's the issue here, they are calling Cisco directly for help now. Here's the update from the tech "interesting....they are showing again on my test phone as well...however, i have checked the system and they are not there...i will need to get with cisco about this...they were gone after i rebooted the servers yesterday"

I will let you know once this is solved.

Thanks for your time.

Carlo Poggiarelli Wed, 11/19/2014 - 06:48
User Badges:
  • Green, 3000 points or more

Hi Alberto.

If you want we can setup a webex to find out what is happening on your CUCM.

Please let me know

 

 

Regards

 

Carlo

Al Ro Mon, 11/24/2014 - 08:48
User Badges:

Thanks a lot Carlo!

Finally got help from Cisco and here's the response:
"worked with cisco we found that the issue only occurs when the phones are registered to the subscriber server...when the phone is registered to the publisher, the directory shows the current information. this indicates and issue with the database replication between the 2 servers.

the databases have been reset and are replication is resyncing...this will take a couple of hours...i will check back then."

This seems to have fixed the issue. Thanks a lot for helping me to figure it out.

Thanks!

Actions

This Discussion

Related Content