×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

CCNA Lab HELP

Unanswered Question
Feb 1st, 2015
User Badges:
  • Cisco Employee,

Hello, 

 

I am building the CCNA Voice lab detailed in the CBT Nuggets series (I will attach the topology below). My config is the same as below, but I am having issues getting the "DHCP server" connected to the internet, but the TFTP server is able to connect.

My default gateway is 10.4.0.4 and the DHCP server can ping that address, just nothing beyond it.

Below the attachment I will put the running configs for both routers.

Thank you in advance for any and all help


 

Running Config for the DHCP Server

1760(config)#do show run
Building configuration...

Current configuration : 3292 bytes
!
! Last configuration change at 23:10:09 UTC Thu Jan 29 2015
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname 1760
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$yCrI$nVKsqRR8pRIrqD9HnfFso0
!
no aaa new-model
voice-card 2
!
voice-card 3
!
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 172.16.1.1 172.16.1.10
ip dhcp excluded-address 172.16.2.1 172.16.2.10
!
ip dhcp pool DATA
   network 172.16.2.0 255.255.255.0
   default-router 172.16.2.1
   dns-server 4.2.2.2
   option 150 ip 172.16.1.1
!
ip dhcp pool VOICE
   network 172.16.1.0 255.255.255.0
   default-router 172.16.1.1
   dns-server 4.2.2.2
   option 150 ip 172.16.1.1
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
voice translation-profile 1
 translate called 1
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
 half-duplex
!
interface FastEthernet0/0
 ip address 172.16.2.5 255.255.255.0
 speed auto
!
interface Serial1/0
 no ip address
 shutdown
 no fair-queue
!
ip forward-protocol nd
ip route 10.4.0.0 255.255.255.0 172.16.2.1
ip route 172.16.1.0 255.255.255.0 172.16.2.1
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
voice-port 2/0
 shutdown
!
voice-port 2/1
 shutdown
!
voice-port 3/0
 description Orange_Uniden
 station-id number 1000
!
voice-port 3/1
 description BLACK AT&T
 station-id number 1001
!
!
!
!
!
dial-peer cor custom
 name 911-CALL
 name LOCAL-CALL
 name LD-CALL
 name INTERNAT-CALL
!
!
dial-peer cor list EMERGENCY
 member 911-CALL
!
dial-peer cor list LOCAL
 member LOCAL-CALL
!
dial-peer cor list LONGDIST
 member LD-CALL
!
dial-peer cor list INTERNATIONAL
 member INTERNAT-CALL
!
dial-peer cor list INCOMING-EMERGENCY
 member 911-CALL
!
dial-peer cor list INCOMING-LOCAL
 member 911-CALL
 member LOCAL-CALL
!
dial-peer cor list INCOMING-LD
 member 911-CALL
 member LOCAL-CALL
 member LD-CALL
!
dial-peer cor list INCOMING-INTERNAT
 member 911-CALL
 member LOCAL-CALL
 member LD-CALL
 member INTERNAT-CALL
!
!
dial-peer voice 1000 pots
 destination-pattern 1000
 port 3/0
!
dial-peer voice 1001 pots
 destination-pattern 1001
 port 3/1
!
dial-peer voice 911 pots
 destination-pattern 911
 no digit-strip
!
dial-peer voice 9911 pots
 destination-pattern 9911
 forward-digits 3
!
dial-peer voice 7 pots
 description 7 DIGIT DIALING
 destination-pattern 9[2-9]......
!
dial-peer voice 10 pots
 description 10 DIGIGT DIALING
 destination-pattern 9[2-9].........
!
dial-peer voice 11 pots
 description 11 DIGIT DIALING
 destination-pattern 91[2-9].........
 prefix 1
!
dial-peer voice 12 pots
 description INTERNATION DIALING
 destination-pattern 9011T
 prefix 011
!
dial-peer voice 2000 voip
 destination-pattern 20..
 session target ipv4:172.16.1.1
!
dial-peer voice 2001 voip
 destination-pattern 09.
 session target ipv4:172.16.1.1
!
!
telephony-service
 max-ephones 10
 max-dn 10
 cnf-file location flash:
 max-conferences 4 gain -6
 transfer-system full-consult
!
!
line con 0
 exec-timeout 0 0
 password 7 143801080D16647A767B
 logging synchronous
 login
line aux 0
line vty 0 4
 exec-timeout 15 0
 password 7 032B4808071D6F1D1C5A
 logging synchronous
 login
!
ntp master 4
end

 

Running Config for the TFTP Server

2801_RTR#show run
Building configuration...


Current configuration : 7488 bytes
!
! Last configuration change at 03:44:29 UTC Fri Jan 30 2015
! NVRAM config last updated at 03:44:33 UTC Fri Jan 30 2015
! NVRAM config last updated at 03:44:33 UTC Fri Jan 30 2015
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname 2801_RTR
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$D/Hq$6ZmXQYs/SUjJi6mDJHCzw/
!
no aaa new-model
!
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
!
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
voice hunt-group 1 parallel
 final 1001
 list 2021,2022,2023,2024,2025
 timeout 20
 pilot 098
!
!
!
!
voice translation-rule 10
 rule 1 /^1919454\(100.\)$/ /\1/
!
!
voice translation-profile TO_1760
 translate called 10
!
!
voice-card 0
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO2851 sn FTX1318A326
!
redundancy
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/0.10
 encapsulation dot1Q 10
 ip address 172.16.1.1 255.255.255.0
 ip helper-address 172.16.2.5
!
interface GigabitEthernet0/0.50
 encapsulation dot1Q 50
 ip address 172.16.2.1 255.255.255.0
 ip helper-address 172.16.2.5
 ip nat inside
 ip virtual-reassembly in
!
interface GigabitEthernet0/1
 ip address dhcp
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface Serial0/3/0
 no ip address
 shutdown
 no fair-queue
!
interface FastEthernet0/1/0
 no ip address
!
interface FastEthernet0/1/1
 no ip address
!
interface FastEthernet0/1/2
 no ip address
!
interface FastEthernet0/1/3
 no ip address
!
interface Vlan1
 no ip address
!
ip default-gateway 10.4.0.1
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip default-network 10.4.0.0
!
logging esm config
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp profile default
!
!
dial-peer cor custom
 name 911_CALL
 name LOCAL_CALL
 name LD_CALL
 name INTERNAT_CALL
!
!
dial-peer cor list EMERGENCY
 member 911_CALL
!
dial-peer cor list LOCAL
 member LOCAL_CALL
!
dial-peer cor list LONGDISTANCE
 member LD_CALL
!
dial-peer cor list INTERNATIONAL
 member INTERNAT_CALL
!
dial-peer cor list INCOMING
!
dial-peer cor list INCOMING-EMERGENCY
 member 911_CALL
!
dial-peer cor list INCOMING-LOCAL
 member 911_CALL
 member LOCAL_CALL
!
dial-peer cor list INCOMING-LONGDISTANCE
 member 911_CALL
 member LOCAL_CALL
 member LD_CALL
!
dial-peer cor list INCOMING-INTERNATIONAL
 member 911_CALL
 member LOCAL_CALL
 member LD_CALL
 member INTERNAT_CALL
!
!
dial-peer voice 1000 voip
 description DIAL-PEER FOR ANALOG PHONES
 destination-pattern 100.
 session target ipv4:172.16.2.5
!
dial-peer voice 911 pots
 corlist incoming INCOMING-EMERGENCY
 corlist outgoing EMERGENCY
 description EMERGENCY
 destination-pattern 911
 no digit-strip
 forward-digits all
!
dial-peer voice 9911 pots
 corlist incoming INCOMING-EMERGENCY
 corlist outgoing EMERGENCY
 description EMERGENCY_9_ACCESS
 destination-pattern 9911
 forward-digits 3
!
dial-peer voice 7 pots
 corlist incoming INCOMING-LOCAL
 corlist outgoing LOCAL
 description 7_DIGIT_DIALING
 destination-pattern [2-9]......
!
dial-peer voice 10 pots
 corlist incoming INCOMING-LONGDISTANCE
 corlist outgoing LONGDISTANCE
 description 10_DIGIT_DIALING
 destination-pattern [2-9]..[2-9]......
!
dial-peer voice 11 pots
 corlist incoming INCOMING-INTERNATIONAL
 corlist outgoing INTERNATIONAL
 description INTERNATION_DIALING
 destination-pattern 011T
 prefix 011
!
dial-peer voice 500 voip
 translation-profile outgoing TO_1760
 destination-pattern 1919454100.
 session target ipv4:172.16.1.1
!
!
!
!
gatekeeper
 shutdown
!
!
telephony-service
 max-ephones 20
 max-dn 75
 ip source-address 172.16.1.1 port 2000
 cnf-file location flash:
 max-conferences 8 gain -6
 transfer-system full-consult
 create cnf-files version-stamp 7960 Jan 30 2015 03:42:50
!
!
ephone-dn  1  dual-line
 number 2001
 pickup-group 011
 call-forward noan 1000 timeout 30
!
!
ephone-dn  2  dual-line
 number 2002
 pickup-group 011
 call-forward noan 1000 timeout 30
!
!
ephone-dn  3  dual-line
 number 2003
 pickup-group 011
 call-forward noan 1000 timeout 30
!
!
ephone-dn  4  dual-line
 number 2004
 pickup-group 011
 call-forward noan 1000 timeout 30
!
!
ephone-dn  5  dual-line
 number 2005
 pickup-group 011
 call-forward noan 1000 timeout 30
!
!
ephone-dn  6  dual-line
 number 2006
 pickup-group 012
 call-forward noan 1001 timeout 30
!
!
ephone-dn  7  dual-line
 number 2007
 pickup-group 012
 call-forward noan 1001 timeout 30
!
!
ephone-dn  8  dual-line
 number 2008
 pickup-group 012
 call-forward noan 1001 timeout 30
!
!
ephone-dn  9  dual-line
 number 2009
 pickup-group 012
 call-forward noan 1001 timeout 30
!
!
ephone-dn  10  dual-line
 number 2010
 pickup-group 012
 call-forward noan 1001 timeout 30
!
!
ephone-dn  11  dual-line
 number 2011
 pickup-group 013
 ephone-hunt login
!
!
ephone-dn  12  dual-line
 number 2012
 pickup-group 013
!
!
ephone-dn  13  dual-line
 number 2013
 pickup-group 013
!
!
ephone-dn  14  dual-line
 number 2014
 pickup-group 013
!
!
ephone-dn  15  dual-line
 number 2015
 pickup-group 013
!
!
ephone-dn  16  dual-line
 number 2016
 pickup-group 013
!
!
ephone-dn  17  dual-line
 number 2017
 pickup-group 013
!
!
ephone-dn  18  dual-line
 number 2018
 pickup-group 013
!
!
ephone-dn  19  dual-line
 number 2019
 pickup-group 013
!
!
ephone-dn  20  dual-line
 number 2020
 pickup-group 013
!
!
ephone-dn  21  dual-line
 number 2021
 pickup-group 014
!
!
ephone-dn  22  dual-line
 number 2022
 pickup-group 014
!
!
ephone-dn  23  dual-line
 number 2023
 pickup-group 014
!
!
ephone-dn  24  dual-line
 number 2024
 pickup-group 014
!
!
ephone-dn  25  dual-line
 number 2025
 pickup-group 014
!
!
ephone-dn  49
 number 097
 description PILOT FOR EPHONE-HUNT 1
!
!
ephone-dn  50
 number 098
 description PILOT FOR VHG1
!
!
ephone  1
 device-security-mode none
 mac-address 0007.5083.486E
 button  1:1 2:14
!
!
!
ephone  2
 device-security-mode none
 mac-address 001A.6D26.595F
 button  1:2 2:15
!
!
!
ephone  3
 device-security-mode none
 mac-address 000B.FDCD.A9D7
 button  1:3 2:16
!
!
!
ephone  4
 device-security-mode none
 mac-address 0003.6B3C.2DA5
 button  1:4 2:17
!
!
!
ephone  5
 device-security-mode none
 mac-address 0019.E778.3EC9
 button  1:5 2:18
!
!
!
ephone  6
 device-security-mode none
 mac-address 0016.462C.FD0A
 button  1:6 2:19
!
!
!
ephone  7
 device-security-mode none
 mac-address F025.7278.41F6
 button  1:7 2:20
!
!
!
ephone  8
 device-security-mode none
 mac-address 000D.BDBF.1818
 button  1:8 2:21
!
!
!
ephone  9
 device-security-mode none
 mac-address 0003.6BC3.80D2
 button  1:9 2:22
!
!
!
ephone  10
 device-security-mode none
 mac-address 0026.0B5D.4976
 button  1:10 2:23
!
!
!
ephone  11
 device-security-mode none
 mac-address 0009.B7D0.F37D
 button  1:11 2:24
!
!
!
ephone  12
 device-security-mode none
 mac-address 0030.94C2.C531
 button  1:12 2:25
!
!
!
ephone  13
 device-security-mode none
 mac-address 0030.94C4.2076
 button  1:13
!
!
ephone-hunt 1 longest-idle
 pilot 097
 list 2011, 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020
 final 1000
 timeout 15, 15, 15, 15, 15, 15, 15, 15, 15, 15
 display-logout LOGGED OUT OF EPHON-HUNT 1
!
!
!
!
line con 0
 exec-timeout 0 0
 password 7 09635D0A18175943595F
 logging synchronous
 login
line aux 0
line vty 0 4
 exec-timeout 15 0
 password 7 002B0005054945575D72
 login
 transport input all
!
scheduler allocate 20000 1000
ntp server 152.2.21.1
end

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Brandon Pierce Sun, 02/01/2015 - 11:14
User Badges:
  • Silver, 250 points or more
  • Community Spotlight Award,

    Best Publication, January 2015

So the CME/CUE is the actual gateway that can egress to the internet.  I don't see any default routes pointing to that interface/IP nor is it listed/shown on the diagram.  I assume G0/1 is the interface since it is Natting?

msturtev Sun, 02/01/2015 - 12:15
User Badges:
  • Cisco Employee,

Hello Brandon,

Yes the CME gi0/1 is connected to my home router and has an active internet connection. 

Any thoughts how I can get my DHCP router connected as well?

 

2801_RTR#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 10.4.0.1 to network 0.0.0.0

S*    0.0.0.0/0 [254/0] via 10.4.0.1
      10.0.0.0/8 is variably subnetted, 3 subnets, 3 masks
S        10.0.0.0/8 [1/0] via 10.4.0.0
C        10.4.0.0/24 is directly connected, GigabitEthernet0/1
L        10.4.0.4/32 is directly connected, GigabitEthernet0/1
      172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
C        172.16.1.0/24 is directly connected, GigabitEthernet0/0.10
L        172.16.1.1/32 is directly connected, GigabitEthernet0/0.10
C        172.16.2.0/24 is directly connected, GigabitEthernet0/0.50
L        172.16.2.1/32 is directly connected, GigabitEthernet0/0.50

Brandon Pierce Mon, 02/02/2015 - 05:03
User Badges:
  • Silver, 250 points or more
  • Community Spotlight Award,

    Best Publication, January 2015

What I personally have done for my home voice lab is ran a ethernet from the modem to my switch and have it trunked.  From there, I am free to go about my network since it's a layer 3 switch which lets me access both of my CUBEs and my PSTN gateway without the need for a serial cable and can access the internet and use NTP sources that aren't locally setup.

msturtev Mon, 02/02/2015 - 05:58
User Badges:
  • Cisco Employee,

Brandon, 

 

Thank you for the input, I will give that a try later on this evening and see if that resolves my issue. 

Brandon Pierce Mon, 02/02/2015 - 11:15
User Badges:
  • Silver, 250 points or more
  • Community Spotlight Award,

    Best Publication, January 2015

Just make sure you setup default routes correctly so that the DHCP server can get internet access as needed.  A default route from the DHCP router to the CME/CUE should be all that is needed since the CME router will be pushing all unknown traffic to the internet via your home modem/router.  Is this purely a static route situation then from what I can see?  Might want to try running EIGRP to get a slightly more "real world" setup.

Actions

This Discussion