×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

28561 router IOS upgrade

Unanswered Question
Feb 12th, 2015
User Badges:

Hi all,

Total noob, but learning.

I bought a second hand 2851 router (CISCO2851-HSEC/K9-REF)

software:

ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

 

I'm getting a boatload of memory fragmentation errors, then it failed to ROM image on 'unknown error'.

From what I have read from searches, all point to upgrading software.

How do I get this?  How much does it cost to get to the unified version(s)?

Does the upgrade see what licenses/features I have installed and automatically enable them? 

Am I allowed to use the software on the Catalyst 2960 and 3750 I have too?

And is 512MB of DRAM the max this router will take?  At 256MB now.

 

Cruising the website is cumbersome and left me more confused then before I searched.

 

TIA,

Dave

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Wilson Samuel Thu, 02/12/2015 - 06:33
User Badges:
  • Gold, 750 points or more
  • Community Spotlight Award,

    Mobile User, July 2015

Don't worry, you are in good hands, just make sure as a gesture of gratitude, please keep rating the posts which you believe have helped you :-)

 

"I'm getting a boatload of memory fragmentation errors, then it failed to ROM image on 'unknown error'."

This is not an encouraging news, could you please unseat the memory and put it right back and see if these err messages go away? These messages show that, some kind of either chipset issue or even worse, Motherboard issue :-(

IOS corruption may also contribute err but I have mostly seen either a crash of the Boot process or no booting at all, and the router gets stuck after the POST.

 

You can download IOS from the Cisco website as long as you are not using the router in production and/or for profit from a business, all you need is a valid CCO ID and a Smartnet (ESW) or UCSS contract.

That should be able to help you to download the software and use it for non production environment.

HTH

 

 

 

 

 

anode5055 Sun, 02/15/2015 - 07:56
User Badges:

Thanks!

Once it dropped out to that ROM message it still ran fine.  Did what I had configured it to.

We lost power for a few hours last night and when it rebooted, those mem frag errors seem to have gone away.  Hmmm.  When I was getting them, a 'reload' didn't seem to help.  Might be a flake RAM module.

I think I'll just leave this sleeping dog along.

Actions

This Discussion