×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

switch 2960s configuration for dark fiber test

Answered Question
Oct 19th, 2015
User Badges:

hi guys

im new in networking. we have a dark fiber testing from Side A > dark fiber > Side B . to test the fiber link , im using a switch 2960 and configure a vlan - vlan 31, and i assign 1 of the port to switchport access vlan 31. im not sure whether the switch need to configure a default gateway which is the other switch tat side B. im not able to ping to my pc either [port 2/0/1]. the fiber link which connected to the switch is port 2/0/49]

can you help me to check whether this configuration is correct ?  below is the running config. tx so much for the help.

SRO-SWITCH-TEST#sh run
Building configuration...

Current configuration : 2679 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname SRO-SWITCH-TEST
!
boot-start-marker
boot-end-marker
!
enable password 7 110A1016141D5F01072728
!
username admin privilege 15 password 7 00071A150754
!
!
no aaa new-model
clock timezone MYS 8
switch 2 provision ws-c2960s-48ts-l
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
ip ssh version 2
!
!
interface FastEthernet0
 no ip address
!
interface GigabitEthernet2/0/1
 switchport access vlan 31
 switchport mode access
 no mdix auto
 spanning-tree portfast
!
interface GigabitEthernet2/0/2
!
interface GigabitEthernet2/0/3
!
interface GigabitEthernet2/0/4
!
interface GigabitEthernet2/0/5
!
interface GigabitEthernet2/0/6
!
interface GigabitEthernet2/0/7
!
interface GigabitEthernet2/0/8
!
interface GigabitEthernet2/0/9
!
interface GigabitEthernet2/0/10
!
interface GigabitEthernet2/0/11
!
interface GigabitEthernet2/0/12
!
interface GigabitEthernet2/0/13
!
interface GigabitEthernet2/0/14
!
interface GigabitEthernet2/0/15
!
interface GigabitEthernet2/0/16
!
interface GigabitEthernet2/0/17
!
interface GigabitEthernet2/0/18
!
interface GigabitEthernet2/0/19
!
interface GigabitEthernet2/0/20
!
interface GigabitEthernet2/0/21
!
interface GigabitEthernet2/0/22
!
interface GigabitEthernet2/0/23
!
interface GigabitEthernet2/0/24
!
interface GigabitEthernet2/0/25
!
interface GigabitEthernet2/0/26
!
interface GigabitEthernet2/0/27
!
interface GigabitEthernet2/0/28
!
interface GigabitEthernet2/0/29
!
interface GigabitEthernet2/0/30
!
interface GigabitEthernet2/0/31
!
interface GigabitEthernet2/0/32
!
interface GigabitEthernet2/0/33
!
interface GigabitEthernet2/0/34
!
interface GigabitEthernet2/0/35
!
interface GigabitEthernet2/0/36
!
interface GigabitEthernet2/0/37
!
interface GigabitEthernet2/0/38
!
interface GigabitEthernet2/0/39
!
interface GigabitEthernet2/0/40
!
interface GigabitEthernet2/0/41
!
interface GigabitEthernet2/0/42
!
interface GigabitEthernet2/0/43
!
interface GigabitEthernet2/0/44
!
interface GigabitEthernet2/0/45
!
interface GigabitEthernet2/0/46
!
interface GigabitEthernet2/0/47
!
interface GigabitEthernet2/0/48
!
interface GigabitEthernet2/0/49
 switchport access vlan 31
 switchport mode access
 speed nonegotiate
 spanning-tree portfast
!
interface GigabitEthernet2/0/50
!
interface GigabitEthernet2/0/51
!
interface GigabitEthernet2/0/52
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan31
 description SRORO OFFICE
 ip address 192.168.31.250 255.255.255.0
!
ip http server
ip http secure-server
!
line con 0
line vty 5 15
!
end

SRO-SWITCH-TEST#

Correct Answer by chhayheng about 1 year 10 months ago

hi haslinifairos,

Case 1: If the different subnet you need to add route with each other.

Case 2: If the same subnet you need to turn off your computer firewall and make sure that both sides are the same range.

--Chhayheng--  

Correct Answer by Mark Malone about 1 year 10 months ago

Hey config looks ok just missing default gateway locally pointing to other switch as you said

pc needs to be set with gateway of 192.168.31.250 vlan 31 and have a static ip in same range and same subnet

make sure your vlan 31 is up/up

 

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
Mark Malone Tue, 10/20/2015 - 02:59
User Badges:
  • Purple, 4500 points or more
  • Cisco Designated VIP,

    2017 LAN

Hey config looks ok just missing default gateway locally pointing to other switch as you said

pc needs to be set with gateway of 192.168.31.250 vlan 31 and have a static ip in same range and same subnet

make sure your vlan 31 is up/up

 

Correct Answer
chhayheng Wed, 10/21/2015 - 08:31
User Badges:

hi haslinifairos,

Case 1: If the different subnet you need to add route with each other.

Case 2: If the same subnet you need to turn off your computer firewall and make sure that both sides are the same range.

--Chhayheng--  

haslinifairos Wed, 10/21/2015 - 13:36
User Badges:

Tq Chhayheng , Malone

i have configured the same subnet for both switches in Side A & Side B , and not configure any default gateway, its working at pingable each other. while at the same time, i turn off the PC firewall , its working. :)

Actions

This Discussion