×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

jabber for windows contact photo

Unanswered Question
Feb 4th, 2016
User Badges:

Hi Guys,

My jabber is having problem in fetching the contact photo from the AD.

The contact photos are available in outlook but my jabber is unable to fetch the same contact photos.


I have added below lines in jabber-config file. Please check and help.


<PhotoSource>thumbnailPhoto</PhotoSource>
<PhotoUriSubstitutionEnabled>true</PhotoUriSubstitutionEnabled>
<PhotoUriSubstitutionToken>sAMAccountName</PhotoUriSubstitutionToken



Regards,

Gowrishankar




  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Amit Kumar Tue, 03/08/2016 - 22:38
User Badges:
  • Cisco Employee,

Jabber needs to have an web server hosting contact Photos, and same URL needs to be specified in jabber configuration file.


Thanks,

Amit

Hello, I have a similar problem ... I need to show the pictures of the contacts 365 OUTLOOK Business in the cloud in the Jabber client . OUTLOOK 365 users put their photo in the profile OUTLOOK 365 in the cloud, but not show me the picture.
I CUCM version 10.5 and Cisco Jabber clients have version 11.5.0 .
The problem is that not know I have to configure in the jabber -config.xml to point to OUTLOOK 365 in the cloud.
I hope your help.
Thank you.
Shadi Shami Thu, 03/10/2016 - 04:33
User Badges:
  • Gold, 750 points or more
  • Community Spotlight Award,

    Mobile User, April 2015

Hello,


add the following to your jabber-config file:


 <Directory>
   <PhotoSource>thumbnailPhoto</PhotoSource>
 </Directory>


Or you can test the attached one.


Thank you,

Shadi

Attachment: 
Jonathan Unger Mon, 03/14/2016 - 22:48
User Badges:
  • Silver, 250 points or more

Hi Gowrishankar,

In order to use the "thumbnailPhoto" AD attribute for the contact photo, you must disable UDS in the service profile for the end user.

Can you please check in CUCM if you have a service profile configured "User Management > User Settings > Service Profile"?

If so, ensure that the "Use UDS for Contact Resolution" is UN-CHECKED. If it is checked, uncheck, save and reset your jabber client.



If you do not have any service profiles configured in CUCM, this response is not applicable.

Actions

This Discussion