Finesse Team Resource error.

Answered Question
Apr 24th, 2016

Hi folks,


I've installed UCCE 11 Setup in a separate domain. Does any one have faced this Error " The Finesse server is currently out of Service. Team Resource Management can only be performed when it is in service" under Finesse administrator Team resource tab. Where do I need to check?

Restarted Cisco DB, Cisco Notification and Cisco Tomcat service and restarted the system.


On Finesse, awdb name (awdb_pod1) and PortNo: 1433 si defined. CTI Server IPaddress and 42027 defined on Finesse admin page.


Still am getting Finesse is out of Service.


Solution contains;

Rogger + PG + CTI

Finesse.

CVP


Any guess... pls guide.



Thanks...

regards,

Ritesh Desai

Correct Answer by karen.johnson5801 about 1 week 3 hours ago

hi Ritesh,


I also got same error and follow the guide you post, but no luck:

The Finesse server is currently Out of Service. Team Resource Management can only be performed when it is In Service.


wondering if you know what else I need to check?


thanks,

K

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (9 ratings)
Loading.
Chintan Gajjar Mon, 04/25/2016 - 02:29

Have you configured DNS properly reverse and forward lookup for finesse?

DNS is must for finesse to be in full service.


Ritesh Desai Mon, 04/25/2016 - 02:58

Hey Chintan,


Thanks for revert. Yes. I have assigned static Forward and Reverse lookup zone. During installation it checks for Reverse lookup zone. So i have added already. Am checking logs. Update you if I found.

If you have any other suggestions please let me know.

 

thanks,

Ritesh Desai

Ritesh Desai Tue, 04/26/2016 - 00:08

Chintan,


I found in https://<ipaddress>:8443/finesse/desktop logs saying gadget could not be loaded.


Found the issue.This is for those who facing.

- Check awdb pod IP address and port no defined in finesse admin.

- Check CTI Server PG in ICM (Re-run PG setup)

- Check Agent PG in ICM (Re-run PG setup)

Root cause for this, mismatch in CUCM PG Logical ID. Re-run PG, edit PIM and install.

This was the root cause. Problem solved. Yeah!


Please rate helpfull post.



regards,

Ritesh Desai.

Correct Answer
karen.johnson5801 Thu, 02/16/2017 - 10:46

hi Ritesh,


I also got same error and follow the guide you post, but no luck:

The Finesse server is currently Out of Service. Team Resource Management can only be performed when it is In Service.


wondering if you know what else I need to check?


thanks,

K

Ritesh Desai Thu, 02/16/2017 - 20:44

Hi karen,


make sure you have created RmCmuser in CUCM.

Finesse architecture says finesse server will authenticate with AWDB. AWDB communicates with PG. Finesse server will communicate with CTI server. AWDB server will communicate with PG (CUCM PIM).


please let me know CTI, JTAPI, Agent PIM status frm Diagnostics Portico.



regards,

Ritesh Desai.

karen.johnson5801 Fri, 02/17/2017 - 13:49

hi Ritesh,


Rmcm is there & CTI port in UCM is registered to UCCE

And here is my Diagnostic Portico:

---------------------------------------

CTI Server 1A
nodeman.exe : 00:55:04 :

nmm.exe : 00:55:03 :

ctisrvr.exe : 00:54:27 : tm-CG1A ctisvr - [ACTIVE uce Port:42027]

Administration and Data Server
nodeman.exe : 00:54:51 :

nmm.exe : 00:54:47 :

configlogger.exe : 00:53:50 : tm-Distributor configlogger

cmsnode.exe : 00:53:50 : tm-Distributor cmsnode

Cms_JServer.exe : 00:53:50 : tm-Distributor cms_jserver

iseman.exe : 00:53:50 : tm-Distributor iseman

replication.exe : 00:53:50 : tm-Distributor replication

rtclient.exe : 00:53:50 : tm-Distributor rtclient

rtdist.exe : 00:53:50 : tm-Distributor rtdist

updateaw.exe : 00:53:50 : tm-Distributor updateaw

Logger A
nodeman.exe : 00:54:50 :

nmm.exe : 00:54:50 :

configlogger.exe : 00:54:09 : tm-LoggerA configlogger

csfs.exe : 00:54:09 : tm-LoggerA csfs

histlogger.exe : 00:54:09 : tm-LoggerA histlogger

recovery.exe : 00:54:09 : tm-LoggerA recovery

replication.exe : 00:54:09 : tm-LoggerA replication

Peripheral Gateway 1A
nodeman.exe : 00:55:04 :

nmm.exe : 00:55:03 :

jtapigw.exe : 00:55:03 : tm-PG1A jtapigw - jgw1 - [ ACTIVE ]

mdsproc.exe : 00:55:03 : tm-PG1A mdsproc - (InSvc Is-Enb Clk)

opc-cce.exe : 00:55:03 : tm-PG1A opc-cce.exe

pgagent.exe : 00:55:03 : tm-PG1A pgagent - (InSvc A:Active B:Disc)

eagtpim.exe : 00:55:03 : tm-PG1A eagtpim - pim1 - [tmCUCM1 ACTIVE]

testsync.exe : 00:55:03 : tm-PG1A testsync

Router A
nodeman.exe : 00:55:04 :

nmm.exe : 00:55:03 :

ccagent.exe : 00:54:45 : tm-RouterA ccagent - (InSvc 1/3 PGs)

dbagent.exe : 00:54:45 : tm-RouterA dbagent

dbworker.exe : 00:54:45 : tm-RouterA dbworker

mdsproc.exe : 00:54:45 : tm-RouterA mdsproc - (InSvc Is-Enb)

router.exe : 00:54:45 : tm-RouterA router

rtsvr.exe : 00:54:45 : tm-RouterA rtsvr

testsync.exe : 00:54:45 : tm-RouterA testsync

Cisco ICM Diagnostic Framework
DiagFwSvc.exe : 00:55:04 :

Ritesh Desai Fri, 02/17/2017 - 16:24

Dear karen,


try doin below.


utils service stop Cisco Finesse Tomcat

utils service stop Cisco Finesse Notification Service

utils service start Cisco finesse notification service

utils service atart Cisco finesse tomcat.


Hope this helps.

karen.johnson5801 Sat, 02/18/2017 - 13:40

Thanks,


I noticed the connection to DB still failed in Finesse setting.  (attached)


On the "Contact Center Enterprise Administration & Data Server Setting"


do you know why?





Attachment: 

Typically you should verify this by creating an ODBC data source on a different Windows server from the AW-HDS. Go to Admin Tools - ODBC Data Sources (32-bit) and add a new Data Source.

Go to System DSN and press Add. On Driver, scroll to the bottom and choose SQL Server. Give it a name.

In server, specify the server in the same way as you did in Finesse - host name or IP address. Presse Next.

Choose SQL Authentication. Press Client Configuration and uncheck Dynamically Assigned port. Ensure TCP/IP. Same port number as you use in Finesse (1433).

Enter login name and password. Next.

Skip changing config on the following screen - press Next. Press Finish.

Test the data source. Does that work? This is not exactly the same as what Tomcat does in Finesse, but it will help.

Regards,

Geoff

The other thing to verify is that Finesse is connected to your CTI Server. On the PG, open a command window and type "procmon <instance> CG1A ctisvr" and you should see a prompt (a few arrows >>>).

Type "clients" - you should see Finesse is connected.

This screen shot is from an instance called "demo" to CG4A with a simplex Finesse connection.

Regards,
Geoff

Attachment: 
karen.johnson5801 Sat, 02/18/2017 - 19:35

hi Geoff,

Do you have guideline on what need to configure on SQL side?  I didn't see in Cisco document for that.


Also the user login should be Windows NT or SQL user?


Thanks,

K

Karen,

CTI Server looks good.

OK, we can see from the screenshot you provided that you are trying to connect to the SQL server as "ucceadmin" and it's failing. Let's go over how you should have created this in SQL Server Management Studio. This is all documented in the Cisco Guides.

You right-clicked on Logins and created a new user called ucceadmin. You configured this as a SQL user (not Windows) and gave ucceadmin a password. Click off all the three boxes below that expire the password etc.

At the bottom of the page, you can set the default database to <instance>_awdb but this does not really matter. Everyone does it, so you should too - but it only controls the default database that comes up when you log into SQL Server Management Studio.

Next you clicked on Roles - this should just have one check box -- public.

Now go to User Mapping. Select the row for the database <instance>_awdb. Below that, check the box for dbreader and dbowner. You might as well do the same with <instance>_hds, but this is not really needed. You do not need to check any other boxes but dbreader and dbowner. You are not writing to the database so you do not need to be dbwriter or other things.

Now save the user.

What you should now do is exit SSMS under your current login and log back in (check SQL Authentication) as your new user ucceadmin. Make sure you have the password correct.

OK?

Now verify that you have set up read permission on the AWDB correctly by selecting New Query, and selecting the <instance>_awdb from the drop down at the top that picks the database for your query.

If you have given the ucceadmin user <instance>_awdb as the default database, this will have been selected for you - but that does not really matter. It's just a convenience for SSMS.

Now type "select * from Agent" in the Query Window and press "Execute". This must show all the agents. If it does not, log out and log back in under the "sa" user or whatever you were doing before to create the user "ucceadmin". Try the process again until you get this correct.

Now go back to that other box and try the ODBC client again. This must connect - press Test Connection. It must pass.

If you don't get this right, you are spinning your wheels in Finesse and your problem is not there - it is with your SQL config.

Regards,
Geoff

karen.johnson5801 Sat, 02/18/2017 - 22:00

Thanks Geoff,


Finally it is working now,  hooray :)


May I have the link in Cisco for this SQL steps ?

Another questions :

- Do I need to re-login my SQL service (attached) with this SQL "ucceadmin" user ?

- Do I also need to recreate "tm_awdb"  DB with this new SQL user?

- Or what else I need to recreate or re-login with this new user?


Thanks,

K

>>>> Do I need to re-login my SQL service (attached) with this SQL "ucceadmin" user 

Not at all. The account the services run under has nothing to do with the SQL account you created for Finesse to read the database.

FYI - I see that you have that running under a domain account, which used to be the recommendation.

But now the best practice is to run those services under Virtual accounts. You can see that on page 22 of "Cisco Unified Contact Center Enterprise Installation and Upgrade Guide, Release 11.5(1)" Step 11.

Step 11

On the Server Configuration page, click the Services Account tab. In the Services Account tab, you must associate the SQL services with the virtual account.

  • For the SQL Server Agent service, in the Account Name field, select NT Service\SQLSERVERAGENT
  • For the SQL Server Database Engine, in the Account Name field, select NT Service\MSSQLSERVER

Note: While you can use the Network or Local Services account instead of the Virtual account, using the Virtual account provides better security.

>>>Do I also need to recreate "tm_awdb"  DB with this new SQL user?

No. A number of SQL logins can be created to read an already created database. You made one for Finesse, and you will probably make one for CUIC; and if you do Live Data you will make one with quite different Roles and User Mappings.

Nothing else to do.

Maybe you will install a B side AW-HDS (in production you would) and have to do the same there, and set up Finesse with a "Backup Host/IP Address".

Regards,
Geoff




karen.johnson5801 Sat, 02/18/2017 - 19:19

hi Geoff,


Thanks, I tried with ODBC from other server, and gave me error (attached).

what is the possible issue here?


thanks,

K


Attachment: 

Actions

This Discussion