cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
244
Views
5
Helpful
9
Replies

Load sharing query

Raja_D
Level 1
Level 1

Hi,

Need advise for the below mentioned requirement.

Cisco router : 18xx

Lan network : 10.54.21.0/24 Primary & 10.54.74.128/26 secondary configured on a SVI interface of the router VLAN2..

Need to ensure that the Primary subnet 10.54.21.0/24 should pass through Primary WAN link 1 & Secondary subnet 10.54.74.128/26 to pass through secondary WAN link 2.


Primary wan link : 10.25.199.184/30

Secondary wan link: 10.24.128.51/30

Incase if the Primary WAN Link ( 10.25.199.184/30) fails the traffic for the Primary subnet ( 10.54.21.0/24 ) should automatically failover through the Secondary WAN link (10.24.128.51/30) and the same applies to secondary subnet (10.54.71.128/26) in vice versa.

BGP attributes that can be used is Local preference for Primary wan link 1 & AS-PATH prepend for secondary wan link 2...

please advise..

9 Replies 9

Borgenstrand
Level 1
Level 1

Depending on how everything is setup, you can use a route-map.
Create one access-list per subnet and then create a route-map to match those access-lists and then set the outgoing interface to one or the other.

interface FastEthernet0/0
ip policy route-map RMAP

access-list 1 permit 10.54.21.0 0.0.0.255
access-list 2 permit 10.54.74.128 0.0.0.63
route-map RMAP permit 10
 match ip address 1
 set interface Serial1/0
!
route-map RMAP permit 20
 match ip address 2
 set interface Serial1/1

Please note that in my example, the serial 1/0 is the primary and serial 1/1 is the secondary WAN link. 

Thank you Borgenstrand for your answer.

As per my understanding your answer would load share the traffic equally for two different subnets respectively onto the two available wan links , but how would the secondary subnet 10.54.74.128/26 be reacheable in network incase if the secondary wan link goes down ?

I would like to have both the Lan subnets to be always reacheable in network even if any of the either wan links goes down and a switchover to that Lan subnet on which the wan link fails should automatically pass through the other available wan link that is in the network. 

Please advise.. 

When I tried this in GNS3, the traffic from primary LAN always went to the primary WAN and the secondary LAN always went to the secondary WAN. If I broke the WAN connection it would choose the other one. However, it is not truly load balancing. If 90% of your internet traffic comes from the primary LAN, 90% of the internet traffic would then go to the primary WAN link. 

This however depends on how your network is set-up. Do you have two different ISPs or two links to one ISP? 

Yes we have two different ISP's and there are 2 different wan links connected on 2 Seperate interfaces (Fastethernet) ports on router. 

When I tried this out in GNS3, it worked as it should. The thing is, that is for outgoing traffic. Is outgoing traffic all that you are concerned about? 

I am concerned about both forwarding and reverse traffic.. 

In regards of outgoing traffic, you can do what I wrote before. 

In regards of ingoing traffic, it will not be load-balanced completely. Even if you add as-path prepend, BGP could still choose the other link due to the fact it has less as-paths to you.

I labbed this up in GNS3:

access-list 1 permit 10.54.21.0 0.0.0.255
access-list 2 permit 10.54.74.128 0.0.0.63

route-map PrimaryWANRMAP permit 10
match ip address 2
set as-path prepend 1
route-map PrimaryWANRMAP permit 20
match ip address
exit
route-map SecondaryWANRMAP permit 10
match ip address 1
set as-path prepend 1
route-map SecondaryWANRMAP permit 20
match ip address
exit

router bgp 1
neighbor 1.1.1.2 remote-as 2
neighbor 1.1.1.2 route-map PrimaryWANRMAP out
neighbor 2.2.2.2 remote-as 3
neighbor 2.2.2.2 route-map SecondaryWANRMAP out

In the above example I used BGP AS numbers 1-4. 

So, you should use multiple route-maps to do what you need. 

Thank you Borgenstrand for your reply... 

You are welcome.

 It would be great if you could rate helpful responses.  :)

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Innovations in Cisco Full Stack Observability - A new webinar from Cisco