cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1886
Views
0
Helpful
3
Replies

Secondary IP network doesnt appear to be routing

Jeff Bos
Level 1
Level 1

I have a current situation where I need to add a subnet. I have created a secondary IP (192.168.101.253). Hosts on the primary (192.168.1.0) can see all test hosts on the secondary (192.168.101.0). Sh ip route looks good. Only default VLAN is in use.

The problem is, test hosts on the secondary IP seem to only ping to other same subnet hosts on the switch and they cannot access the internet. Test hosts on the secondary have the correct gateway IP (192.168.101.253) for the secondary and can ping the address but they don't appear to be getting any routing info from the router. I feel like traffic isn't getting past the switch but I am not sure. Traceroute doesn't turn up any good info.

hostname ss-inside
!
boot-start-marker
boot-end-marker
!
card type t1 1
logging message-counter syslog
logging buffered 8000
enable secret 5 $1$yMn$oaNCiBooHyJ97o3lsS.
!
no aaa new-model
network-clock-participate T1 1/0
!
!
ip source-route
!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
archive
 log config
  hidekeys
!
!
controller T1 1/0
 channel-group 1 timeslots 1-24
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.101.253 255.255.255.0 secondary
 ip address 192.168.1.253 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0:1
 ip address 192.168.255.254 255.255.255.252
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.1.254
ip route 192.168.2.0 255.255.255.0 192.168.1.250
ip route 192.168.102.0 255.255.255.0 192.168.1.250
!
no ip http server
no ip http secure-server
!
logging trap debugging
snmp-server community fnb1fnb1 RO
!
!
!
!
control-plane
!
!
!
!
!
line con 0
 password 7 071605E5B505241
 login
 no modem enable
line aux 0
line vty 0 4
 password 7 13116001E017D7D
 login
!
end

Gateway of last resort is 192.168.1.254 to network 0.0.0.0


     192.168.255.0/30 is subnetted, 1 subnets
C       192.168.255.252 is directly connected, Serial1/0:1
S    192.168.102.0/24 [1/0] via 192.168.1.250
C    192.168.1.0/24 is directly connected, FastEthernet0/0
S    192.168.2.0/24 [1/0] via 192.168.1.250
C    192.168.101.0/24 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 [1/0] via 192.168.1.254

I cant decide if its an issue on the router or on the switch. Any assistance on this would be appreciated.

Thanks!

J

3 Replies 3

Michael Muenz
Level 5
Level 5

The host 192.168.1.254 (your gateway) needs a route for 101.X via 1.253.

Seems this is missing ...

Michael Please rate all helpful posts

Hi -

Add "no ip redirects" to the interface with the secondary IP.  Then from a non-config prompt execute "clear ip redirect".  Also check the subnet masks on the 192.168.1.x devices.  If they are using a /16 mask instead of /24, then you will have a problem there also.

PSC

It is an interesting thought about the possibility of an issue about subnet mask size. But I think it is much more likely to be an issue that the gateway at 192.168.1.254 needs a route to 192.168.101. Or perhaps it might be an issue that the gateway is doing network address translation for the 192.168.1.0 network but not translating for the 192.168.101.0 network.

HTH

Rick

HTH

Rick
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: