No extra tabs in Finesse Supervisor

Unanswered Question
Feb 6th, 2017

Hi,


Something weird; I want to create extra tabs in Finesse Supervisor, but I can't see them. when I add them under the agent role I do see the new tabs immediately.

For test I use:


<tab>
    <id>CustomTab1</id>
    <label>Test</label>
    <gadgets>
    </gadgets>
</tab>


Under agent I see the extra tab under supervisor role I add the same data, but I don't see en extra tab


Any idea?


Thanks


JH



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
j.huizinga Wed, 02/08/2017 - 10:53

Nope, nothing

This is what I have added under agent (just testing)

<tab>
                <id>CustomTab1</id>
                <label>This is Agent TAB 1</label>
                <gadgets>
                </gadgets>
            </tab>
            <tab>
                <id>CustomTab2</id>
                <label>This is Agent TAB 2</label>
                <gadgets>
                </gadgets>
            </tab>
            <tab>
                <id>CustomTab3</id>
                <label>This is Agent TAB 3</label>
                <gadgets>
                </gadgets>
            </tab>

And this works perfectly!!


And this is what I have added under supervisor:

<tab>
                <id>CustomTab1</id>
                <label>This is Supervisor TAB 1</label>
                <gadgets>
                </gadgets>
            </tab>
            <tab>
                <id>CustomTab2</id>
                <label>This is Supervisor TAB 2</label>
                <gadgets>
                </gadgets>
            </tab>
            <tab>
                <id>CustomTab3</id>
                <label>This is Supervisor TAB 3</label>
                <gadgets>
                </gadgets>
            </tab>


And I also tried with the column and columns tag:

<tab>
                <id>CustomTab1</id>
                <label>This is Supervisor TAB 1</label>
                <columns>
                    <column>
                        <gadgets>
                        </gadgets>
                    </column>
                </columns>
            </tab>
            <tab>
                <id>CustomTab2</id>
                <label>This is Supervisor TAB 2</label>
                <columns>
                    <column>
                        <gadgets>
                        </gadgets>
                    </column>
                </columns>
            </tab>
            <tab>
                <id>CustomTab2</id>
                <label>This is Supervisor TAB 2</label>
                <columns>
                    <column>
                        <gadgets>
                        </gadgets>
                    </column>
                </columns>
            </tab>


No extra tab's under finesse supervisor

UCCX version: 10.6.1.11001-31


Has anyone be able to create extra tab's in finesse supervisor?


Thanks


Jan

david.macias Mon, 02/13/2017 - 08:26

Jan,

Sorry it took me a while to do this in the lab and you're close, you're just missing a tiny piece. If you notice in the layout you'll have the opportunity to have two different layouts in the same XML. Once for agents and one for supervisors. You can tell them apart by this:

<layout>

<role>Agent</role>

</layout>

or

<layout>

<role>Supervisor</role>

</layout>

Make sure you're adding the tab in the right role.

david

j.huizinga Tue, 02/14/2017 - 07:59

Hi David,

Yes I am aware of that, I I have configured that correctly

For the moment it is something in my LAB, most customers have CUCM 10.X with UCCX 10.X or CUCM 11.X with UCCX 11.X and here we have no issues.

Or something wrong in my LAB (CUCM 11.5 with UCCX 10.6) or a bug between these levels.

Not really an issue, when I modify the XML on global level I have the tabs, only on Team level I don't see them.

Thank you for your help


Jan

j.huizinga Tue, 02/14/2017 - 08:04

Correct, this also works at my customer, in my LAB where I have CUCM 11.5 with UCCX 10.6 I have issues on team level

Jan


j.huizinga Sun, 02/12/2017 - 23:49

CUCM 11.5 and UCCX 10.6 seems to be a problem. I can't get supervisor tabs. I can get the tabs when I configure the tabs under "Desktop Layout" But when I configure the tabs under the "Team Resources" I don't get the supervisor tabs.

Customer has CUCM 10.5 and UCCX 10.6 and here it works perfectly.

Even after reinstalling UCCX 10.6 in my lab (with CUCM 11.5) I can't get the supervisor tabs.

Anyway, little weird

Can work with it by configuring the XML under "Desktop Layout"

JH


Actions

This Discussion