Cisco ASA and RDNSS (RFC 6106)

Unanswered Question

Hi

I have a Cisco ASA 5515x as my firewall / gateway.

I try to set up IPv6 in my network.

I thought it was a good idea to go with DHCP, but then I noticed that Android devices does not support IPv6 DHCP...

My Android devices get IPv6 addresses in my network somehow (maybe from some setting in the ASA?), but they does not get provieded DNS information.

After some more reading, I understand that the way devices get information about DNS servers, suffixes, etc without IPv6 DHCP, is through RDNSS.

But I cannot see anywhere in ASDM where I can provide that info.

So my question is: Does ASA support this option?

If not, what can I do?

If it does, where can I set it up?


Thanks.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Philip D'Ath Tue, 02/07/2017 - 11:11
User Badges:
  • Purple, 4500 points or more
  • Cisco Designated VIP,

    2017 WAN, LAN, VPN

I have never heard of RDNSS in relation to ASA's - so I am thinking the answer is no.

James Leinweber Mon, 02/13/2017 - 07:45
User Badges:
  • Silver, 250 points or more

As of ASA firmware 7.7 there is still no rdnss option when configuring RA's, so I'm with Philip: not yet.  If your ASA was running in transparent mode and upstream supported it off a router or something, it could pass through.

Android only started supporting RDNSS in 5.0, and still doesn't support DHCPv6.  Running v6-only as opposed to dual-stack is still a challenge, I think.

The android devices are doing SLAAC (stateless auto-address configuration) using the on-link prefixes from the ASA's router advertisements and appending their own host parts, be they EUI-64 mapped or privacy style, presumably after duplicate address detection (multicast a neighbor solicitation to ff02::1 all nodes and expect no advertisement in response).

-- Jim Leinweber, WI State Lab of Hygiene

Actions

This Discussion