Port choosing VLAN - unable to get IP

Answered Question
Mar 2nd, 2017
User Badges:

A port is working for VLAN 1, but when i set it for VLAN 2, it couldn't get ip from that VLAN. Sometimes it gets IP, but unable to connect Internet. (It says "DNS problem". Then i release the IP, it will get IP by 169.XXX.XXX

By the way, some ports in the same switch, are working for both VLAN, some of them couldn't.

What's the wrong thing?

Correct Answer by Julio Moisa about 3 months 3 weeks ago

Hi

As suggestion the vlan 1 should not be used and it should be shutdown for security purposes, I would like to know how are you providing DHCP to the vlan 2. 

How these vlans are different segments we should have the following configuration:

interface vlan 1
ip address 1.1.1.1 255.255.255.0
ip helper-address <dhcp server IP>
no shutdown


interface vlan 2
ip address 2.2.2.1 255.255.255.0
ip helper-address <dhcp server IP>
no shutdown

End user interface
interface fa1/1/1
switchport host  (optional, it will provide config for access mode)
switchport access vlan 2
swtichport mode access
no shutdown

Are you using a DHCP server standalone or DHCP configured on a router? Could you please share a topology and your configuration?

Hope it is useful

:-)


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Julio Moisa Thu, 03/02/2017 - 04:27
User Badges:
  • Blue, 1500 points or more

Hi

As suggestion the vlan 1 should not be used and it should be shutdown for security purposes, I would like to know how are you providing DHCP to the vlan 2. 

How these vlans are different segments we should have the following configuration:

interface vlan 1
ip address 1.1.1.1 255.255.255.0
ip helper-address <dhcp server IP>
no shutdown


interface vlan 2
ip address 2.2.2.1 255.255.255.0
ip helper-address <dhcp server IP>
no shutdown

End user interface
interface fa1/1/1
switchport host  (optional, it will provide config for access mode)
switchport access vlan 2
swtichport mode access
no shutdown

Are you using a DHCP server standalone or DHCP configured on a router? Could you please share a topology and your configuration?

Hope it is useful

:-)


Actions

This Discussion