UCCX RTMT Alert

Unanswered Question
Mar 7th, 2017
User Badges:

Hi


I am getting an Alert from our UCCX RTMT almost every 10 minutes. The Alert is as follows:


UTC :  %UC_SERVICEMANAGER-2-ServiceFailed: %[ServiceName=SOAP -Log Collection APIs][Reason=Service stopped abruptly][AppID=Cisco Service Manager][ClusterID=][NodeID=XXXXXXXXXXXXXX]: Service terminated.

AppID : Cisco Syslog Agent


Can you please advise what could be the solution.


Many thanks


Ali Alqwasmi



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Chris Deren Tue, 03/07/2017 - 04:57
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,
  • Cisco Designated VIP,

    2017 IP Telephony, Contact Center, Unified Communications

From similar thread here:

https://communities.cisco.com/thread/45238?start=0&tstart=0

I did open a TAC SR, and we found the root cause. The issue stemmed from an expired tomcat.pem certificate on each of the clusters where we were having the issue. Once I updated the tomcat.pem certificate I was able to start the SOAP - CDRonDemand service and the SOAP-CallRecord errors went away. I'm looking clean now.

-----

I had the same problem following an upgrade from 9.1.2 to 10.5, but with a different cause / resolution.  Thought I would add the solution here in case it helps others.

In our case the problem was caused by the CUCService application user not being a member of the 'Standard CCM Admin Users' group.  Addint the user to the group and restarting the service cleared the problem.

The TAC engineer also suggested setting the CUCService account to the same password as the application administrator account (i.e. the account created at install time for login to CCM) and restarting the service.  Changing the password wasn't necesary in our case.

Ali Alqwasmi Mon, 03/20/2017 - 00:24
User Badges:

Hi Chris 


Thank you for your reply. I checked the permissions information for the CUCservice user in the applications users and it is member of the 'Standard CCM Admin users' group.

I was thinking of restarting the password to match the application administration password, however just wanted to make sure that it wouldn't affect the UCCX sync with CUCM or any other operations.


Many thanks

Actions

This Discussion