Expressway transform to simplify dial string for CMR requesting traversal license

Answered Question

Having implemented CMR integration via Expressway, we're now trying to configure a transform on the Expressway-C as suggested in the 'Webex Meeting Center Video Conferencing Enterprise Deployment Guide (WB31) to 'Simplify the Dial String'.


The example given says 'For example, for a prefix of 7 use a regex pattern string of 7(\d{9})'.  This alone does not seem to work as the dial string coming from CUCM is 7(\d{9})@xxx.xxx.xxx.xxx:5060, so I have configured a dial string 7(\d{9})@.* and this seems to have done the trick as I am no longer seeing 'Event="Search Completed" Reason="Not found"' in the event log.


However I am instead seeing the following;


tvcs: Event="Search Completed" Reason="Service Unavailable" Service="SIP" Src-alias-type="SIP" Src-alias="[email protected]" Dst-alias-type="SIP" Dst-alias="sip:[email protected]:5060" Call-serial-number="1339e388-dede-4a81-a6b0-9f9f75164efd" Tag="c49c65ec-b179-446c-849e-a45d47f398a5" Detail="found:false, searchtype:INVITE, Info:No License Available" Level="1" UTCTime="2017-05-19 13:38:10,741"
licensemanager: Level="INFO" Detail="License not granted" call_id="a5d58fb1-b2a0-41a6-823b-ded7df5f2496" lic_type="traversal" tokens=2 UTCTime="2017-05-19 13:38:10,739"


it appears to be wanting a traversal license.


The Expressways are X8.6.1 which shouldn't need any additional licenses for CMR integration, but do you need traversal licenses to do this?  Do later Expressway version resolve this?


Thanks.

Correct Answer by Alok Jaiswal about 1 month 3 weeks ago

Its working as expected, hence i hardly believe the behavior will change going forward. Without the domain there is no way it detect it as a CMR call instead of a normal B2B call.

I am not sure what document you are referring to, but look at the WBS31 document here, and follow this one.

https://help.webex.com/docs/DOC-11707


If you want to save on licensing cost then you have to use URI dialing method with the domain.


Regards,

Alok

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Alok Jaiswal Tue, 05/30/2017 - 15:52
User Badges:
  • Bronze, 100 points or more

If you dial a numeric string in CUCM and then pass it via SIP trunk to Expressway, then Expressway will always see [email protected]_address_of_CUCM:5060, which is why you need the transform in Expressway to convert it to [email protected].

Alok Jaiswal Thu, 06/01/2017 - 16:22
User Badges:
  • Bronze, 100 points or more

Correct, but if you create a sip route pattern for domain "webex.com" and remove the route pattern and then dial "[email protected]" it routes via sip route pattern and then it will always shows up as the URI with domain and not via ip-address.

I would only do the way you are doing at the moment, if i have phones who are not able to dial alphanumeric URI's. But if they have Jabber then use that to dial in CMR. 


What's happening here is since the Expressway doesn't see that domain "webex.com" it treat is as normal B2B call and asking for license allocation. Read the Expressway release note for x8.6.


"Note: This only applies when the dialed string does not need transformation on the Expressway (for example, [email protected])."


http://www.cisco.com/c/dam/en/us/td/docs/voice_ip_comm/expressway/releas... 


Regards,

Alok

We already have SIP route patterns configured which allow dialling [email protected] and this works fine from Jabber.  But there's a specific section in the deployment docs about setting up simple dialling in the way that I've described and the question is all about why the transform wasn't working and why Expressway is throwing the license error.


If it makes sense for Expressway to be trying to apply a license in this scenario then I understand what is happening.  The question remains, would I see different behaviour with a later version of Expressway?

Correct Answer
Alok Jaiswal Fri, 06/02/2017 - 04:52
User Badges:
  • Bronze, 100 points or more

Its working as expected, hence i hardly believe the behavior will change going forward. Without the domain there is no way it detect it as a CMR call instead of a normal B2B call.

I am not sure what document you are referring to, but look at the WBS31 document here, and follow this one.

https://help.webex.com/docs/DOC-11707


If you want to save on licensing cost then you have to use URI dialing method with the domain.


Regards,

Alok

Actions

This Discussion