×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

SF300 VLAN DHCP disconnect

Unanswered Question

Good evening everyone, 


I have had the misfortune to have never run into a SF300-48 before recently. It is a doozy of a CLI and GUI. I can't seem to get my ShoreTel phones and LAN working simultaneously and the configuration of this device is counter to all of my CCNA studies. If I'm accurate in my thinking, all of my ports need to be trunk ports to allow DHCP to do it's thing for both VLANs (VOICE, and DATA)


I've tested DHCP for both VLANS but it will only work for one at a time. The DHCP Server is the other end of the trunk on port Gi4. Any help would be greatly appreciated.


My configs below:



MDSW1#show run
interface fa1
storm-control broadcast enable
exit
interface fastethernet1
storm-control broadcast level 10
exit
interface fastethernet1
storm-control include-multicast
exit
interface fastethernet5
storm-control broadcast level 10
exit
interface fastethernet7
storm-control broadcast level 10
exit
interface fastethernet8
storm-control broadcast level 10
exit
interface fastethernet9
storm-control broadcast level 10
exit
interface fastethernet12
storm-control broadcast level 10
exit
interface fastethernet15
storm-control broadcast level 10
exit
interface fastethernet22
storm-control broadcast level 10
exit
interface fastethernet42
storm-control broadcast level 10
exit
interface range fa1,fa5,fa7-9,fa12,fa15,fa22,fa42
spanning-tree portfast
exit
interface range fa1,fa5,fa7-9,fa12,fa15,fa22,fa42
port security mode max-addresses
exit
interface range fa1,fa5,fa7-9,fa12,fa15,fa22,fa42
port security max 10
exit
interface range fa1,fa5,fa7-9,fa12,fa15,fa22,fa42
port security discard trap 60
exit
vlan database
default-vlan vlan 1001
exit
interface range fa1-48
switchport forbidden default-vlan
exit
vlan database
vlan 1,10,20
exit
voice vlan id 20
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 001049 ShoreTel_Phone
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
interface vlan 1
no ip address dhcp
exit
bonjour interface range vlan 1
hostname MDSW1
username cisco password encrypted 9f2e833b117b58adbc8799a22a8859ae8c1511b4 privilege 15
ip ssh server
no snmp-server server
interface fastethernet1
macro description "switch | no_switch | switch | no_switch | ip_phone_desktop | no_ip_phone_desktop | ip_phone_desktop | no_ip_phone_desktop | ip_phone_desktop"
exit
interface fastethernet5
macro description ip_phone_desktop
exit
interface fastethernet7
macro description ip_phone_desktop
exit
interface fastethernet8
macro description "ip_phone_desktop | no_ip_phone_desktop | ip_phone_desktop | no_ip_phone_desktop | ip_phone_desktop"
exit
interface fastethernet9
macro description ip_phone_desktop
exit
interface fastethernet12
macro description ip_phone_desktop
exit
interface fastethernet15
macro description ip_phone_desktop
exit
interface fastethernet22
macro description ip_phone_desktop
exit
interface fastethernet42
macro description ip_phone_desktop
exit
interface gigabitethernet4
macro description "switch | no_switch"
exit
interface fastethernet1
!next command is internal.
macro auto smartport dynamic_type ip_phone_desktop
switchport trunk allowed vlan add 20
switchport trunk native vlan 1
exit
interface fastethernet2
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet3
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet4
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet5
!next command is internal.
macro auto smartport dynamic_type unknown
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet6
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet7
!next command is internal.
macro auto smartport dynamic_type unknown
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet8
!next command is internal.
macro auto smartport dynamic_type unknown
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet9
!next command is internal.
macro auto smartport dynamic_type unknown
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet10
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet11
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet12
!next command is internal.
macro auto smartport dynamic_type unknown
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet13
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet14
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet15
!next command is internal.
macro auto smartport dynamic_type unknown
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet16
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet17
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet18
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet19
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet20
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet21
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet22
!next command is internal.
macro auto smartport dynamic_type unknown
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet23
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet24
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet25
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet26
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet27
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet28
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet29
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet30
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet31
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet32
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet33
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet34
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet35
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet36
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet37
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet38
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet39
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet40
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet41
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet42
!next command is internal.
macro auto smartport dynamic_type unknown
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet43
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet44
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet45
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet46
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet47
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface fastethernet48
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
exit
interface gigabitethernet4
no macro auto smartport
switchport trunk allowed vlan add 10,20
exit
interface vlan 10
name DATA
exit
interface vlan 20
name VOICE
exit
 



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion