UCCX 8.5 - Recording script not working.

Unanswered Question
Jul 16th, 2017
User Badges:

I am using UCCX 8.5 , have a requirement of calling on a specific DN (trigger) by user, such that it prompt for recording a message on call, when successful this recorded message will be played to list of stored DN by calling them back.

For this i have declared variable in script of document type, tried with value 'DOC[]' and even with 'null'.

Issue is that when running reactive debugging, script is giving error when coming onto recording step, and with error as "system experiencing problem"  is not able to record. Debug Error is 'Error Unmarshaling return, nested exception is: java.io.WriteAbortedException: writing aborted; java.io.NotSerializableException: com.cisco.wf.cmt.dialogs.CMTRecordingDialogImpl'

I have also tried with Successful user authentication but no charm.

Even tried with uploading prompt option but error hits in recording step.

Have anybody ever faced this error, any solutions to this issue??

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Deepak Rawat Mon, 07/17/2017 - 00:31
User Badges:
  • Cisco Employee,

Please find attached the recording script with all the required prompts, just upload it to the system and try it. Associate with the application and you are good to go.

You will just need to make two changes to the below steps in this script:

1) On the promptmgmt = Get User (User ID : "derawat") step, change the user to your local user who had admin rights to login into CCX Admin page

2) Just below the above step, you will find the Authenticate User Password (promptmgmt, "cisco") step. Please change the password to the one as per the user that you are using in step 1.

 

Regards

Deepak

Attachment: 
kanheriiafnoc Mon, 07/17/2017 - 03:48
User Badges:

Thanx Deepak,  I had tried with your script, it works fine till i reach recording tab. In reactive debug i am getting same error as specified above. Thing is i am not able to record message, although i have enhanced user license, which supports use of recording in script.

I have tried searching error but didn't find error details / description.

Please share if any other workaround or solution is there to this problem.

Actions

This Discussion