×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Long delay when deleting Messages

Unanswered Question
Jan 12th, 2001
User Badges:

Call Manager Integration, 3.05a. Unity Enterprise 2.4.5(66). Exchange 5.5 SP4. Cisco MCS-7835 w/1Gb ram.<br><br>If a subscriber deletes a long message by phone, maybe 2 minutes in length, there is a good 15 second pause between the time the user presses the delete button and the continuation of their session. The user mailboxes are located on a separate exchange server local to the Unity server. I have created and checked the exchange MTA perf logs and of any other possible bottlenecks I could think of external to Unity, but to no avail. I created a mailbox local to the Unity server, and got almost the same delay, plus or minus a few seconds. I am currently running an extended subscriber report and I am creating and deleting long messages using that user as a guinea pig. <br><br>Any ideas?<br><br>Matt Slaga <img src="/images/icons/wink.gif"><br>TimeBridge Technologies<br><font color=red>MCNE</font color=red>, <font color=blue>MCSE2k-4.0-3.51</font color=blue>, <font color=purple>CCNA</font color=purple>, <font color=purple>CIPT2.0</font color=purple>

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Anonymous (not verified) Fri, 01/12/2001 - 09:27
User Badges:

Unfortunately there's only one way to make this faster and that's to set your Class of Service back to not copy messages that are deleted over the phone to the deleted items folder. Which I understand may not be what the site wants...

When we copy something to the deleted items folder, it's not something that we can easily do in the background so we have to submit the "move" request and wait for it to finish. For big messages it'll take a bit. When we just want the message deleted, we mark it deleted and let Exchange take care of the rest on it's own time so it happens right away. The good news is this delay should not affect other users currently logged in over the phone (in early versions of 2.4.0 this was the case). The bad news is there's not much we can do about the delay itself for the subscriber doing the move/delete.

If you clear the "Deleted messages are copied to the deleted items folder" check box on the "Messages" page of the COS that user is associated with, these pauses should go away entirely.


Jeff Lindborg
Unity Product Architect
Active Voice
jlindborg@activevoice.com
http://members.home.net/jlindborg

mslaga Fri, 01/12/2001 - 10:09
User Badges:

I created a test COS for the test user, and the problem was resolved. I suppose changing the codec from G711 to G729 would be a more viable solution if the customer "had to have" the option and didn't want the issues that come with it. If the licensing issue wasn't an issue, of course.

Matt Slaga
TimeBridge Technologies
MCNE, MCSE2k-4.0-3.51, CCNA, CIPT2.0

mslaga Mon, 01/22/2001 - 08:49
User Badges:

Just for the sake of asking, does this issue also pertain to forwarding messages to other subscribers via the telephone interface?

Matt Slaga
TimeBridge Technologies
MCNE, MCSE2k-4.0-3.51, CCNA, CIPT2.0

Actions

This Discussion