×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Help on 3500XL Config

Unanswered Question
Mar 7th, 2001
User Badges:

Hi all,


Can you please help me on configuring 3500XL 12.0(5)XU switch for separate voice vlan and data vlan.


What i did was:

data vlan : 1

voice vlan : 200


config:


step1:

enable

vlan database

vlan 200

exit


step2:

config t

int fa0/5

power inline auto

switchport trunk encapsulation dot1q

switchport mode trunk

switchport voice vlan 200


switchport trunk allowed vlan 200

switchport pripority extend cos 0


end


Now a computer connected to the phone is getting the ip address but the phone in continue to display IP CONFIGURING. any thoughts?.


Also how to associate an ip network to the voice vlan 200?


thanks in advance

Thaya

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jtdyer Wed, 03/07/2001 - 11:28
User Badges:

the first thing that springs to mind is: did you add a DHCP server for vlan 200 (or "ip helper" to one) so that the phones can get their new IP addresses & all the other info they need (call manager address, dns address, etc)?


Also check to make sure that call manager can reach (ping) devices in the new vlan 200, maybe there's a missing/incorrect default gateway somewhere -- if the phones are getting an IP address...


The switch commands you used should work...


John


thayanc Wed, 03/07/2001 - 11:35
User Badges:

how do you associate an ip network to the voice vlan 200?.

jtdyer Wed, 03/07/2001 - 12:52
User Badges:

you need to come up with a new valid ip subnet that will give you enough hosts to address all your phones, gateways, etc -- in our case I grabbed another "private" class C -- 192.168.75.x...

I don't know what you're doing for routing -- external router or RSM/MSM/etc -- but you'll need a router port in the new subnet -- so that the phones can reach the outside world... I cranked up a spare ethernet port on a 2600 we had & gave it 192.168.75.1... Don't forget to put that router port in vlan 200 (on a 3500, use the switchport access vlan 200 command to make it so).

Since the phones will all get their IP addresses via dhcp, you'll have to create a DHCP scope for the new subnet, add most of the new subnet to the DHCP pool (I did 192.168.75.10-.250) and don't forget to set up default gateway, dns, and option 150 scope options... THIS IS REALLY WHERE YOU'RE TELLING THE PHONES ABOUT THE NEW IP SUBNET (when they get their IP address)

You've got a couple choices on how the phones can reach the new scope: 1. add an ip helper statement to your new router port in vlan 200 -- so the dhcp requests from the phones will be forwarded along to your current dhcp server... 2. put a dhcp server in vlan 200... I kinda took approach 2 -- I put another NIC in my current NT server & put it in the 192.168.75.x subnet -- and put it's associated switch port in vlan 200... Also made sure I could ping the new NT server address from PCs in VLAN 1(to make sure routing works back & forth between the vlans)


The trick is not to think of vlan 200 as "special" or anything -- it has to follow normal vlan isolation rules (broadcasts are contained, to get from one vlan to another you must use a router, etc) -- so if you were to draw it out, you've just built a LAN with all the phones on it -- and another LAN with all the PCs on it. If there are any services that the phones need to boot/operate/etc on the PC LAN, you'll have to provide a mechanism for them to reach the PC LAN (which is what I was trying to describe by saying add a router port, set up a dhcp server, etc)...


hope this helps.

john

dgoodwin Sat, 03/10/2001 - 13:36
User Badges:
  • Cisco Employee,

You should also define the native vlan for the trunk ports to the phones. From the page at http://www.cisco.com/univercd/cc/td/doc/product/voice/ip_tele/avvidqos/qoscamps.htm#xtocid2607133 an example is:



interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk native vlan 12

switchport mode trunk

switchport voice vlan 112

switchport priority extend cos 0

spanning-tree portfast




As John mentioned, there will be 1 data vlan and 1 voice vlan. If the phones will be configured via DHCP then your DHCP server (whether it be a server machine or an IOS router) needs to be configured with another scope to support your voice vlan.


Then once you have connected a router that can talk to both VLAN's either via a trunk connection or via 2 separate interfaces, you'll need to use an ip helper-address on the voice vlan so the DHCP requests from the phones will get to the DHCP server.

Actions

This Discussion