caller ID and international dialing

Unanswered Question
Jun 13th, 2001
User Badges:

I have just cutover a call manager system using a 6608-PRI blade for the gateway. I am using the 9.@ route pattern. The PRI carrier (AT&T) does not want to be sent the "011" for international calls. What is the best way to handle this?

Also, with the same setup, call manager is only sending the 4-digit extension number for caller ID even though I set the gateway parameter "caller ID DN" to 248XXXX. Display IE delivery is checked and Presentation bit is allowed. What's missing?


Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
dgoodwin Wed, 06/13/2001 - 21:34
User Badges:
  • Cisco Employee,

Robert,


If AT&T does not want to be sent the 011 for international calls, how are they going to be able to tell that the number dialed is international? Are they expecting us to set the called numbering type to international in the ISDN setup message?


You could definitely create a Route Pattern called 9011.! and set the discard instructions to PreDot on the Route Pattern, and we would only send the numbers after the 011 to AT&T, but note that by default CallManager will probably set the numbering type to unknown in the ISDN setup message to AT&T. If this doesn't work, try going to the gateway configuration page for the 6608 PRI port and set the "Called Party Numbering Type Unknown" (something like that) to International, reset the gateway, and try again. Make sure to try dialing other numbers that go through that particular gateway like local/long distance and change back to defaults if needed.


For the Caller ID issue, remove the Caller ID DN from the gateway config. On the 9.@ Route Pattern, set the calling party transform mask to 408248XXXX and change the 408 part to whatever your area code is.


If it still doesn't work, you may need to turn on detailed tracing for CallManager (how to do this is at http://www.cisco.com/warp/public/788/AVVID/cm_trace.html) and then you can use the Q.931 Translator tool to figure out what you are actually sending as the Calling Party Number (Caller ID) out to AT&T. That tool is in C:\Program Files\Cisco\bin and you just open the CCM trace file with it.


Or, open a TAC case.

rvincent Thu, 06/14/2001 - 10:58
User Badges:

Dave:

thanks. i changed the "called Party Numbering type" from Call Manager to Unknown, left the route pattern as 9.@, and it works fine. seems that when call manager tells them its an international call, they don't want to see the "011". If we don't tell them its an international call, then they need to see the "011". Does that make sense?


I'll try your fix for the caller ID this evening. I did talk to TAC. They told me to use a XXXX translation pattern and put in 248XXXX under the calling party transform mask. What's the difference ?


Should the Use calling party's external mask check box be checked?

dgoodwin Thu, 06/14/2001 - 12:07
User Badges:
  • Cisco Employee,

Cool. Yes, that makes sense about the unknown. If the setting is Cisco CallManager, then it will probably set the called numbering type to international if 011 is dialed, unless you override it. So that should be fine.


About the Caller ID issue, the Pattern part of the Translation Pattern -- which you said is XXXX -- is the called number. So that means that if a caller dials XXXX then the calling number will change to 248 plus the extension of the caller. So I don't think that will fix the problem.


I think you need to put the calling party transform mask on the 9.@ Route Pattern like I indicated before, and if it does not fix it, capture the CCM traces and if you like, you can use the Q.931 Translator yourself and see what CM is sending to AT&T for the Calling Party Number.

We ran into this same exact issue w/ AT&T. You will not be able to integrate into the AT&T PRI using a skinny gateway. The reason for this centers around the fact that the 4ESS AT&T uses wants the call classified as ISDN/National or ISDN/International on the D Channel on a call-by-call basis.


We used an Cisco 2610 w/ NM-HDV-T1-24 to resolve this. The IOS-based H.323 gateways are much more flexible regarding signalling and digit manipulation. I can provide the config for the 2610 if interested.

dgoodwin Thu, 06/14/2001 - 21:19
User Badges:
  • Cisco Employee,

Actually, I think this has more to do with some of AT&T's switches being 4ESS that require tagging each call as Megacom, SDN, SDS, etc.


This is done with a Network Specific Facility IE in the ISDN setup message that they receive from the customer end. The problem is that CallManager is not currently capable of sending that particular IE so it can't be done with a Skinny gateway.


Cisco IOS can do this with the isdn nsf commands on the ISDN serial interface, so that is the only solution currently if you are one of the unlucky few AT&T PRI customers that are connected to one of their old 4ESS switches.

Actions

This Discussion