×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Template defaults

Unanswered Question
Jul 16th, 2001
User Badges:

I'm having an issue with creating a subscriber template. Every time I create a new template it has an extension associated with it by default. On the Call transfer page, in the "Yes, ring subscriber's extension:" field, there is always 9500. Why that number is there I can't figure out. I can't get rid of it and every new subscriber I make based on my "Standard Subscriber" template has this on the call transfer page. In addition, when I try to create a new subscriber with that number, I get an error message saying "Extension 9500 is already in use by CallHandler:cht_Standard subscriber. Please enter a unique extension."<br>Can anybody tell me how to get rid of the default number supplied for new subscriber templates?<br><br>

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Anonymous (not verified) Mon, 07/16/2001 - 02:50
User Badges:

hmmm... the primary call hanlders beind a template object should never have a DTMF_ACCESS_ID assigned to them. There was a problem in 2.4.5 where the template was being "cross linked" with a real subscriber (i.e. both the template and the subscriber were "sharing" a primary call handler). That looked similiar to what you're reporting... what version are you on here, by the way?

If you create a new template (i.e. not one based on an existing template) does it get a DTMF_ID as well?

We'd need to be able to get into the system and poke around in DOHPropTest to try and clean something like this up. It may not be as simple as deleting the DTMF_ID, you may have multiple objects pointing at the same call handler which would be bad.

You can run dbWalker off my web site to see if there some cross linked handlers but it wont automatically clean up an ill formed template.

You may also consider rerunning the ConfigMgr.exe and reapplying the default objects (opening greeting, default templates etc...). You'll lose your opening greeting voice file (and the operator or goodbye call handler voice files if you modified those for some reason... most folks don't) when you do that so you'll want to be sure to save it off as a wav file first, but other than that it'll leave your system in tact.


Jeff Lindborg
Unity Product Architect/Answer Monkey
Cisco Systems
[email protected]
http://www.AnswerMonkey.net (new page for Unity support tools and scripts)

Anonymous (not verified) Tue, 07/17/2001 - 08:45
User Badges:

I had this happen on a 2.46.102 system and running the default scripts was the only way to get it fixed.

bwelch Wed, 07/25/2001 - 00:45
User Badges:

I'm currently running 2.4.6 102. As far as I can tell, TAC fixed this using DohPropTest. I can now create a new subscriber template without having it associated with a DTMF_ID. I was told this was never supposed to be but I saw it and watched Pradeep Musugu remove it. Just now I created another subscriber template and it doesn't have the DTMF_ID associated. To me it seems the problem is fixed but you now have me worried that there are multiple objects pointing at the same call handler. I tried to run the dbWalker off your web site but received a run time error. If I have to I will run the ConfigMgr.exe but like I said, the problem seems to be gone. However, I would like to be sure it's gone for good.
Thanks for you help

Anonymous (not verified) Wed, 07/25/2001 - 02:31
User Badges:

You need to be logged in as the install account when you run dbWalker (as with most of my tools)... the web page and help states this but for whatever reason most folks miss it. I'm betting that's what the run time error you see is (it can't connect to the DOH without proper rights).

I'm unsure how an ID would have gotten in there, it's definitely a bug whatever it is since templates should never have an ID associated with them. I'd definitely try the dbWalker again (it does work... honest).

Jeff Lindborg
Unity Product Architect/Answer Monkey
Cisco Systems
[email protected]
http://www.AnswerMonkey.net (new page for Unity support tools and scripts)

Anonymous (not verified) Mon, 07/23/2001 - 01:37
User Badges:

HELP! Having this same problem -- even when I try to create a new subscriber template NOT based on the original. Need
instructions on fixing this. TIA!

Anonymous (not verified) Mon, 07/23/2001 - 02:23
User Badges:

There aren't any canned instructions for fixing this (i.e. go to the registry and set the "do funky stuff with the template" registry setting to false...).

I'm not entirely sure what's going on with your box or how it got into that state. We'll need to look around in the DOH on your box and do a few tests so we can see what's happening. You'll want to open an incident with TAC on this one.

Jeff Lindborg
Unity Product Architect/Answer Monkey
Cisco Systems
[email protected]
http://www.AnswerMonkey.net (new page for Unity support tools and scripts)

bwelch Wed, 07/25/2001 - 07:17
User Badges:

Problem fixed. -This issue was easily fixed once a TAC engineer gained access to the DOH and removed the DTMF entry for the call handler associated with new subscriber templates. I still don't know what caused this. Unity was upgraded from 2.4.5 to 2.4.6 102 four weeks before I noticed the issue.

Actions

This Discussion