×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Extension Mobility w/ 7940 Phones

Unanswered Question
Oct 18th, 2001
User Badges:

Call Manager 3.1(2c) w/ 7960 and 7940 phones


Added User Device Profiles w/ 7960 2-Line profiles (7940s don't appear to be an option) and added the Login/Logout Services.


Added the Users and associated them with the profiles.


Added all of the phones (using 2-line profiles for 7940s and 7960 respectfully) and enabled Extension Mobility w/ <Use Current Device Settings> for the Log Out Profile (which creates the Autogenerated Device Profiles).


Added the Login/Logout Services to the phone.


Added the Login/Logout Services to the Autogenerated Profiles


Now, here's the behavior when attempting to login:


Login works great on the 7960s.


When I login to the 7940, my primary extension appears on the second row of the phone display (below the header), and it says "Your current options" at the bottom of the display, everything else is blank. I can't get dialtone, and the phone is essentially dead. When I logout the phone returns to the proper Autogenerated config.


Also, if I create a 7940 phone using a 7940 1-line config, and once the autogenerated config is applied to the phone, I get the same appearance as above (one line on the second row, "Your current options", blank everywhere else, and no dialtone).


This appears to be tied to the 7940's templates, or lack thereof. It appears that the autogenerated profiles do not allow a template for 7940s, only 7960s.


Any help would be appreciated.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
rbewlay Thu, 10/18/2001 - 14:15
User Badges:

Your are right - 7940 only gives a single line for Extension Mobility. Fix expected in 3.1.3 I'm told


Rory

dgoodwin Thu, 10/18/2001 - 14:34
User Badges:
  • Cisco Employee,

Yes, the DDTS is CSCdv56387 and it looks like this will be fixed in 3.1(3)... there will be a new service parameter to address this.

Brian Carscadden Thu, 10/18/2001 - 15:16
User Badges:

Good to know, however I had a different problem.


I suspected an issue with the 7940 1-line template. So I removed the extension mobility and login services from the phone. Essentially I have a new 7940 ... It appears now that any 7940 I create and attempt to use the '7940 1-line' template the screen comes up blank with 'Your Current Options' displayed and NO extension.


Any way to fix a corrupt 7940 phone template, considering they DON'T appear at all in the Phone Button Template menu? I'm considering just reinstalling CM.


Any thoughts?



dgoodwin Thu, 10/18/2001 - 18:10
User Badges:
  • Cisco Employee,

Does everything work exactly the way it should if you configure the phone with the 7940 2-line template? If so, then we might be able to repair the problem in the database, or at least try to diagnose what has happened. You should call TAC on this unless you are comfortable navigating the database.

Brian Carscadden Fri, 10/19/2001 - 05:15
User Badges:

If I create a 7940 (without any associated Extension Mobility) and use the 2-line template, everything works fine. The minute I either use the 1-line template or an attempt Extension Mobility config (even w/ the 2-line template) the problems begin. With Extension Mobility, it seems to automatically change the button template back to 1-line, or even "NONE". So all in all, I think the problem is related to the 1-line template. I can deal with the other Extension Mobility limitations (1 line only) that you mentioned originally. Let me know what I can do to fix this in the database.


Many thanks for your help so far...

dgoodwin Fri, 10/19/2001 - 09:30
User Badges:
  • Cisco Employee,

If you haven't done this before, it will be safest to call TAC and have them take a look.

Actions

This Discussion