×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

cannot load flash

Unanswered Question
Nov 25th, 2001
User Badges:

Hello

I am sending you the following configuration the CISCO 2651 router. The problem with our router is that last night many times the light was fluctuated and our UPS was not working, becasue of that now the configuration we made on the router is not working and when ever we try to access the router through console it cant let us do any thing and shows us the message that the FLASH CANNOT BE LOADED. So pl tell me that this is the problem of the flash, IOS software or there is some configuration problem in this router. The router we are using is for the security purposes to secure our network from other internal network through access list / filtering like we had implement security so that one network cant access other .

Pl let me know the solution of this probelm

Thanks


The configuration of the router is:



Testing Lower main memory - data equals address

Testing Lower main memory - checkerboard

Testing Lower main memory - inverse checkerboard

Cleargin lower 4K memory for cache initialization

Clearing bss

Reading monitor variables from NVRAM

Enabling Interrupts

Enabling instruction cache

Reading cookie

Initializing main memory

Sizing NVRAM

Initializing PCI subsystem

Exiting init

C2600 platform with 32768 Kbytes of main memory


load prog: bad file magic number: 0x0

boot: cannot load "flash:"


rommon 1> dev

Devices in device table

id name

flash: flash

rommon 2> dir flash

file size checksum file name

4049 bytes (0xfd1) 0xf924 satrting-config

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
kestewart Mon, 12/03/2001 - 11:46
User Badges:

Looks like someone deleted the IOS image. Try loading a new IOS image in via Xmodem through the console port. To do this, put the IOS image you want to load into the router on the PC you've got connected into the console port, then use the command:

xmodem [-cyrx] [filename]

-c use CRC-16

-y use YMODEM protocol

-r copy image to RAM (default is first flash partition)

-x do not launch image on completion of download to DRAM (dangerous!)

Notes:

The ROMMON XMODEM /YMODEM transfer works on the console port only.

You can only download files to the router. You cannot use XMODEM/YMODEM to get files from the router.

After you download the new image and reload, it should work fine.


One other thing: Check the name of your startup configuration file - in the output above, there's a typo. It should be 'starting-config', not 'satrting-config'

Actions

This Discussion

 

 

Trending Topics - Security & Network