×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Cisco 2501 Configuration

Unanswered Question
Nov 28th, 2001
User Badges:

I am new to cisco routers so please excuse the simple questions. I have managed to set up point to point from our corporate office to our colocation. We have a 2621 route at the colo and a 2501 router at our corp via a T1. It seems to me that the connection speed is quit slow. I am not sure if I configured it right but I can get out to the internet and see all the other servers at the colo. The 'sh int' command on the 2501 router shows that e0 has 1020 collisions and 5 interface resets while the s1 shows o collisions and 764 int resets. Can anyone help?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
millerv Wed, 11/28/2001 - 14:46
User Badges:

how is the serial interface configured ?

I wouldn't worry about the collisions on the eithernet. I would be concerned about the resets,

set the clock on your router(s)

add the following config statements:

service timestamps debug datetime msec

service timestamps log datetime msec



make sure you have logging buffered on.

you should not be seeing all those resets

kynguyen Thu, 11/29/2001 - 08:57
User Badges:

Here is the config for the 2621 router:



Current configuration:

!

version 12.0

service config

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

ip subnet-zero

ip name-server 216.39.106.4

!

!

!

!

interface FastEthernet0/0

ip address 216.39.106.30 255.255.255.224

ip directed-broadcast

full-duplex

!

interface Serial0/0

ip address 192.168.2.1 255.255.255.0

ip directed-broadcast

!

interface FastEthernet0/1

ip address 192.168.3.254 255.255.255.0

ip directed-broadcast

full-duplex

!

ip classless

ip route 0.0.0.0 0.0.0.0 216.39.106.1

ip route 192.168.1.0 255.255.255.0 192.168.2.254

no ip http server

!

access-list 102 permit icmp any any echo-reply

dialer-list 1 protocol ip permit

dialer-list 1 protocol ipx permit

!

line con 0

exec-timeout 0 0

transport input none

line aux 0

line vty 0 4


!

end

svermill Wed, 11/28/2001 - 15:38
User Badges:

Make sure that your duplex settings match on all devices. High collision rates these days often are a result of full-duplex interfaces stepping on half-duplex transmisions.

kynguyen Wed, 11/28/2001 - 20:56
User Badges:

On the 2621 router both ethernet interfaces are running at full-duplex but on the 2501 router there is no option to enable full-duplex or even half-duplex. Does the 2501 have that feature?

millerv Thu, 11/29/2001 - 09:24
User Badges:

Doubt it. its a 10 meg int anyway. so it defaults

to half.

on your serial link, I assume you have external DSU/CSU's for a T-1. are they set up correctly ?

svermill Thu, 11/29/2001 - 10:08
User Badges:

Since it is your 2501 with the collisions, you might check to see that all attached devices are set for half-duplex. There may be a full-duplex device attached. But that shouldn't have any impact on your serial side, as Mr. Miller pointed out. I have never seen a hight number of "resets" on a serial interface so I have no idea what it means. Sounds like he might.

phil.wang@karsi... Fri, 11/30/2001 - 01:28
User Badges:

As the rule of thumb, if the collisions are less than 1% of the packects trafered, it is acceptable. Otherwise, I agree duplex/half-duplex misconfigure could be the problem of the ethernet side. Remember if you have any half-duplex only device such as LAN hub, you will have to use half-duplex for all. For the serial interface reset issue on 2501, I believe it is the 2501 router running out of the power. check the 'sh proc cpu' and sh proc mem' results. the 2501 router simply cant handle the traffic.

millerv Fri, 11/30/2001 - 09:06
User Badges:

Back to the serial interface. could you post a show

int serial0? There should be some stuff at the bottom indicating things like CRC errors. It might

be a clue to what you are getting so many resets/.



kynguyen Fri, 11/30/2001 - 09:39
User Badges:

Here is the sh int on all. The thing is serial0 is not being used. Since then i have cleared the counter to see if errors persist. it looks like ethernet0 still has alot of collisions though.



Ethernet0 is up, line protocol is up

Hardware is Lance, address is 0010.7b36.f1a0 (bia 0010.7b36.f1a0)

Description: Inside interface (Corp)

Internet address is 192.168.1.8 255.255.255.0

MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec, rely 255/255, load 1/255

Encapsulation ARPA, loopback not set, keepalive set (10 sec)

ARP type: ARPA, ARP Timeout 4:00:00

Last input 0:00:00, output 0:00:00, output hang never

Last clearing of "show interface" counters never

Output queue 0/40, 0 drops; input queue 0/75, 0 drops

5 minute input rate 2000 bits/sec, 2 packets/sec

5 minute output rate 17000 bits/sec, 2 packets/sec

1302389 packets input, 102189515 bytes, 0 no buffer

Received 1104869 broadcasts, 0 runts, 0 giants

4 input errors, 4 CRC, 4 frame, 0 overrun, 0 ignored, 0 abort

0 input packets with dribble condition detected

444176 packets output, 127744587 bytes, 0 underruns

4 output errors, 862 collisions, 5 interface resets, 0 restarts

0 output buffer failures, 0 output buffers swapped out



Serial0 is administratively down, line protocol is down

Hardware is HD64570

Description: Not used

MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, rely 199/255, load 1/255

Encapsulation HDLC, loopback not set, keepalive set (10 sec)

Last input 2w5d, output 2w5d, output hang never

Last clearing of "show interface" counters never

Output queue 0/40, 0 drops; input queue 0/75, 0 drops

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

1037 packets input, 61514 bytes, 0 no buffer

Received 1037 broadcasts, 0 runts, 0 giants

693 input errors, 693 CRC, 107 frame, 0 overrun, 0 ignored, 31 abort

1530 packets output, 72614 bytes, 0 underruns

0 output errors, 0 collisions, 25651 interface resets, 0 restarts

0 output buffer failures, 0 output buffers swapped out

6 carrier transitions

DCD=down DSR=down DTR=down RTS=down CTS=down



Serial1 is up, line protocol is up

Hardware is HD64570

Description: Outside interface (Corp)

Internet address is 192.168.2.254 255.255.255.0

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load 1/255

Encapsulation PPP, loopback not set, keepalive set (10 sec)

LCP Open

Open: ipcp, cdp

Last input 0:00:02, output 0:00:02, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0 (size/max/drops); Total output drops: 0

Output queue: 0/64/0 (size/threshold/drops)

Conversations 0/7 (active/max active)

Reserved Conversations 0/0 (allocated/max allocated)

5 minute input rate 17000 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

653339 packets input, 128371320 bytes, 0 no buffer

Received 1864 broadcasts, 0 runts, 0 giants

207 input errors, 207 CRC, 22 frame, 0 overrun, 0 ignored, 15 abort

564857 packets output, 40758984 bytes, 0 underruns

0 output errors, 0 collisions, 755 interface resets, 0 restarts

0 output buffer failures, 0 output buffers swapped out

29 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up

jchromcik Fri, 11/30/2001 - 11:39
User Badges:

what would be considered abnormal for CRC, overuns, collisions, and interface resets. I can look at these stats but can't tell whether they are functioning normal or not.

pbrady Sun, 12/02/2001 - 21:10
User Badges:

Hey,

I would start at the bottom and work your way up. First check your cables from the your side to the Telco box (CPE to Smart Jack). Scan cables and make sure they test good. I would change your encap type to PPP. This gives better support for higher level protocols. Here is a generic Serial Int config:


interface Serial0/0

ip address 192.168.1.1 255.255.255.252

no ip directed-broadcast

encapsulation ppp

service-module t1 timeslots 1-24


On your Ethernet problems if you have input errors and CRS's, I would bet that you have a duplex mismatch somewhere on your network. As a good reference with Cisco, you should always set your duplex and speed on all your interfaces. The 2501 and 2610's I think only support 10mb/half so you cant really do anything with those but make sure on your 2621 on the other end to set to 10mb/half-duplex.


Good luck!


Paul

faheyd Tue, 12/04/2001 - 11:09
User Badges:

Try and troubleshoot the problem in two separate sections:

1. The serial interface problems, see http://www.cisco.com/univercd/cc/td/doc/cisintwk/itg_v1/tr1915.htm . Following the hints in the above link, you have cleared your router/csu with loopbacks, you then open a job to the Telco to fix the link.


2. The ethernet can then be properly diagnosed. It could be anything. A bad pair on a workstation drop, duplex setting wrong on the switch, the phase of the moon. After checking equipment settings, you can look at the switch and see which interface/port is injecting collisions onto the network. If it's a dumb switch, you're going to have to log into each workstation individually and see what the NICs are telling you. Plus you have to review your installation and make sure there are no links over 100 meters (TOTAL) including patch cables, and subtract about 3 meters for every patch on a link.


Try not to make things more difficult than they already are. Just break it down into sections, and you'll be OK after it's all over.

amedwards Tue, 12/04/2001 - 11:47
User Badges:

I'd suggest doing a "clear counters serial serial1" to get a better picture of whats currently happening as the counters have "never" been cleared. Here's why:


Your "show int serial1" indicates the reliability of 255/255 over a 5 minute reporting interval and 1/255 load, indicating that the resets are from before the last 5 minutes (ie. maybe way in the past when you originally setup the T1) and the line loading is <1% of the available bandwidth.


Also remember that WAN traffic is bursty, so you might want to fine tune the polling interval to smaller periods and watch it the "sh int s1" output for rel and load... barring a more effective network management suite or at a minimum MRTG (freeware) to track historical patterns on your interfaces.

Actions

This Discussion