.dat file problem

Unanswered Question
Nov 29th, 2001
User Badges:
  • Bronze, 100 points or more

I tried to leave a voice message to a Internet Subscriber user which is located in a different organisation. Since I've assocaited a SMTP email address to this Internet Subscriber user, so the voice message can be sent to this user through email. After those user checked his inbox, there is an email with an attachment received. However, the attachement is in .dat file format instead of .wav format. This .dat file cannot be opened by all means. Would anyone like to tell me how to solve this problem?<br><br>Many thanks.<br><br>

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Anonymous (not verified) Thu, 11/29/2001 - 11:23
User Badges:

Sounds like that is happening AFTER Unity relays the messages to SMTP. Is there any email anti-virus software that might change the attachment or message class? Does this happen with all Internet Subscribers regardless of final destination? What happens if you send to an Internet Subscriber with a local address? Have you checked Microsoft's knowledge base for similar problems with sending attachments? What's strange is that .DAT is much more likely to be blocked (by IIS lockdown or URLscan tools) than a .WAV file is.

Scott Morgan
Cisco Systems TAC

Anonymous (not verified) Fri, 11/30/2001 - 02:36
User Badges:

Below are my findings:
Actually, I don't use email relay to forword the smtp emails to outside. Also, I try to send voice mails to different email addresses in different domains, like usa.net, hotmail.com and others ISP providers. I found that the voice messages will be converted to .DAT file in those internet email account providers, like usa.net and hotmail.com, while the voice messages occur propably in .WAV file format in other ISP email accounts. So, may I know the reason why this strange symptom happens?



Anonymous (not verified) Fri, 11/30/2001 - 09:12
User Badges:

This sounds similiar to a problem we worked through in 2.4.6 with internet subscribers sending messages to Notes accounts and it showed up as DAT files. It had to do with client support for "rich text format" (i.e. Outlook and Outlook Express showed the messages fine, web based clients and other showed the .DAT files).

Read through this thread and see if you can check some of these things in your case:

http://avforums.isomedia.com/cgi-bin/showthreaded.pl?Cat=&Board=unityent&Number=1009&page=&view=&sb=&vc=1#Post1009


Jeff Lindborg
Unity Product Architect/Answer Monkey
Cisco Systems
[email protected]
http://www.AnswerMonkey.net (new page for Unity support tools and scripts)

Anonymous (not verified) Sat, 12/01/2001 - 23:43
User Badges:

Since I am now using Exchange 2000 server, I cannot find the "Rich Text format" flag to modify on Exchange system manager or AD for users.
In my testing, the Internet Subscriber is using Hotmail address. After I send a voice message to Internet Subscriber, I use different clients to check this voice mail. First, I use Outlook client. It works fine and .wav file occurs. Then, I use Outlook Express client. Again, .dat file is attached. So, I view the email header and I found that the content type is "application/TNEF" while it is "audio/wav" in Outlook client. Afterwards, I try to browse this email from the browser. It is .dat attachment too. Then, I send a voice mail directly to Hotmail account (not through Internet Subscriber), .WAV file is attached even I check those voice mail from browser or Outlook Express client.
Later on, I create another email account on Outlook Express to check the internal user voice mail by using POP3. It works fine and .WAV file is correctly attached. So, could we conclude that using Internet Subscriber would create this weird problem?


Anonymous (not verified) Sun, 12/02/2001 - 06:47
User Badges:

No, this has nothing to do with the Internet Subscriber, it has to do with the fact that we're sending a message with a custom type (VOICE instead of SMTP in this case). The SMTP gateway SHOULD send the message attachments out as MIME encoded, but it's using the MS-specific TNEF stuff which most clients can't handle (including, oddly enough, Outlook Express). Since it doesn't know how to deal with the attachment, the clients will typically show up as the winmail.dat file instead of the WAV file you're looking for.

in Ex2K this is set on the SMTP gateway itself. You set the "use rich text format" to "never" and attachments will always go out MIME encoded, which is what you want. This is the default, however it appears this is a bug with Ex2K when dealing with message types other than plain-jane SMTP. Looks like they had problems with fax servers... the faxes were coming accross as .dat attachments instead of .TIF, same deal we're seeing here. There does appear to be a patch for it, however. Check out this link on MSDN:

http://support.microsoft.com/default.aspx?scid=kb;EN-US;q300996

They note the problem is still there in SP1 but there is a hot fix for it. Unfortunately you have to contact MS directly to get it, it's not available for download. It'll be in SP2 when it's released but I have no idea when that will be. You might try seeing if you can get the hot fix from them for this issue. If you do, let us know how it goes.


Jeff Lindborg
Unity Product Architect/Answer Monkey
Cisco Systems
[email protected]
http://www.AnswerMonkey.net (new page for Unity support tools and scripts)

Anonymous (not verified) Sun, 12/02/2001 - 07:52
User Badges:

Actually, reading over your original post, you may be OK if you just set the "use rich text format" flag to "never". You aren't sending messages out as VOICE (i.e. to another Unity user via the internet), you're sending it out as SMTP directly. The bug I mentioned in the previous post would burn you using VOICE but not SMTP.

Make sure you have your gateway configured to never use rich text (TNEF)... it's evil in a lot of ways. To check this open up the Exchange MMC control, go to "Global Settings" and then "Internet Message Formats". Select your format (i.e. "defaults") in the right pane and right click and select properties. On the "Advanced" tab, you'll see a radio button option for "never use" Rich Text Format. Make sure you select that. Not sure if you have to bounce Exchange to get this change to take effect or not.

It also turns out not using RTF is not the default as I has thought... this is very likely a fix for you then. Let me know if this clears the problem. We'll need to get a tech note in there somewhere for Ex2K sites to check this setting.


Jeff Lindborg
Unity Product Architect/Answer Monkey
Cisco Systems
[email protected]
http://www.AnswerMonkey.net (new page for Unity support tools and scripts)

Actions

This Discussion