×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

EIGRP doesn't accept backup default route

Unanswered Question
Jan 13th, 2002
User Badges:

Following scenario:


R3-----R4

¦ ¦

R1 R2


R1 and R2 are propagating a redistributed (static) default route to R3 and R4. R3 and R4 now get each 2 default routes. Only one is installed in the eigrp topoloy database. This one goes to the main routing table (R3--> next hop R1, R4--> next hop R2).

If I am shutting down interface on R3, default route pointing to R1, R3 doesn't do anything with the default route arriving from R4. The same happens on R4.

Any ideas?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
svermill Sun, 01/13/2002 - 12:07
User Badges:

Someone who sounded very knowledgeable in another forum was discussing EIGRP default route distribution the other day. I plan to take some of what I learned from him into the lab, but haven't had a chance yet. Thus, this is purely a theoretical suggestion:


try enabling 'default-information allow out' on routers R3 & R4 and see if they propagate what they learn to one another.


svermill Sun, 01/13/2002 - 15:15
User Badges:

I tried issuing the command that I mentioned earlier. It didn't show up in running config, so it is probably safe to assume that it is endabled by default. Oh well.

svermill Sun, 01/13/2002 - 16:52
User Badges:

Me again. I finally got some routers configed up for EIGRP and did some experimenting with default routes (boy did I re-learn a few things I thought I already knew). Anyway, I tried something very similar to your setup. If you do a 'sh ip eigrp top detail' you should see that both routes are actually in the topology database (the secondary may not show up without the 'detail' keyword because it isn't a feasible successor). Once you kill the successor route, the other finds its way into both the topo and forwarding tables via the query process very quickly. So you should find out why that secondary default route isn't finding it's way in the topo table to start with (if in fact it isn't). Are R3 and R4 successfully forming a good neighborship?

woker Mon, 01/14/2002 - 03:14
User Badges:

Situation has changed (don't know why). Following output if I shutdown link on R3 pointing to R1:

----------------------------------------------------

IP-EIGRP Topology Table for AS(3000)/ID(193.178.156.3)


Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

r - Reply status


P 0.0.0.0/0, 0 successors, FD is Inaccessible

via 193.178.156.3 (257026560/257024000), FastEthernet0/0

----------------------------------------------------

Why "Inaccessible" ?

woker Mon, 01/14/2002 - 06:32
User Badges:

Additional info:

- The neighborship between R3 and R4 is formed successfully.

- fa0/0 is the interface pointing to R4. (R3 gets that route from R4)

svermill Mon, 01/14/2002 - 09:20
User Badges:

Could you post your topology table using the 'detail' or 'all' keyword before you shut the interface?

Actions

This Discussion