×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.
MickPhelps Fri, 01/18/2002 - 15:05
User Badges:

Can you give more information? How do you know that it is still bound? Are you using frame maps or interface-dlci commands? Have you tried to "clear frame"? What does "show frame pvc" show?


If the telco is sending LMI for an interface, inverse arp will always try to figure out whats on the other side unless you disable it or use a frame map. Even if inverse arp doesn't try to map the PVC, LMI received will still show up on a "show frame pvc" as a dlci bound to an interface.


Mick.


mikejr@1024k.com Fri, 01/18/2002 - 15:33
User Badges:

My fault for not providing enough information.


I am using two 1600's with 56k CSU/DSU cards in them. They are connected with a rollover cable, with one router controlling the switching and the switching.


OT: you told me to try and turn on the switching earlier and it worked =) So thanks for fixing that little problem.


I actually hace to separate, but related problems..


I accidentally bounded DLCI 20 to S1 on my second router. I want to remove it becuase I already have DLCI in use another the router on the other end. I don't know whether or not that would cause conflicts, but regaardless, I want to remove it more uniformity's sake.


Now my other problem is the fact that when I try and add a DLCI to a sub interface of that ill-bounded S1 I get an error. It will say that the line protocol is up, then a few seconds later it is taken back down. I have a feeling that this problem is caused by the conflicting DLCI on the parent Serial interface.


Now that I've confused the heck out of you, here is the config info for that router along with the show frame pvc.


CONFIGURATION

-------------


Building configuration...


Current configuration:

!

version 12.0

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname butler

!

enable password voyager

!

ip subnet-zero

!

!

!

interface Ethernet0

ip address 192.163.123.30 255.255.255.0

no ip directed-broadcast

!

interface Serial0

no ip address

no ip directed-broadcast

shutdown

no fair-queue

!

interface Serial1

no ip address

no ip directed-broadcast

encapsulation frame-relay

logging event subif-link-status

logging event dlci-status-change

!

interface Serial1.1 point-to-point

ip address 10.0.0.3 255.255.255.0

no ip directed-broadcast

frame-relay interface-dlci 30

!

router eigrp 202

network 192.163.123.0

!

ip classless

!

!

line con 0

exec-timeout 5 0

transport input none

line vty 0 4

password voyager

login

!

end


SHOW FRAME PVC

--------------


PVC Statistics for interface Serial1 (Frame Relay DTE)


DLCI = 20, DLCI USAGE = UNUSED, PVC STATUS = ACTIVE, INTERFACE = Serial1


input pkts 1271 output pkts 0 in bytes 90821

out bytes 0 dropped pkts 0 in FECN pkts 0

in BECN pkts 0 out FECN pkts 0 out BECN pkts 0

in DE pkts 0 out DE pkts 0

out bcast pkts 0 out bcast bytes 0 Num Pkts Switched 0


pvc create time 00:45:25, last time pvc status changed 00:45:25


DLCI = 30, DLCI USAGE = LOCAL, PVC STATUS = DELETED, INTERFACE = Serial1.1


input pkts 0 output pkts 3 in bytes 0

out bytes 843 dropped pkts 0 in FECN pkts 0

in BECN pkts 0 out FECN pkts 0 out BECN pkts 0

in DE pkts 0 out DE pkts 0

out bcast pkts 3 out bcast bytes 843

pvc create time 00:44:54, last time pvc status changed 00:44:44


**Note: I noticed when I pasted this into the window that the DLCI *is* removed from S1, but it's still in the PVC listing. **


But it still does not let me add a new DLCI mapping to the S1.1 interface.


Also for future reference is there any way to clear all configurations and start over as if the router just came outta the box?



Hope you can make some sense of this mess =)

--Mike


MickPhelps Fri, 01/18/2002 - 15:47
User Badges:

dlci 20 is probably comming from the other router. I would check the other config to make sure its no longer there. try a clear frame as well.


You'll want to create one sub-if for each PVC that you wish to run on the same main serial interface. Don't try to create multiple DLCI mappings for a single p2p sub-if.


If you need to do this, you may wish to use "frame-relay map" and point-to-multipoint interfaces or sub-ifs.


Mick.


mazhar71 Mon, 01/21/2002 - 07:23
User Badges:

Hi,

Try to use "no frame-relay interface dlci XXXX"

Regards

svermill Fri, 01/18/2002 - 16:41
User Badges:

On your router that is set up as the frame switch, you set the 'frame map ip x.x.x.x nnn' on the interface. That DLCI (nnn) gets propogated to the distant end router via LMI. You don't even need a map statement on the other router because inverse arp takes care of the rest. However, you can add the static statement for clarity. Note, though, that since your LMI is coming from the frame switch, the DLCI must match if you decide to add the static statement on the remote.


Start by adding nothing on the remote, clear your frame inarp, wait a minute or two, ping accross the link...everything should work. Then 'sh frame map' and you should see the DCLI as assigned by the map statement on the switch.

svermill Fri, 01/18/2002 - 16:55
User Badges:

Oh yeah, I just remembered that you were using subinterfaces. So you can't leave the DLCI statement out because the LMI only goes to the main interface and must be associated with a subinterface from there. If you would like to follow my earlier post as a way to see how things are working in the background, start without using subs. Then put your sub back in place, but realizing that the DLCI statement must match that which is being propogated by the switch.


Sorry for the confusion. Its waaay past beer-thirty.

kmuthukamu Tue, 01/22/2002 - 07:35
User Badges:

Hi,


Removing the DLCI value depends on the interface where you configured.

1. If it's physical interface & allowed for dynamic DLCI mapping, pls. try by giving *clear frame-relay-inarp*.

2. If it's subinterface & static dlci , check by removing the frame-relay map command configured on both sides.


Hope it helps.


-Kanchi





Actions

This Discussion