×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Help needed with 806 NAT setup.

Unanswered Question
Jan 21st, 2002
User Badges:

Ok, first off, I know hardly anything about this but got stuck doing it anyway.


I'm attempting to setup a cisco 806 with NAT. It will be connected between a DSL router and the LAN to provide internet access to stations on the LAN. I have to do the routing and NAT here because the DSL router won't do it, and the way the ISP assigns the IP's is a little screwy.

I need it to do nat from the inside addresses 10.0.0.x to the outside public addresses 65.x.x.x.


I'm using the standard IOS software, do I need a different feature pack?


From the 806:

I can ping DSL router

No name resolution out.

I can ping LAN


From local station:

I can ping Lan int on 806

all other outside pings return dest unreachable


DSL Router:

LAN int set on 65 net

NAT off

DHCP off


If I switch the local machine over to the 65 net (IP and GW) it works fine. But the local machines MUST remain on the 10.0.0.x net.


Am I going about this all wrong?


Here's what I have so far. Thanks for any help you can give. Here's an example of what I'm trying to do.

http://www.precdata.com/network.jpg

Is this even possible to do?


show run

Building configuration...


Current configuration : 1480 bytes

!

version 12.2

no parser cache

no service single-slot-reload-enable

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname xxxx

!

logging rate-limit console 10 except errors

enable secret 5

enable password 7

!

username xx password 7

ip subnet-zero

ip name-server 205.152.0.x *********ISP DNS servers

ip name-server 205.152.0.x

ip name-server 205.152.0.x

!

no ip dhcp-client network-discovery

lcp max-session-starts 0

!

!

!

interface Ethernet0

description LAN connection ********Connected to LAN hub

ip address 190.20.50.111 255.255.255.0 *********Set as gateway on local

machines

ip nat inside

no cdp enable

hold-queue 32 in

!

interface Ethernet1

description WAN connection to ISP

ip address 65.x.x.2 255.255.255.0 ******** (one of 5 public IP's, other

2 will be static later connected to DSL router)

ip nat outside

no cdp enable

!

router rip

version 2

network 190.20.0.0

no auto-summary

!

ip default-gateway 65.x.x.1 **********(dsl router lan

interface)

ip nat pool DynamicUsers 65.x.x.4 65.x.x.5 netmask 255.255.255.0

*********2 of the 5 public IPs that private dhcp stations will use for

internet.

ip nat inside source list 1 pool DynamicUsers overload

ip classless

ip http server

!

access-list 1 permit 190.20.0.0 0.0.255.255 **********(allow everything

from this net to go out)

access-list 111 permit icmp any any echo

access-list 111 permit icmp any any time-exceeded

access-list 111 permit icmp any any echo-reply

!

line con 0

exec-timeout 120 0

stopbits 1

line vty 0 4

exec-timeout 0 0

login local

length 0

!

scheduler max-task-time 5000

end


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
kowhai Mon, 01/21/2002 - 08:49
User Badges:

What DSL Router are you using?

-Peter

Actions

This Discussion