×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

2621 dial up into NT4 RAS server PPP Problems

Unanswered Question
Jan 31st, 2002
User Badges:

I have configured a 2621 to access a network via a NT4 RAS server, using a modem on the aux port. This seems to work quite well. BUT, when I try to use this over a satellite link there seems to be a problem when the end to end delay exceeds a second or so. What I see is the packet leave the router but never return. Also occasionally there is a large amount of APPP65 traffic in and out of the router, for no apparent reason (something resyncing perhaps?). I also experience a problem where a ping request is replied to at the async port but never seems to meet the higher protocols, i.e. the request hits the router but not IP/ICMP as if it is stuck in a buffer or being dropped. I do not experience these problems if I am using the modem attached directly to the router. (The satellite provides the RS232 comms between router and modem)

Does anyone know of a timeout value that can be increased to allow better stability? or have any other ideas.


The router config


(BTW The modem printer command is because the modem has a weird interface where DCD (DSR) cannot be controlled and is always set high)


Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Ocean

!

enable password ******

!

!

!

!

!

memory-size iomem 30

ip subnet-zero

no ip domain-lookup

!

chat-script SHORE ABORT ERROR ABORT BUSY "" "AT" "OK" "ATDT\T" TIMEOUT 60 CONNECT \c

modemcap entry paul:MSC=&c0*fl0*mf0&d6

!

!

!

interface Loopback0

ip address 132.0.214.4 255.255.255.255

no ip directed-broadcast

!

interface FastEthernet0/0

ip address 25.59.204.1 255.255.255.0

no ip directed-broadcast

no ip mroute-cache

speed auto

half-duplex

no cdp enable

!

interface Serial0/0

ip unnumbered FastEthernet0/0

no ip directed-broadcast

encapsulation ppp

ip ospf authentication-key NAVYNET

ip ospf cost 20

ip ospf hello-interval 15

ip ospf dead-interval 45

no ip mroute-cache

!

interface FastEthernet0/1

no ip address

no ip directed-broadcast

shutdown

duplex auto

speed auto

!

interface Async65

no ip address

no ip directed-broadcast

encapsulation ppp

dialer in-band

dialer pool-member 20

async default routing

ppp authentication pap chap ms-chap callin

ppp chap refuse

ppp pap sent-username NTDOMAIN\userid password **************

!

interface Dialer10

ip unnumbered Loopback0

no ip directed-broadcast

dialer pool 20

dialer string 123456789

dialer-group 1

no cdp enable

!

router ospf 1

area 0.0.0.0 authentication

network 25.0.0.0 0.255.255.255 area 0.0.0.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer10 150

no ip http server

ip ospf name-lookup

!

access-list 101 permit ip any any

dialer-list 1 protocol ip list 101

!

line con 0

password letmein

login

transport input none

line aux 0

exec-timeout 0 0

script dialer SHORE

modem Printer

transport output none

stopbits 1

speed 19200

flowcontrol hardware

line vty 0 4

password letmein

login

!

end


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jduffek Thu, 01/31/2002 - 19:53
User Badges:

We should compare the two different async chips the modem and the sat-modem are using and nail it down. What models are these two different devices? Hopefully some research with thier documentation can help us out.


Josh

mitchellp Fri, 02/01/2002 - 07:59
User Badges:

I'm not sure what the chipset is but I do know that the modem is a Motorola codex 3265 fast and the mux is a GDC (General Datacom, I think) minimux (now obsolete!) The sat channel is seriously strange. All interfaces present as DCE and the cable to the modem is DCD from modem to RTS on sat channel (otherwise no comms at all end to end) TX / RX crossed, and DSR from sat channel to DTR on the modem. Flow control is handled by the sat channel at the 2621 end by RTS/CTS, but it looks to me like these are simply linked together (no output level at all from CTS without input from RTS. All signals jammed high on the modem. (DSR, DCD, DTR, RTS)

DCD is permanently high from the sat channel to the 2621 and DTR from 2621 seems to have no effect at all on the link or the remote modem, so I guess it's not passed through. RTS/CTS flow control as above.

Hope this helps.


Paul

Actions

This Discussion