×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

SNMP requests that work against 3.1(2c) fail against 3.1(3a)

Unanswered Question
Feb 8th, 2002
User Badges:
  • Green, 3000 points or more

Greetings folks,


Newbie alert.


This is my first post to this forum so take it easy on me if I'm asking a question that has already been answered. I searched and could not find any thing pertinent.


I'm looking at Network Management of VOIP networks and have an reasonable application that works fine against 3.1(2c) CCM and also an older 3.0 version. But when I point this at the 3.1(3a) CCM it fails.


I'll give you a simple example rather than describe the application and perhaps you can point me in the right direction.


For example, if I send this simple SNMP command towards a 3.1(2c) CCM:


/usr/local/bin/snmpget -m all geohplabpg1b.cup.hp.com public enterprises.cisco.ciscoMgmt.ciscoCcmMIB.ciscoCcmMIBObjects.ccmAlarmConfigInfo.ccmGatewayAlarmEnable.0


It returns with:


enterprises.cisco.ciscoMgmt.ciscoCcmMIB.ciscoCcmMIBObjects.ccmAlarmConfigInfo.ccmGatewayAlarmEnable.0 = true(1)


But against a 3.1(3a) CCM:


/usr/local/bin/snmpget -m all ws76082p.cup.hp.com public enterprises.cisco.ciscoMgmt.ciscoCcmMIB.ciscoCcmMIBObjects.ccmAlarmConfigInfo.ccmGatewayAlarmEnable.0


It fails with:


Error in packet

Reason: (genError) A general failure occured

Failed object: enterprises.cisco.ciscoMgmt.ciscoCcmMIB.ciscoCcmMIBObjects.ccmAlarmConfigInfo.ccmGatewayAlarmEnable.0


I know the agent is working because:


/usr/local/bin/snmpget -m all ws76082p.cup.hp.com public system.sysUpTime.0


returns with:


system.sysUpTime.0 = Timeticks: (6123) 0:01:01.23


Is there some way to validate the situation in the agent?


Regards,

Geoff Thompson



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
geoff@hp.com Fri, 02/08/2002 - 16:32
User Badges:
  • Green, 3000 points or more

Hi,


I hate to reply to my own message but here is a little more data. Instead of a focussed SNMP get I'll just walk the MIB starting at enterprises ...


/usr/local/bin/snmpwalk -m all ws76082p.cup.hp.com public enterprises


enterprises.cisco.ciscoMgmt.23.1.1.1.1 = NULL

enterprises.cisco.ciscoMgmt.23.1.1.1.1.1.2 = 2

enterprises.cisco.ciscoMgmt.23.1.1.1.1.2.2 = 1

enterprises.cisco.ciscoMgmt.23.1.1.1.1.3.2 = 60

enterprises.cisco.ciscoMgmt.23.1.3.1.0 = 1

enterprises.cisco.ciscoMgmt.23.1.3.2.0 = 60

enterprises.cisco.ciscoMgmt.23.1.3.3.0 = 180

enterprises.cisco.ciscoMgmt.23.1.3.4.0 = "ws76082p"

Error in packet.

Reason: (genError) A general failure occured

Failed object: enterprises.cisco.ciscoMgmt.23.1.3.4.0


Could this be a bug in the extensions to the SNMP agent. The walk is fine on all the other Call Managers.


Regards,

Geoff Thompson

Actions

This Discussion