×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Routing between a Cisco 2514 router and an ADSL modem

Unanswered Question
Mar 26th, 2002
User Badges:

Hi,

I have an ADSL model connected to the Internet. I also have a Cisco 2514 router that I would like to connect to the ADSL modem to provide Internet to the internal network.

I erased the startup-config on the 2514 so as to configure it from scratch. The 2514 router is running IOS 11.00. I assigned IP addresses to the two Ethernet ports on the 2514. One Ethernet port on the 2514 (assigned IP address of 192.168.0.1 and mask of 255.255.255.0) is connected to a hub and the other port to the ADSL modem (assigned IP address of xxx.xxx.xxx.206 and mask of 255.255.255.252 where xxx is a number). The modem IP address is xxx.xxx.xxx.205. I could ping the two Ethernet port from a PC connected to the hub. However, I was unable to ping the ADSL modem from the PC but I could ping the Modem from a telnet session on the 2514. I could achieve what I wanted to do using Microsoft W2K with Internet sharing enabled.

I am not sure what to do next. Does RIP needs to be enabled? Do I have to do anything with the static route table. Would you be able to give detail instruction.

Thanks in advance for your help.

Regards,

Kevin

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
beth-martin Tue, 04/02/2002 - 07:00
User Badges:
  • Bronze, 100 points or more

Turning on RIP would get the job done, at least as far as being able to ping your ADSL modem (getting beyond that may be another step). Adding a couple of static routes would be another solution. Give the following to link a look for the syntax of a static route:


http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/12cgcr/np1_r/1rprt1/1rindep.htm#xtocid8


Good luck!

klwmpa Thu, 04/04/2002 - 00:00
User Badges:

Hi


Thanks for responding to my message. I'm still can not it to work. I have enable RIP and added static route. Would you be kind enough to have a look at the router configuration file to see if there are any obvious mistake. Your help is greatly appreciated. Sorry I have mask some IP addresses (it will be marked as xxx.xxx) for security reason.


The modem is at address xxx.xxx.165.205 and is connected to Ethernet1 interface.


Thanks

Kevin



Using 676 out of 32762 bytes

!

version 11.0

service udp-small-servers

service tcp-small-servers

!

hostname Granville

!

enable secret 5 $1$01.x$wFx6zSykKdPK90sua2hpx/

enable password test

!

ip subnet-zero

!

interface Ethernet0

ip address 192.168.0.1 255.255.255.0

!

interface Ethernet1

ip address xxx.xxx.165.206 255.255.255.252

!

interface Serial0

no ip address

shutdown

no fair-queue

!interface Serial1

no ip address

shutdown

!

router rip

network 192.168.0.0

distance 10

!

ip default-gateway xxx.xxx.165.205

ip route 192.168.0.0 255.255.255.0 xxx.xxx.165.205 130

!

line con 0

line aux 0

transport input all

line vty 0

password test

login

length 25

line vty 1 4

password test

login

!

end

mvanterve Thu, 04/04/2002 - 02:10
User Badges:

Hello,


I think that you need to enable NAT.

It looks like that your ADSL modem doesn't know about the network 192.168.0.0.


Regards,


Mario

klwmpa Thu, 04/04/2002 - 20:31
User Badges:

Hi Mario,


Thanks for your response. Would you know how to enable NAT on a Cisco 2415 router?


Thanks,


Kevin

srittenberg Thu, 04/04/2002 - 21:37
User Badges:

again, you have no default route. you must have a default route for the Internet access. You do NOT need NAT.

srittenberg Thu, 04/04/2002 - 21:34
User Badges:

what's your route statement? you should have the default route:


ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.205


your default gateway for the win2k PCs should be 192.168.0.1. It's easier to setup the router as a dhcp server, you could add the default route; DNS; domain name to the dhcp... or not. the problem is the route. You do not need to run RIP because no need to. Use static when you can, use routing protocol when you must. in your case, you have a stub router, static route will be fine.

mvanterve Fri, 04/05/2002 - 00:25
User Badges:

I think that the problem is not on the router.

It seems that the ADSL modem doesn't know the way back to the 192.x.x.x network.

The ADSL modem should be pointing for the 192.x.x.x network to the interface of the router.


Mario

Actions

This Discussion