×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

BGP RR and OSPF

Unanswered Question
Apr 18th, 2002
User Badges:
  • Bronze, 100 points or more

Hi,

Here is what I have setup in the lab and for some reason I don't get BGP reflected routes as best route in the route-reflector-client's routing table. I know it has to do with OSPF. If I use RIP the same routes appear as the best routes. Any ideas as to what am I doing wrong here.


Router#1 (Acts as RR)


router ospf 1

log-adjacency-changes

network 172.16.0.0 0.0.255.255 area 0

!

router bgp 3

bgp log-neighbor-changes

redistribute ospf 1 match internal external 1 external 2

neighbor 172.16.1.2 remote-as 3 (To Router#1)

neighbor 172.16.1.2 route-reflector-client

neighbor 172.16.10.2 remote-as 3 (To Router#2)

neighbor 172.16.10.2 route-reflector-client



Router#2 (RR-client#1)

interface Loopback100

ip address 172.16.65.1 255.255.255.0


router ospf 1

log-adjacency-changes

network 172.16.0.0 0.0.255.255 area 0


router bgp 3

bgp log-neighbor-changes

neighbor 172.16.1.1 remote-as 3 (To RR)




Router#3 (RR-Client#2)

router ospf 1

log-adjacency-changes

network 0.0.0.0 255.255.255.255 area 0

!

router bgp 3

bgp log-neighbor-changes

neighbor 172.16.10.1 remote-as 3 (To RR)




Here is my BGP routing table on RR-Client#2



RR-Client#2 show ip bgp

BGP table version is 31, local router ID is 172.16.10.2

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal

Origin codes: i - IGP, e - EGP, ? - incomplete


Network Next Hop Metric LocPrf Weight Path

*>i172.16.1.0/24 172.16.220.1 0 100 0 ?

*>i172.16.2.254/32 172.16.220.1 0 100 0 ?

*>i172.16.10.0/24 172.16.220.1 0 100 0 ?

*>i172.16.20.0/24 172.16.220.1 0 100 0 ?

--------- * i172.16.65.0/24 172.16.1.2 65 100 0 ?---------------

*>i172.16.100.0/24 172.16.220.1 7 100 0 ?

*>i172.16.220.0/24 172.16.220.1 0 100 0 ?



Everything else is fine but 172.16.65.0/24 route is not selected as the best route when I use OSPF as IGP. This route is originated from RR-Client#1.


I checked the RouterID for BGP and OSPF both matches I am not sure what else to check.


Thanks


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Gilles Dufour Thu, 04/18/2002 - 14:38
User Badges:
  • Cisco Employee,

could we get a "sh ip bgp 172.16.65.0 255.255.255.0" and a 'sh ip route 172.16.65.0" and a 'sh ip ospf data"

Anonymous (not verified) Thu, 04/18/2002 - 15:08
User Badges:

Hi,

I will get you that in few minuets . You can easily reproduce this by setting up three routers one as RR and other two as clients. Use OSPF as IGP and also try RIP. In my testing RIP works fine but it's the OSPF that gives the problem.


Thanks


Anonymous (not verified) Thu, 04/18/2002 - 15:26
User Badges:

Here it is


Router#1(RR)


Router1#show ip bgp 172.16.65.0 255.255.255.0

BGP routing table entry for 172.16.65.0/24, version 3

Paths: (1 available, best #1, table Default-IP-Routing-Table)

Advertised to non peer-group peers:

172.16.10.2 172.16.20.1

Local, (Received from a RR-client)

172.16.1.2 from 172.16.1.2 (200.200.200.1)

Origin IGP, metric 0, localpref 100, valid, internal, synchronized, best


Router1#show ip route 172.16.65.0

Routing entry for 172.16.65.0/24

Known via "ospf 1", distance 110, metric 65, type intra area

Last update from 172.16.1.2 on Serial1, 00:09:59 ago

Routing Descriptor Blocks:

* 172.16.1.2, from 200.200.200.1, 00:09:59 ago, via Serial1

Route metric is 65, traffic share count is 1


Router1#show ip ospf database


OSPF Router with ID (172.16.220.1) (Process ID 1)



Router Link States (Area 0)


Link ID ADV Router Age Seq# Checksum Link count

172.16.100.1 172.16.100.1 620 0x80000003 0x4FD5 2

172.16.220.1 172.16.220.1 620 0x80000004 0xB3A1 6

200.200.200.1 200.200.200.1 664 0x80000002 0x60F7 4


Net Link States (Area 0)


Link ID ADV Router Age Seq# Checksum

172.16.10.1 172.16.220.1 620 0x80000001 0x59C1


Type-5 AS External Link States


Link ID ADV Router Age Seq# Checksum Tag

192.168.5.0 200.200.200.1 715 0x80000001 0xA788 0

192.168.10.0 200.200.200.1 714 0x80000001 0x70BA 0

Router#2 (Rrclient#1)



Router2#show ip bgp 172.16.65.0

BGP routing table entry for 172.16.65.0/24, version 3

Paths: (1 available, best #1, table Default-IP-Routing-Table)

Advertised to non peer-group peers:

172.16.1.1

Local

0.0.0.0 from 0.0.0.0 (200.200.200.1)

Origin IGP, metric 0, localpref 100, weight 32768, valid, sourced, local, best



Router2#show ip route 172.16.65.0

Routing entry for 172.16.65.0/24

Known via "connected", distance 0, metric 0 (connected, via interface)

Routing Descriptor Blocks:

* directly connected, via Loopback100

Route metric is 0, traffic share count is 1


Router2#show ip ospf database


OSPF Router with ID (200.200.200.1) (Process ID 1)



Router Link States (Area 0)


Link ID ADV Router Age Seq# Checksum Link count

172.16.100.1 172.16.100.1 744 0x80000003 0x4FD5 2

172.16.220.1 172.16.220.1 743 0x80000004 0xB3A1 6

200.200.200.1 200.200.200.1 786 0x80000002 0x60F7 4


Net Link States (Area 0)


Link ID ADV Router Age Seq# Checksum

172.16.10.1 172.16.220.1 743 0x80000001 0x59C1


Type-5 AS External Link States


Link ID ADV Router Age Seq# Checksum Tag

192.168.5.0 200.200.200.1 837 0x80000001 0xA788 0

192.168.10.0 200.200.200.1 837 0x80000001 0x70BA 0






Router-3(Rrclient#2)



Router-3#show ip bgp 172.16.65.0 255.255.255.0

BGP routing table entry for 172.16.65.0/24, version 0

Paths: (1 available, no best path)

Not advertised to any peer

Local

172.16.1.2 (metric 70) from 172.16.10.1 (200.200.200.1)

Origin IGP, metric 0, localpref 100, valid, internal, not synchronized

Originator: 200.200.200.1, Cluster list: 172.16.220.1


Router-3#show ip route 172.16.65.0

Routing entry for 172.16.65.0/24

Known via "ospf 1", distance 110, metric 71, type intra area

Last update from 172.16.10.1 on TokenRing0, 00:14:22 ago

Routing Descriptor Blocks:

* 172.16.10.1, from 200.200.200.1, 00:14:22 ago, via TokenRing0

Route metric is 71, traffic share count is 1


Router-3#show ip ospf database


OSPF Router with ID (172.16.100.1) (Process ID 1)



Router Link States (Area 0)


Link ID ADV Router Age Seq# Checksum Link count

172.16.100.1 172.16.100.1 886 0x80000003 0x4FD5 2

172.16.220.1 172.16.220.1 887 0x80000004 0xB3A1 6

200.200.200.1 200.200.200.1 931 0x80000002 0x60F7 4


Net Link States (Area 0)


Link ID ADV Router Age Seq# Checksum

172.16.10.1 172.16.220.1 887 0x80000001 0x59C1


Type-5 AS External Link States


Link ID ADV Router Age Seq# Checksum Tag

192.168.5.0 200.200.200.1 983 0x80000001 0xA788 0

192.168.10.0 200.200.200.1 982 0x80000001 0x70BA 0


cantoron Thu, 04/18/2002 - 19:21
User Badges:

No. The router id is not matched yet. For Router3, The BGP router id is the RR's ID, not the Originator router id. So it is different.

There are something you can do.

1. Do not use ospf;

or

2. In your case, all router are physical full meshed( Am I right?), so you can do in the RR with this command ' no bgp client-to-client reflection', and definde bgp neighbor in both RR-client.


Are there any choice? Please let me know if it work. Thanks

Anonymous (not verified) Thu, 04/18/2002 - 19:56
User Badges:

HI,

I am sorry but I am not sure what you mean by router id is not matched for Router3.

If i do "show ip bgp" and "show ip ospf " i am seeing the same Router-id.


As you said if i use RIP as IGP it works fine. I am not sure why it doesn't work with OSPF. Would you be able to explain why?


The problem is very easy to reproduce.


Thanks

cantoron Thu, 04/18/2002 - 20:05
User Badges:

From: http://www.cisco.com/warp/public/459/25.shtml,

'If the matching route is learned from an OSPF neighbor, its OSPF router ID must match the BGP router ID of the iBGP neighbor.'

The router id here concerned is router where the route learned from, not the router itself.

So for your case, the BGP ID is RR' router ID, OSPF ID is Router2' ID.


Note: I am looking for a networking job and cannot practice. So if I am wrong, please let me know. Thanks

Anonymous (not verified) Thu, 04/18/2002 - 20:18
User Badges:

Thanks for pointing that out.


Any solution for this? Does this mean you can not use OSPF with RR or confederation?


Thanks


seilsz Thu, 04/18/2002 - 20:41
User Badges:
  • Bronze, 100 points or more

Disable BGP synchronization.

Anonymous (not verified) Thu, 04/18/2002 - 20:51
User Badges:

That is one of few workarounds that i don't want to try right now.


Thanks

Actions

This Discussion