cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
887
Views
0
Helpful
4
Replies

ISDN Connection Drops and Restarts

julian.coelho
Level 1
Level 1

We have configured an ISDN BRI port on a 1600 series router to call another ISDN BRI port using dialer profile. The ISDN Link comes up and goes down many times per second. This can be seen in Debug. When we use Debug ISDN q931 we get the "Cause i=0x809f - normal, unspecified or Special intercept, call blocked group restriction". We have changed the ISDN line and tried on another ISDN line but the same problem exists. Appreciate help. Thanks.

4 Replies 4

tepatel
Cisco Employee
Cisco Employee

Because of interesting traffic, the router may be keep dialing out. Need to take a look for debug

debug dialer

debug isdn q931

to see why its dialing..also put the config too.

Thanks for your response. I list below the config. Appreciate any help. Thanks.

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log datetime msec

service password-encryption

!

hostname repl98

!

enable password 7 XXXXXXXXXXXXXXXXXXX

!

username XXXXXX password 7 XXXXXXXXXXXX

ip subnet-zero

no ip domain-lookup

isdn switch-type basic-net3

!

interface Ethernet0

description connected to rep LAN

ip address 192.168.98.250 255.255.255.0

no ip directed-broadcast

!

interface Serial0

description connected to s5

backup delay 1 1

backup interface Dialer1

ip address 192.168.198.1 255.255.255.0

no ip directed-broadcast

encapsulation ppp

!

interface BRI0

description ISDN connection to h2

no ip address

no ip directed-broadcast

encapsulation ppp

dialer rotary-group 1

isdn switch-type basic-net3

no fair-queue

!

interface Dialer1

description ISDN connection to h2

ip address 192.168.202.3 255.255.255.0

no ip directed-broadcast

encapsulation ppp

no ip split-horizon

dialer in-band

dialer idle-timeout 300

dialer map ip 192.168.202.2 name XXXX broadcast XXXXXXXX

dialer hold-queue 10

dialer load-threshold 10 either

dialer-group 1

no fair-queue

ppp authentication chap

ppp multilink

!

router eigrp 100

network 192.168.98.0

network 192.168.202.0

no auto-summary

!

ip classless

!

dialer-list 1 protocol ip permit

snmp-server community public RO

!

line con 0

exec-timeout 0 0

password 7 XXXXXXXXXXXXX

login

transport input none

line vty 0 4

password 7 XXXXXXXXXXXXX

login

!

end

From the config, Eigrp is the strong cendidate which will bring up the line. May be (assuming without debug) because of connection was not successful it keeps trying to dialout again everytime it needs to send the hello packet over..

Now..need to have following debug to fid the problem

debug dialer

debug ppp negotiation

debug isdn q931

debug ppp authentication

Thanks for your help. I used all 4 debugs and got the following output:

2d21h: BRI0 DDR: rotor dialout [priority]

2d21h: BRI0 DDR: Dialing cause ip (s=192.168.202.3, d=224.0.0.10)

2d21h: BRI0 DDR: Attempting to dial XXXXXXXX

*Mar 3 21:02:51.960: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0, TEI 64 changed to up

2d21h: ISDN BR0: TX -> SETUP pd = 8 callref = 0x24

2d21h: Bearer Capability i = 0x8890

2d21h: Channel ID i = 0x83

2d21h: Called Party Number i = 0x80, ' XXXXXXXX'

2d21h: ISDN BR0: RX <- CALL_PROC pd = 8 callref = 0xA4

2d21h: Channel ID i = 0x89

2d21h: ISDN BR0: RX <- CONNECT pd = 8 callref = 0xA4

*Mar 3 21:02:52.900: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up

*Mar 3 21:02:52.924: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to XXXXXXXX

2d21h: BR0:1 PPP: Treating connection as a callout

2d21h: BR0:1 PPP: Phase is ESTABLISHING, Active Open

2d21h: BR0:1 LCP: O CONFREQ [Closed] id 81 len 28

2d21h: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

2d21h: BR0:1 LCP: MagicNumber 0x3F8480E7 (0x05063F8480E7)

2d21h: BR0:1 LCP: MRRU 1524 (0x110405F4)

2d21h: BR0:1 LCP: EndpointDisc 1 Local (0x1309017265706C3938)

2d21h: ISDN BR0: TX -> CONNECT_ACK pd = 8 callref = 0x24

2d21h: ISDN BR0: RX <- DISCONNECT pd = 8 callref = 0xA4

2d21h: Cause i = 0x809F - Normal, unspecified or Special intercept, call blocked group restriction

*Mar 3 21:02:52.988: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down

2d21h: DDR: Call disconnected, 1 packets unqueued and discarded

2d21h: BR0:1 LCP: State is Closed

2d21h: BR0:1 PPP: Phase is DOWN

2d21h: BRI0:1 DDR: disconnecting call

2d21h: ISDN BR0: TX -> RELEASE pd = 8 callref = 0x24

2d21h: ISDN BR0: RX <- STATUS pd = 8 callref = 0xA4

2d21h: Cause i = 0x829F - Normal, unspecified or Special intercept, call blocked group restriction

2d21h: Call State i = 0x0C

2d21h: ISDN BR0: RX <- RELEASE_COMP pd = 8 callref = 0xA4

*Mar 3 21:02:53.571: %LINK-3-UPDOWN: Interface Dialer1, changed state to up

2d21h: BRI0 DDR: rotor dialout [priority]

2d21h: BRI0 DDR: Dialing cause ip (s=192.168.202.3, d=224.0.0.10)

2d21h: BRI0 DDR: Attempting to dial XXXXXXXX

2d21h: ISDN BR0: TX -> SETUP pd = 8 callref = 0x25

2d21h: Bearer Capability i = 0x8890

2d21h: Channel ID i = 0x83

2d21h: Called Party Number i = 0x80, ' XXXXXXXX '

2d21h: ISDN BR0: RX <- CALL_PROC pd = 8 callref = 0xA5

2d21h: Channel ID i = 0x89

2d21h: ISDN BR0: RX <- CONNECT pd = 8 callref = 0xA5

*Mar 3 21:02:56.964: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up

*Mar 3 21:02:56.987: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to XXXXXXX

2d21h: BR0:1 PPP: Treating connection as a callout

2d21h: BR0:1 PPP: Phase is ESTABLISHING, Active Open

2d21h: BR0:1 LCP: O CONFREQ [Closed] id 82 len 28

2d21h: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

2d21h: BR0:1 LCP: MagicNumber 0x3F8490E8 (0x05063F8490E8)

2d21h: BR0:1 LCP: MRRU 1524 (0x110405F4)

2d21h: BR0:1 LCP: EndpointDisc 1 Local (0x1309017265706C3938)

2d21h: ISDN BR0: TX -> CONNECT_ACK pd = 8 callref = 0x25

2d21h: ISDN BR0: RX <- DISCONNECT pd = 8 callref = 0xA5

2d21h: Cause i = 0x809F - Normal, unspecified or Special intercept, call blocked group restriction

*Mar 3 21:02:57.047: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down

2d21h: DDR: Call disconnected, 1 packets unqueued and discarded

2d21h: BR0:1 LCP: State is Closed

2d21h: BR0:1 PPP: Phase is DOWN

2d21h: BRI0:1 DDR: disconnecting call

2d21h: ISDN BR0: TX -> RELEASE pd = 8 callref = 0x25

2d21h: ISDN BR0: RX <- STATUS pd = 8 callref = 0xA5

2d21h: Cause i = 0x829F - Normal, unspecified or Special intercept, call blocked group restriction

2d21h: Call State i = 0x0C

2d21h: ISDN BR0: RX <- RELEASE_COMP pd = 8 callref = 0xA5

2d21h: BRI0 DDR: rotor dialout [priority]

2d21h: BRI0 DDR: Dialing cause ip (s=192.168.202.3, d=224.0.0.10)

2d21h: BRI0 DDR: Attempting to dial XXXXXXXX

2d21h: ISDN BR0: TX -> SETUP pd = 8 callref = 0x26

2d21h: Bearer Capability i = 0x8890

2d21h: Channel ID i = 0x83

2d21h: Called Party Number i = 0x80, 'XXXXXXXX'

2d21h: ISDN BR0: RX <- CALL_PROC pd = 8 callref = 0xA6

2d21h: Channel ID i = 0x89

2d21h: ISDN BR0: RX <- CONNECT pd = 8 callref = 0xA6

*Mar 3 21:03:01.864: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up

*Mar 3 21:03:01.888: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to XXXXXXX

2d21h: BR0:1 PPP: Treating connection as a callout

2d21h: BR0:1 PPP: Phase is ESTABLISHING, Active Open

2d21h: BR0:1 LCP: O CONFREQ [Closed] id 83 len 28

2d21h: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

2d21h: BR0:1 LCP: MagicNumber 0x3F84A435 (0x05063F84A435)

2d21h: BR0:1 LCP: MRRU 1524 (0x110405F4)

2d21h: BR0:1 LCP: EndpointDisc 1 Local (0x1309017265706C3938)

2d21h: ISDN BR0: TX -> CONNECT_ACK pd = 8 callref = 0x26

2d21h: ISDN BR0: RX <- DISCONNECT pd = 8 callref = 0xA6

2d21h: Cause i = 0x809F - Normal, unspecified or Special intercept, call blocked group restriction

*Mar 3 21:03:01.932: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down

2d21h: DDR: Call disconnected, 1 packets unqueued and discarded

2d21h: BR0:1 LCP: State is Closed

2d21h: BR0:1 PPP: Phase is DOWN

2d21h: BRI0:1 DDR: disconnecting call

2d21h: ISDN BR0: TX -> RELEASE pd = 8 callref = 0x26

2d21h: ISDN BR0: RX <- STATUS pd = 8 callref = 0xA6

2d21h: Cause i = 0x829F - Normal, unspecified or Special intercept, call blocked group restriction

2d21h: Call State i = 0x0C

2d21h: ISDN BR0: RX <- RELEASE_COMP pd = 8 callref = 0xA6

2d21h: BRI0 DDR: rotor dialout [priority]

2d21h: BRI0 DDR: Dialing cause ip (s=192.168.202.3, d=224.0.0.10)

2d21h: BRI0 DDR: Attempting to dial XXXXXX

2d21h: ISDN BR0: TX -> SETUP pd = 8 callref = 0x27

2d21h: Bearer Capability i = 0x8890

2d21h: Channel ID i = 0x83

2d21h: Called Party Number i = 0x80, 'XXXXXXX'

2d21h: ISDN BR0: RX <- CALL_PROC pd = 8 callref = 0xA7

2d21h: Channel ID i = 0x89

2d21h: ISDN BR0: RX <- CONNECT pd = 8 callref = 0xA7

*Mar 3 21:03:06.443: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up

*Mar 3 21:03:06.467: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to XXXXXXX

2d21h: BR0:1 PPP: Treating connection as a callout

The line restarts every few seconds. Appreciate your help.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: