×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

SetVolume

Unanswered Question
Jun 11th, 2002
User Badges:
  • Bronze, 100 points or more

I have tried to use the setvolume utility on two seperate unity 3.1(3) servers and have received the same SQL script error both times. Am I doing the same thing wrong? Do I have incorrect permissions? please let me know.<br><br>

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Anonymous (not verified) Tue, 06/11/2002 - 01:15
User Badges:

The error message after running as local administrator or the installation account used for unity is as follows:

"Synchronization between SQL and the directory failed. Check the log for details."

The information from SqlSync_3d0666e9.txt is as follows:

Tue Jun 11 16:08:57.71 Entering Initialize \ConnectorClientBase.cpp (line 48)

Tue Jun 11 16:08:57.87 Failed CoCreating IID_IAvDSConfig {AvDsAD.AvDsAD.1} Exiting Function. 0x80004002 \ConnectorClientBase.cpp (line 78)

Tue Jun 11 16:08:57.87 Failed to initlalize DbSync. 0x80004002 \DbSync.cpp (line 208)

Anonymous (not verified) Tue, 06/11/2002 - 01:49
User Badges:

that error is the syncher complaining that the monitor interface isn't available... which is odd. Is the AvDSAD service running on your box? Do you get the same error in the syncher logs if you force the synch to kick off manually by running the configuration setup (part 2 setup) with the "/sync" command line?


Jeff Lindborg
Unity Technical Lead/Answer Monkey
Cisco Systems
[email protected]
http://www.AnswerMonkey.net (new page for Unity support tools and scripts)

Anonymous (not verified) Wed, 06/12/2002 - 06:49
User Badges:

Does running configuration setup in /sync mode affect Unity as far as taking it out of Production or requiring a reboot?



Anonymous (not verified) Wed, 06/12/2002 - 07:04
User Badges:

no, all the synch does is run through the SQL database for subscribers and distribution lists and make sure those users are in the directory. If they're not in the directory at all they'll be created, if they are in the directory they'll be referenced by their unique directory Id in our local SQL database.

Normally not something you need to but I'm curious if the syncher component is having trouble just in general or more specifically for the way we're calling it. I suspect the montior interface is having a problem across the boards and you'll see the same error.


Jeff Lindborg
Unity Technical Lead/Answer Monkey
Cisco Systems
[email protected]
http://www.AnswerMonkey.net (new page for Unity support tools and scripts)

bcarpenter Wed, 06/12/2002 - 07:09
User Badges:

The strange thing about this is that I had the problem on two seperate unity servers in the same situation. This is the case of taking one unity server down, and rebuilding it (using almost all of your tools, thank you) on another brand new, more powerful box. I guess that's where I'm most confused. I will check both of these suggestions out and reply back in the forum asap.


Brian Carpenter
Systems Engineer
General Datatech, l.p.
[email protected]

bcarpenter Thu, 06/13/2002 - 06:45
User Badges:

Well, we solved the problem without being smart enough to actually FIX anything. With the release of 3.1(4), we decided to upgrade Unity. Unity 3.1(4) came with SetVolume that seems to have a different interface than the program we were downloading from answermonkey or cco. This updated utility worked correctly and the sync ran without issue.

Hopefully or blind luck will shed some light on the issue?

Brian Carpenter
Systems Engineer
General Datatech, l.p.
[email protected]

Anonymous (not verified) Thu, 06/13/2002 - 07:01
User Badges:

3.1.(4) has an updated SQLSyncher... there may have been a problem there but it runs fine on all the 3.1(3) test systems I have so I'm not quite sure what the deal was. The SetVolume on AnswerMonkey should be the same version shipping with 3.1(4) today.

Jeff Lindborg
Unity Technical Lead/Answer Monkey
Cisco Systems
[email protected]
http://www.AnswerMonkey.net (new page for Unity support tools and scripts)

Anonymous (not verified) Tue, 06/11/2002 - 06:56
User Badges:

There's no SQL scripts being run in the Set Volume utility... I suspect you are not logged in locally as a member of the local Administrators group (necessary for read/write access to the UnityDB database). That's just a guess without information about the specific message you're seeing.


Jeff Lindborg
Unity Technical Lead/Answer Monkey
Cisco Systems
[email protected]
http://www.AnswerMonkey.net (new page for Unity support tools and scripts)

Actions

This Discussion