cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
265
Views
0
Helpful
1
Replies

Configuration for ISDN PRI for backup leased line

admin_2
Level 3
Level 3

I have done a configuration for E1 ISDN PRI backup for my leased line to my client office.I have done for BRI backup but not sure for PRI. Is my config below is correct?

_______________________________________

Office Router :-

isdn switch-type primary-net5

!

controller E1 1/0

pri-group timeslots 1-30

!

int s0/0

description # lease line to client #

ip address 192.168.200.1 255.255.255.252

backup delay 10 2

backup interface Dialer1

encapsulation ppp

!

int e0/0

description # internal lan connection #

ip address xxx.xxx.xxx.xxx 255.255.255.0

!

int s1/0:15

description # backup link to Client #

no ip address

encapsulation ppp

isdn switch-type primary-net5

dialer pool-member 1

ppp authentication chap

!

interface Dialer1

description # backup link to Client #

ip unnumbered Serial0/0

encapsulation ppp

dialer remote-name CLIENT

dialer string xxxxxxxx

dialer pool 1

dialer load-threshold 1

dialer-group 1

ppp authentication chap

ppp multilink

!

ip classless

ip route xxx.xxx.xxx.xxx 255.255.255.0 Serial0/0

ip route xxx.xx.xxx.xxx

255.255.255.0 Dialer1 2

!

access-list 1 permit any

dialer-list 1 protocol ip permit

!

_______________________________________

Client router :-

isdn switc-type primary-net5

!

controller E1 1/0

pri-group timeslots 1-30

!

int s0/0

description # lease line to My Office #

ip address 192.168.200.2 255.255.255.252

backup delay 10 2

backup interface Dialer1

encapsulation ppp

!

int e0/0

description # Client internal lan connection #

ip address xxx.xxx.xxx.xxx 255.255.255.0

!

int s1/0:15

description # backup link to My Office#

no ip address

encapsulation ppp

isdn switch-type primary-net5

dialer pool-member 1

ppp authentication chap

!

interface Dialer1

description # backup link to My Office#

ip unnumbered Serial0/0

encapsulation ppp

dialer remote-name MyOffice

dialer string xxxxxxxx

dialer pool 1

dialer load-threshold 1

dialer-group 1

ppp authentication chap

ppp multilink

!

ip classless

ip route xxx.xxx.xxx.xxx

255.255.255.0 Serial0/0

ip route xxx.xxx.xxx.xxx

255.255.255.0 Dialer1 2

!

access-list 1 permit any

dialer-list 1 protocol ip permit

!

1 Reply 1

Not applicable

On the routers you should not

use IP unnumbered to serial 0/0, since

if that interface goes down that address

may not be useable. You can apply the

address to a loopback interface, and let

the serial and dialer interfaces use it.

You shouldn't use the backup command

on both sides; if the line goes down, you

only want one end to initiate the connection;

otherwise, there is a chance that both

will try to call each other.

For that same reason, you should probably

only have one side with a phone number to

dial, to avoid contention with the dialing.